1. DizWhiz's Avatar
    Lately it seems anywhere I go I get a WiFi notification for TWI/xfinity WiFi to sign in with my account credentials. The issue is that my data stops working until I turn WiFi off in settings when it tries to connect. Anyone else run into this?

    Posted via the Android Central App
    03-01-2016 12:26 AM
  2. B. Diddy's Avatar
    Do you need the phone to remember that hotspot? If not, go to Settings>Wi-fi​, long-press that network, and tap Forget.
    03-01-2016 01:18 PM
  3. DizWhiz's Avatar
    Thanks, I've tried that but it's pretty much anywhere in my area. We used to have Att Hotspots but now stores and restaurants switched to this csblefi system. Short version it's not just one location

    Posted via the Android Central App
    03-02-2016 01:14 PM
  4. B. Diddy's Avatar
    But if you Forget the network, it shouldn't connect automatically, right? It'll show it in your available network list, but it shouldn't connect unless you tap it, after which you'd have to enter your Xfinity account information again at the login page.
    Laura Knotek likes this.
    03-02-2016 09:12 PM
  5. DizWhiz's Avatar
    Thanks I just told it to forget both types (Comcast and TWI) I'll see if it continues.

    Posted via the Android Central App
    03-06-2016 04:10 PM
  6. Laura Knotek's Avatar
    What I've done is turn off automatic notifications for Wi-Fi networks.
    03-06-2016 04:17 PM
  7. Lok52's Avatar
    What I've done is turn off automatic notifications for Wi-Fi networks.
    https://uploads.tapatalk-cdn.com/2016...12ce4e401e.jpg
    That just stupid it from telling you there are networks available. It should still connect to any that are already in its list.

    Posted via Android Central App
    03-07-2016 07:55 AM
  8. B. Diddy's Avatar
    Do you have the Xfinity Wifi app installed? That might be causing it to automatically connect.
    03-07-2016 10:43 AM
  9. Dennis Janson's Avatar
    But if you Forget the network, it shouldn't connect automatically, right? It'll show it in your available network list, but it shouldn't connect unless you tap it, after which you'd have to enter your Xfinity account information again at the login page.
    I have the same problem ever since that last update. Forgetting the network is not working. It tries to reconnect to it anyway. Then when it doesn't get online my wifi just shuts off, instead of connecting to my password protected wifi. Samsung really messed up their software ever since they tried adding the smart switch. I have all of those options turned off and it still connects to networks I never told it to connect to.
    08-13-2016 07:25 AM
  10. B. Diddy's Avatar
    Welcome to Android Central! Which phone do you have?
    08-14-2016 02:16 PM
  11. revitupmx5's Avatar
    Its annoying. I have a Tasker program to turn off Wi-fi whenever I leave home. And come back on when I return. If I want Wi-fi when at Starbuck's I turn it on. And turn it off when I go.
    08-15-2016 05:11 AM
  12. corwyn74's Avatar
    This exact thing started happening a few weeks or so ago to me too, always connecting to xfinitywifi but it is "Connected, no internet". I am right next to my home router but it connects to the xfinitywifi hotspot with no internet instead. I have told it to forget that network and it continues to try to connect!
    10-31-2016 04:46 PM
  13. revitupmx5's Avatar
    2 things, either it's looking for a password. You have to shut off wifi when you leave your home, and turn it on when you return.
    11-01-2016 04:47 PM
  14. B. Diddy's Avatar
    I have told it to forget that network and it continues to try to connect!
    Which phone do you have? Go to Settings>Wi-fi​, tap Menu>Advanced, and see if there is an option to automatically connect to open networks.
    11-01-2016 05:56 PM
  15. revitupmx5's Avatar
    Any Android phone can install Tasker. As I said a short Tasker progream can turn off Wi-Fi when you leave home and turn Wi-Fi on when returning.
    I understand your frustration and I still get that Starbucks automatic connection. Maybe because I use it every day and enable it, but that damn xfinitywifi used to connect every damn time I went out and I never see it anymore.
    I hope that helps
    11-01-2016 07:20 PM
  16. southsam7's Avatar
    Do you have the Xfinity Wifi app installed? That might be causing it to automatically connect.
    No dummy it auto connects many users and we don't have the xfinity app. Try again
    11-24-2016 05:56 PM
  17. B. Diddy's Avatar
    No dummy it auto connects many users and we don't have the xfinity app. Try again
    Hmm. How does my suggestion make me a dummy when it's a potential cause for some users? Perhaps you could give more details about your situation, and I can try to avoid being a dummy in my answer to you.

    If you've ever connected to an xfinitywifi hotspot, the phone will try to connect if it encounters another one, assuming your wi-fi is on and not already connected to a stronger network. If you don't want it to auto-connect, then forget the xfinitywifi network in your wi-fi settings.
    11-24-2016 11:44 PM

Similar Threads

  1. How to make Android like a BlackBerry?
    By jason9900 in forum General News & Discussion
    Replies: 12
    Last Post: 04-02-2016, 09:06 PM
  2. Best free way to develop an Android app for showcasing art
    By MisterJanuary in forum Android Apps
    Replies: 3
    Last Post: 03-08-2016, 08:10 AM
  3. Where did the app I downloaded to my HTC One go?
    By AC Question in forum HTC One Series
    Replies: 1
    Last Post: 03-01-2016, 01:23 PM
  4. Google unable to refund Nexus 6P
    By esuser1 in forum Nexus 6P
    Replies: 4
    Last Post: 03-01-2016, 10:50 AM
  5. Migrate sms from Window phone to Android?
    By tuannguyenht in forum General Help and How To
    Replies: 0
    Last Post: 03-01-2016, 12:19 AM
LINK TO POST COPIED TO CLIPBOARD