1. BicknellBees's Avatar
    I have recently up graded my HTC M7 to the M9, I love both phones, however I am having a problem with my M9

    If I have wi-fi and 4g on my phone it will not send or receive text messages, if I keep the wi-fi on and set the phone to 3g it does.

    The phone will not send if set to 4g only but will if on 2 or 3g.

    I have replaced the sim card and done a full re - set on the phone none of which made a difference, I am with Vodafone UK and the 4g signal is only 2 bars, but my wife's I - phone (also with Vodafone) does not have this problem.

    As I pay for 4g I do really want to be able to use it, I also do not want to keep switching manually between 3 and 4g

    I am not very techie and have never had a problem with a phone before. Any help / advice would be greatly appreciated.

    Ian G
    05-10-2015 11:12 AM
  2. NadaAddict's Avatar
    Your phone uses the actual phone connection to send sms messages, not data.

    Posted via the Android Central App
    05-10-2015 04:23 PM
  3. BicknellBees's Avatar
    Thanks for the reply..................I now understand that 4g is for data, however I still have an issue that when my phone has a 4g signal it will not send or receive texts, Carphone Warehouse say it is a Vodafone issue and Vodafone say there is no issue! Having now gone through everything with the service provider I am wondering if the problem could be with the phone not working correctly or a software issue. Again thanks for the response any help is appreciated.
    05-11-2015 04:54 AM
  4. NadaAddict's Avatar
    Ugh... That's a weird one... No clue. Good luck though!

    Posted via the Android Central App
    05-11-2015 06:24 PM
  5. BicknellBees's Avatar
    Thanks, I have now handed it back to Vodafone.......................Hopefully they can fix it!
    05-13-2015 08:32 AM
  6. Stephen Murt's Avatar
    I am also having a similar issue!
    (M9, on Vodafone UK).
    If I'm at home, on WiFi and in a 4G signal (only sometimes, just on the edge of signal at home) , and want to send a text, I regularly get a ' unable to send text after multiple attempts' message with a red triangle in the text.
    I have been told that some texts I send are arriving up to fifteen minutes after I send?
    This is ONLY when at home on 4G, never anywhere else, and never if only on 3G.

    I found that if I turn the phone off, then back on, the messages send immediately.

    Local Voda shop said they had not heard of the problem, and said it could be my lack of signal.... Obviously not!
    05-13-2015 04:14 PM
  7. BicknellBees's Avatar
    This may sound an odd thing to say but I am so glad somebody else has this issue (please take that the way it's intended!), Vodafone made me feel like I was the only person on the planet with this problem!
    What you are describing is exactly the problem I am having. As I have previously said I have now given the phone back for the Vodafone repair team to look at. Very happy to up date you when they give it back to me.

    Up date: My phone was replaced and over the weekend I had no problems
    Stephen Murt likes this.
    05-15-2015 05:16 AM

Similar Threads

  1. Replies: 2
    Last Post: 05-10-2015, 02:49 PM
  2. Replies: 0
    Last Post: 05-10-2015, 11:08 AM
  3. Replies: 1
    Last Post: 05-10-2015, 10:42 AM
  4. How can I pair my lg G3 with my iPad Air2?
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 05-10-2015, 10:12 AM
LINK TO POST COPIED TO CLIPBOARD