1. playaz's Avatar
    Lately I've started noticing that during the nights when my phone is idling, the gmail push notifications are not coming in, and are only delivered in the mornings immediately after waking the phone.

    Is this a bug in gmail or is this something I can fix manually and how'?
    04-25-2016 09:21 PM
  2. PapaGary's Avatar
    Under Settings>Sounds and notifications>Do not disturb do you have Turn on as scheduled checked? If so that's the way it is supposed to work. Under Allow exceptions you can adjust what notifications come through.
    04-25-2016 09:49 PM
  3. playaz's Avatar
    Under Settings>Sounds and notifications>Do not disturb do you have Turn on as scheduled checked? If so that's the way it is supposed to work. Under Allow exceptions you can adjust what notifications come through.
    No, do not disturb is completely off, so this is not the case unfortunately.
    04-26-2016 06:13 AM
  4. foxbat121's Avatar
    Which version of OS are you running on? In Android 5.xx, there is a sleep mode in battery manager. In Android 6.0, there is a doze mode. Both do the same thing, turn off data and sync when the phone idles for too long.
    04-26-2016 08:38 AM
  5. playaz's Avatar
    I'm on 6.0

    Where should I look and disable?
    04-26-2016 08:52 AM
  6. foxbat121's Avatar
    Google for it. There are plenty of topics about it. It is the new feature of Android 6.0 OS, not specific for M9. Don't have 6.0 on my M9 yet.
    04-26-2016 11:02 AM
  7. playaz's Avatar
    Google for it. There are plenty of topics about it. It is the new feature of Android 6.0 OS, not specific for M9. Don't have 6.0 on my M9 yet.
    It was switched off, so this isn't the solution either.
    04-26-2016 09:53 PM
  8. playaz's Avatar
    Is there still no solution for this available?
    05-10-2016 09:43 PM
  9. GSDer's Avatar
    Are you using Wi-Fi or cellular data during the time that the device is asleep? If Wi-Fi, be sure you have it set to always remain connected while sleeping.
    05-11-2016 09:38 AM
  10. playaz's Avatar
    Are you using Wi-Fi or cellular data during the time that the device is asleep? If Wi-Fi, be sure you have it set to always remain connected while sleeping.
    Yes this is enabled, I already checked this. I'm using WIFI.
    05-11-2016 10:03 AM
  11. GSDer's Avatar
    Well, you could try turning WiFi off one night and see if Gmail acts as it should - if it does you'll at least be sure it has something to do with the WiFi configuration or Doze feature.

    Of course you did a Factory Reset after the update to 6.x?
    05-13-2016 10:01 PM
  12. playaz's Avatar
    I did, didn't help at all. This is doze it's unbeliavable that this can't be fixed. The other night I left it on charger and then it works normally...
    05-14-2016 05:26 AM
  13. GSDer's Avatar
    I don't see anywhere that you can modify Doze settings, and if it did this immediately after a Factory Reset then I can only assume you didn't fiddle with Battery Saver or Battery Optimization settings.

    I'd try the shotgun approach:
    1. Restart the phone immediately before going to bed and see if the problem still occurs
    2. If that doesn't make any difference, reboot into Safe Mode immediately before going to bed and see if the problem still occurs

    If all else fails, plug the phone in before going to bed and wait for the next OS update
    05-14-2016 04:41 PM
  14. Golfdriver97's Avatar
    If Doze is having an effect, there should be an option to whitelist it under battery optimization settings. Look in Settings>Battery>menu.
    Laura Knotek likes this.
    05-14-2016 07:53 PM
  15. foxbat121's Avatar
    Reading a bit about Doze. Here are my findings:
    1. Doze can't be turned off. But you can create application exceptions for individual applications.
    2. Doze only kicks in when you are not touching the phone AND not plugged in.
    3. When doze kicks in, network access will be blocked and delayed.

    So, the simple solution to OP is simply plug in to AC charge when you go to bed. If you already doing that, it is not the problem caused by Doze mode. GMail always has its own mind, in my past experience, and Google never let you modify or change sync options (push or manual or scheduled poll).
    05-16-2016 07:47 AM

Similar Threads

  1. Yahoo! Sports - Some logos not displayed
    By Vucko in forum Samsung Galaxy S7 edge
    Replies: 3
    Last Post: 09-03-2016, 08:07 PM
  2. Led flash not working
    By Garrick Sprockel in forum Samsung Galaxy S4
    Replies: 5
    Last Post: 04-30-2016, 01:17 AM
  3. Replies: 2
    Last Post: 04-26-2016, 04:44 PM
  4. Replies: 6
    Last Post: 04-26-2016, 04:38 PM
  5. Why is my MacroDroid Macro not working on my Droid Max
    By AC Question in forum Ask a Question
    Replies: 0
    Last Post: 04-25-2016, 07:48 PM
LINK TO POST COPIED TO CLIPBOARD