1. melody96's Avatar
    I just tried opening a PDF file and it came up with something asking what I wanted to open it with, I can't remember the app I chose but it came up with 2 options - "always" or "just once" I pressed "always" and it turns out the app won't open my file. Since I chose "always" everytime I try to open a PDF file it tries to open with that app but it doesn't work so now I can't open PDF files on my phone
    I tried looking for the app in my app list to clear defaults but I can't find it, I've cleared defaults for every app I think it might be and I even reset my app preferences but I still can't open any PDF files

    This is a screenshot of what it looks like when I try to open a PDF file from the internet app https://i.imgur.com/RafVCML.jpg this pops up for one second and then jumps back to my browser
    10-14-2017 04:46 PM
  2. B. Diddy's Avatar
    Welcome to Android Central! Try wiping the cache partition: https://support.t-mobile.com/docs/DOC-31522
    10-14-2017 10:59 PM
  3. Javier P's Avatar
    Welcome to the forums. Also, you could try installing a new PDF reader app from the Play Store. Next time you try to open a PDF file the system should detect the new option and show the selection menu again.
    B. Diddy likes this.
    10-15-2017 07:42 AM
  4. melody96's Avatar
    Do you know what exactly this clears? I'm a bit worried it'll clear some things I don't want cleared
    10-15-2017 06:02 PM
  5. melody96's Avatar
    I just tried this, unfortunately it didn't show the selection menu again
    10-15-2017 06:03 PM
  6. Javier P's Avatar
    Which browser are you using? Do you get the same problem if you try to open a PDF from a different one, like Chrome or Firefox?
    10-15-2017 07:11 PM
  7. B. Diddy's Avatar
    Do you know what exactly this clears? I'm a bit worried it'll clear some things I don't want cleared
    The cache partition only contains temporary data -- nothing crucial.
    10-15-2017 09:42 PM
  8. melody96's Avatar
    I'm using the Internet browser and no, it works fine on Google Chrome
    10-16-2017 06:04 AM
  9. Javier P's Avatar
    I'm using the Internet browser and no, it works fine on Google Chrome
    It sounds like the cause of the problem is some setting or default changed in the browser, then. You could try clearing defaults for that browser or even clearing data from settings - apps - select the browser.
    10-16-2017 12:24 PM
  10. melody96's Avatar
    I did the settings - app - browser - clear defaults last time and just tried browser settings (3 dots on top right corner of browser) - settings - advanced settings - reset to default but it's still not working
    10-16-2017 03:37 PM

Similar Threads

  1. After upgrading to Oreo, I can't use my mobile data to access the Internet.
    By Android Central Question in forum Ask a Question
    Replies: 5
    Last Post: 08-13-2018, 03:19 PM
  2. Replies: 0
    Last Post: 10-14-2017, 04:38 PM
  3. Make shortcuts default on drop down menu
    By Android Central Question in forum Ask a Question
    Replies: 0
    Last Post: 10-14-2017, 04:33 PM
  4. Replies: 1
    Last Post: 10-14-2017, 04:29 PM
  5. where is the System UI Tuner?
    By Android Central Question in forum Ask a Question
    Replies: 1
    Last Post: 10-14-2017, 04:20 PM
LINK TO POST COPIED TO CLIPBOARD