1. LifeInLaralay's Avatar
    I've almost filled up my internal memory of my HTC One Mini (not rooted or anything) so I purchased the Meenova Mini MicroSD card reader to slot in my MicroSD. Well as soon as I slotted it in, I got "Preparing USB Storage" but then it immediately went to "USB Storage is safe to remove" and then "USB Storage Removed" and then it will continue to cycle through like this. I tried to mount it manually in settings, same thing. I checked ES File Explorer to see if it was just being a jerk, but alas, the card was not there.
    So I tried reformatting the MicroSD on my computer - using the same card reader with an adapter - it works absolutely fine on the computer and I've tried it on both Mac and PC. Anyway, I reformatted it (FAT32) hoping it would solve the problem, but again the same thing happened. I turned the phone off and on again, I said please, I told it that it was pretty, I tried to bribe it with money. No luck.
    So I tried googling the specific Reader, with the specific device, and basically found that, as far as I can see, I've done everything correctly and it should work. But it doesn't.

    I downloaded the OTG Troubleshooter to my phone,
    It continuously flashes between these two screens when the reader is connected;
    01-31-2014 06:32 PM
  2. Nick Davey's Avatar
    Did you get this resolved I have the same issues. !
    02-03-2014 02:09 PM
  3. Wizardsden's Avatar
    I have the exact same issue, though I think it might be carrier specific. When I connect any USB storage device to the OTG cable on my Verizon Galaxy S3, it immediately unmounts. Keyboard and mouse work fine. I can connect the same USB drive using the same adapter to my Wife's Cricket Galaxy S3, and it works perfectly. Both phones are running Android 4.3.
    02-05-2014 11:45 PM

Similar Threads

  1. Is this normal charging behavior?
    By someguy01234 in forum Moto X (2013)
    Replies: 7
    Last Post: 02-12-2014, 05:53 PM
  2. PSA: Ebony Natural Moto X trim material is metal
    By Papadakis in forum Moto X (2013)
    Replies: 17
    Last Post: 02-11-2014, 10:49 AM
  3. Chromecast only working when USB is plugged into computer?
    By omahamatt in forum Google Chromecast
    Replies: 3
    Last Post: 02-01-2014, 10:44 AM
  4. Where is ZTE Radiant ?
    By escorbar23 in forum Other ZTE Android Phones
    Replies: 1
    Last Post: 01-31-2014, 06:21 PM
  5. HTC Desire 500 files question
    By alexander888 in forum Android 4.1 / 4.2 / 4.3 Jelly Bean
    Replies: 2
    Last Post: 01-31-2014, 04:30 PM