1. Technology Geek's Avatar
    So I'm a bit stuck. I can ONLY boot into the bootloader/fastboot. Using fastboot I tried flashing recovery. It will flash a recovery fine (tried TWRP, CWM, stock) but when you boot to recovery you get the HTC splash screen and then it hangs. For quite a while I was worried I had a bad image. But after a little more searching I found out I had some corrupt information. Model ID and Serial # appear to be really messed up.

    # fastboot getvar mid
    mid: �
    finished. total time: 0.002s
    # fastboot getvar serialno
    serialno: ߞ�X�C
    w\	`2�#
    finished. total time: 0.002s
    I tried to re-write my serial number and model ID, but I guess it won't work because I don't have the ENG hboot.

    fastboot oem writemid PN07120
    (bootloader) [ERR] Command error !!!
    OKAY [  0.012s]
    finished. total time: 0.012s
    Another thing that is interesting is that version-misc shows UNKNOWN. (which is the 1st line after *** UNLOCKED *** on the boot/fastboot screen)

    (bootloader) version-misc: UNKNOWN SHIP S-OFF

    I've tried looking for the ENG hboot but cannot find it. Anyone know where it is? I've got the HTC One Developer Edition

    EDIT: Looks like I found a site that had it.

    EDIT: Bah! Catch 22 here. Can't flash new hboot because model ID doesn't match.

    # fastboot flash zip ENG_hboot.zip 
    sending 'zip' (475 KB)...
    OKAY [  0.242s]
    writing 'zip'...
    (bootloader) zip header checking...
    (bootloader) zip info parsing...
    (bootloader) checking model ID...
    FAILED (remote: 41 model id check fail)
    finished. total time: 0.648s
    02-18-2014 10:49 AM
  2. FreedomHacks's Avatar

    Sorry to resurrect an old thread but I have the same issue on my M8. Ever have any resolution to this problem??
    04-19-2015 05:03 AM
  3. benny3's Avatar

    Sorry to resurrect an old thread but I have the same issue on my M8. Ever have any resolution to this problem??
    Same issue? what are you wanting to do and what have you did?
    04-19-2015 05:40 AM

Similar Threads

  1. And now we are getting Kit Kat 4.4...thoughts, comments?
    By SDHarleydad in forum Samsung Galaxy Note 2
    Replies: 15
    Last Post: 02-27-2014, 10:41 AM
  2. Air Command, Multi Screen and Notification Panel stop working
    By sateesh desu in forum Samsung Galaxy Note 10.1 (2014)
    Replies: 6
    Last Post: 02-24-2014, 12:01 AM
  3. Returning to rooting and need advice
    By traumahawk in forum Samsung Galaxy S4 Rooting, ROMs & Hacks
    Replies: 1
    Last Post: 02-19-2014, 04:41 PM
  4. Ringtone and notifications
    By MadMike71 in forum Motorola Droid MAXX
    Replies: 8
    Last Post: 02-18-2014, 03:24 PM
  5. green LED light doesnt work for sms and calls
    By pandora1 in forum LG Optimus G
    Replies: 0
    Last Post: 02-18-2014, 09:19 AM