1. gokulb's Avatar
    Hello all,

    I had bought a HTC M8 Eye and came with Stock rom kitkat4.4.4

    I had followed the root methods. Successfully unlocked the bootloader

    1. Boots into bootloader
    2. After attempting to flash the TWRP recovery image to the device I am not able to enter recovery. The system does attempt to enter and I receive the pink message at the top of the screen "Entering Recovery..." but then the system reboots and enters the bootloader
    3. If i reboot it phone boots normally.
    4. I have tried to flash twrp or cwm both - no results.
    5. I tried to flash many versions of twrp and cwm - no results
    6. i tried to clear cache via ADB and flash recovery again - no result

    Kindly help
    Thanks in advance.
    Gokul
    12-04-2014 02:44 AM
  2. benny3's Avatar
    Sounds like you are flashing the wrong recovery. You need the recovery for your specific phone and carrier
    12-04-2014 06:25 AM
  3. gokulb's Avatar
    ok let me try and come back

    Thanks
    12-04-2014 11:26 AM
  4. benny3's Avatar
    ok let me try and come back

    Thanks
    What carrier
    12-04-2014 09:59 PM
  5. gokulb's Avatar
    Vodafone india sim and i have tried the following recovery img

    1. openrecovery-twrp-2.8.1.0-m8.img
    2. openrecovery-twrp-2.8.1.0-m8_whl.img
    3. openrecovery-twrp-2.8.1.0-m8_wlv.img
    4. openrecovery-twrp-2.7.0.2-m8.img
    5. openrecovery-twrp-2.7.0.0-m8_whl.img
    6. openrecovery-twrp-2.7.0.2-m8_wlv.img

    So should i go for earlier versions?
    12-04-2014 10:17 PM
  6. benny3's Avatar
    what was the out put of the cmd prompt when flashing with fastboot?
    12-05-2014 11:36 PM
  7. gokulb's Avatar
    Hey
    extremely sorry i was unwell to report.

    i tried to flash once again and this is the prompt i get.

    target reported max download size of 1826406400 bytes
    sending 'recovery' (14818 KB)...
    OKAY [ 1.785s]
    writing 'recovery'...
    OKAY [ 0.533s]
    finished. total time: 2.317s
    Apples-MacBook-Prolatform-tools apple$

    do help getting frustrated everytime.
    Thanks in advance.

    2. Tried HTC One 2014 (M8) All-In-One Toolkit V2.0 [4-19-2014] [PERM ROOT] - intially it said error: device not found

    then installed all HTC Drivers and at 1st it said error : device not found
    then on the second cmd it flashed twrp.

    Then aswell no luck.
    12-09-2014 08:16 AM
  8. benny3's Avatar
    Is the bootloader unlocked?
    12-09-2014 04:23 PM
  9. gokulb's Avatar
    Yes It in unlockedHTC M8 will not boot recovery mode-img_20141210_084526.jpg
    this is what is displayed

    ***software status: Modified***
    ***unlocked***
    Mels_tuhl pvt ship s-on
    radio - 1.22.
    12-09-2014 09:18 PM
  10. benny3's Avatar
    By the looks of the recoveries you installed you have sprint and verizon recoveries in the list to. My guess you still have the wrong recovery flashed
    This is the one you want...Techerrata Downloads - Browsing m8. Grab the 2.8.1 and flash it
    12-10-2014 09:27 AM
  11. gokulb's Avatar
    hey

    I tried flashing 2.8.1 with usb cables changed

    Apples-MacBook-Pro:desktop apple$ cd platform-tools
    Apples-MacBook-Prolatform-tools apple$ ./fastboot flash recovery openrecovery-twrp-2.8.1.0-m8.img
    target reported max download size of 1826414592 bytes
    sending 'recovery' (16576 KB)...
    OKAY [ 1.978s]
    writing 'recovery'...
    OKAY [ 0.633s]
    finished. total time: 2.611s
    Apples-MacBook-Prolatform-tools apple$ ./fastboot flash recovery openrecovery-twrp-2.8.1.0-m8.img
    target reported max download size of 1826414592 bytes
    sending 'recovery' (16576 KB)...
    OKAY [ 2.058s]
    writing 'recovery'...
    OKAY [ 0.649s]
    finished. total time: 2.707s

    it says okay. does not boot to recovery
    12-10-2014 10:02 AM
  12. benny3's Avatar
    Are you rooted by chance?
    12-10-2014 10:22 AM
  13. benny3's Avatar
    Have you tried booting into recovery with fastboot? Then you can install superuser and try TWRP Manager or flashify to install recovery

    "fastboot boot openrecovery-twrp-2.8.1.0-m8.img"
    12-10-2014 10:31 AM
  14. gokulb's Avatar
    Apples-MacBook-Prolatform-tools apple$ ./fastboot boot openrecovery-twrp-2.8.1.0-m8.img
    downloading 'boot.img'...
    OKAY [ 2.126s]
    booting...
    FAILED (remote: dtb not found)
    finished. total time: 2.128s
    12-10-2014 11:29 AM
  15. benny3's Avatar
    EDIT: I just did it and it to said boot img but it did boot into recovery

    No idea why its saying downloading boot.img. It should be the recovery img. Doyou have abootimg in your fastboot/adb folder? also you ddo have the recovery img in there right?

    I find renaming the recovery to just "recovery" it makes it easier to remember and type so it would be

    Code:
    fastboot boot recovery.img
    12-10-2014 07:23 PM
  16. gokulb's Avatar
    hey

    1. tried boot into recovery changing the name recovery.img - no luck

    HTC M8 will not boot recovery mode-screen-shot-2014-12-11-6.44.56-pm.png

    2. attaching my folder having all the files, i have the recovery.img file. But which is the boot.img file?

    HTC M8 will not boot recovery mode-screen-shot-2014-12-11-6.41.17-pm.png
    12-11-2014 07:16 AM
  17. benny3's Avatar
    Well i would say is this recovery doesn't support the M8 EYE so until there is a recovery for that model you are out of luck. you can try Phils recovery

    [m8][CWM Advanced Edition] PhilZ Touch | HTC One (M8) | XDA Forums
    12-11-2014 10:50 AM
  18. gokulb's Avatar
    hey thanks a bunch..
    i have tried this now. this too has disappointed me. anyways i shall wait and follow for the new recovery versions.

    Thanks a lot for your time.
    12-11-2014 02:01 PM
  19. donnickle's Avatar
    i have an htc one m8 but wont boot after an installation of 6.0 was done. when I tried the bootloader it said locked at the top
    m8_UL_CA PVT SHIP s-off
    CID-11111111
    HBOOT-3.19.0.0000
    RADIO-1.29.214500021.12G
    OPENDSP-V51.2.2-00593-M8974_FO.1015
    OS-6.12.401.4
    eMMC-B00T 2048MB
    DEC 17 2015,14:15:48.23766
    01-28-2016 07:48 AM

Similar Threads

  1. How can I install original OS on Android HTC One M7?
    By Louis-Philippe Baillargeon in forum HTC One M7
    Replies: 4
    Last Post: 04-04-2015, 04:05 AM
  2. Processor Not Responding
    By throssel in forum Samsung Galaxy S5
    Replies: 1
    Last Post: 12-04-2014, 02:18 PM
  3. S3 not connecting to PC?
    By Frankie Hiltz in forum Ask a Question
    Replies: 1
    Last Post: 12-04-2014, 01:06 AM
  4. Replies: 0
    Last Post: 12-04-2014, 12:54 AM
  5. Replies: 1
    Last Post: 12-04-2014, 12:08 AM
LINK TO POST COPIED TO CLIPBOARD