1. dirtysleep's Avatar
    There is already topic opened on the matter in the EVO 4G section but I will re post this here as I am using ONE S and hope other users can help.

    I have discovered the issue while listening to streaming music on various apps - Winamp, Google Play Music etc. After my telephone goes in sleep, some 30 seconds after that the streaming stops. When I wake up the telephone, streamings starts again. No need to explain how annoying is that as I have to keep my phone up in order to be able to listen to the streaming music using the WIFI.

    Here comes the summary:

    - HTC ONE S upgraded to Android 4.1.1
    - "Keep WIFI on during sleep" is turned ON but makes absolutely no difference (while this should be resolving the problem, though)
    - WIFI connection is not dropping while in sleep and then re connecting, it only stops the service and then resumes
    - Issue happens only when using WIFI
    - Issue not happens when using 3G mobile Internet
    - Issue happens on various apps (it is not app dependant)
    - Issue has nothing to do with the type of the wireless router nor with the wireless channel (if anyone tells that this makes total non sense)

    My personal opinion is that this is mainly linked with a software bug with "Keep WIFI on during sleep" as this is the thing that should be making the magical trick. Other possibility is this to be badly managed by the internal power saver manager of the telephone, something that I could not manage to find where can be tweaked.

    I will be more than happy to hear a good explanation to the problem and to find a real good solution, not walk arounds or bypassers or 3rd party software that masks the problem.
    08-11-2013 09:37 PM
  2. Gdraft#WN's Avatar
    According to Tmo, this is how the phone is supposed to work.

    Guess if you can't/won't fix it.... feature it.

    The first upgrade to JB fixed the issue, Wifi was on all the time.

    Then they decided that drained the battery to quickly so sent out an update a month or two later that turned it back off.


    Had I known that, that was the major part of the update. I would have stuck with the first 4.1 update as that actually worked.

    Now I have a phone that takes GREAT voice mail and kids play angry Birds on it.

    But as a phone. What a useless piece of Poo


    If someone can find a patch for it. it would make it back into a decent phone.
    Bushido123 likes this.
    08-12-2013 09:28 PM
  3. Bushido123's Avatar
    The same solution worked for me:
    I fixed it like this: Settings -> WLAN -> Additional settings (i went to this from three dots on the upper right corner in tablet. Phone users might have to click additional button on the phone or on the lower part of the screen.) -> Keep Wi-fi (or WLAN or whichever connection name appears instead of it) on during Sleep -> Always.

    After I made this change, the music did not stop anymore when Android went to sleep mode.
    11-15-2017 02:51 AM

Similar Threads

  1. Wifi boost/extender of hotspot question
    By reykjavik2014 in forum General Help and How To
    Replies: 3
    Last Post: 10-15-2015, 05:59 PM
  2. 4G in Riverside California for Sprint
    By Yusuf in forum General News & Discussion
    Replies: 5
    Last Post: 08-15-2013, 07:47 PM
  3. Notifications over WiFi
    By my bandit in forum Verizon Samsung Galaxy S4
    Replies: 3
    Last Post: 08-12-2013, 05:40 PM
  4. My phone is on safe mode
    By simbero613 in forum General Help and How To
    Replies: 1
    Last Post: 08-12-2013, 09:13 AM
  5. Photos in gallery jumbled up
    By Sameer Aibani in forum Samsung Galaxy Note 2
    Replies: 0
    Last Post: 08-11-2013, 08:52 PM
LINK TO POST COPIED TO CLIPBOARD