1. S_hades's Avatar
    Hi all. I've been reading through these and other forums searching for help with a problem I'm having. I tried to put Trickdroid 9.1.0 on my HTC One S, which seemed to work fine at first. I had Android loaded and was installing apps when one app (Soundprofile I believe) recommended a reboot after install, which I did. The phone got stuck in a boot loop, showing the HTC logo screen with the red warning text, black screen and HTC logo again, over and over. I did a little reading, found that I should try to reflash the boot.img, so I extracted it from the ROM, flashed it...nothing, no change. Tried it twice just to be sure, no effect. Still not worrying, I tried to push the Trickdroid ROM onto the internal SD using ad push and was able to reflash the ROM. I went through the installer, but on first boot, I ended up in the same mess.

    Why not go back to stock completely, I thought. I searched for a RUU and found mostly sites with dead links. I finally found one called RUU_Ville_U_ICS_40_S_HTC_Europe_2.31.401.5.exe. I flashed the stock recovery, locked the bootloader (read somewhere that you have to do this if you're S-ON) booted into the bootloader and ran the exe. A couple of minutes into it I got error 155 image error. Either I'm doing something wrong or I have the wrong RUU for my phone. Either way, I can't seem to find another RUU that's actually downloadable.

    At this point I remembered that I had a nandroid backup somewhere on an external disk, so I decided it was time to go back to a previous state, restoring that nandroid backup. I unlocked the bootloader again, flashed CWM and booted into recovery. Because I had wiped all storage during the ROM installation, I had to push the nandroid (made with CWM) back to the internal SD. For some reason at this stage, I couldn't get adb push to work. adb didn't show any connected devices, even when CWM was loaded in recovery mode (or in the bootloader for that matter). Some more reading followed and determining in CWM that I couldn't mount the sd card anymore, I flashed the stock recovery, used the clear storage option and reflashed CWM. Now I could push files again, but pushing the nandroid folder (17 files, over 2Gb) always results in the phone going black and the ad push comment staying forever on screen without showing progress or ever finishing (I waited for 2 hours at one point). Tried to flash TWRP as recovery instead, and that resulted in not being able to use adb push again. This is where I am right now, and I'm quickly running out of ideas. I'm a total noob when it comes to this stuff, I'm just trying things I find in the forums, but I think I need a little help from someone more experienced than me. I don't really care what I end up with, a stock install, a ROM, or a recovery from the nandroid, as long as it is a working phone Is there anyone out there who can provide some help or insights?

    My phone:
    HTC One S Z520 (S4)
    location: Belgium
    Bootloader: unlocked
    S-ON
    HBoot 2.15.0000
    Radio 1.15.50.05.29
    OpenDSP v31-1.0.45.0815
    11-24-2013 06:57 AM
  2. S_hades's Avatar
    Sometimes the obvious solutions are the best. I was able to adb push a different ROM to the internal storage (Android Sense Best Stock) and have that working now. Am in the process of reinstalling apps, so keeping my fingers crossed, but I think I'm out of the woods. Any insights as to why I had these problems with Trickdroid would be appreciated, as I'm still curious to try that one out.
    11-24-2013 09:11 AM

Similar Threads

  1. samsung tab 3 7inch problems with date and time resetting
    By Craig Palmer in forum Android 4.1 / 4.2 / 4.3 Jelly Bean
    Replies: 10
    Last Post: 09-04-2016, 10:06 AM
  2. AT&T Galaxy S3 - Dashclock widget with PIN lock???
    By KreepyKen in forum AT&T Galaxy S III
    Replies: 4
    Last Post: 01-06-2014, 08:20 PM
  3. Help with galaxy gear
    By rockrchic923 in forum Samsung Galaxy Gear
    Replies: 8
    Last Post: 11-25-2013, 12:16 AM
  4. Stuck flashing a ROM with HTC Desire HD
    By pesho318i in forum Android 4.1 / 4.2 / 4.3 Jelly Bean
    Replies: 3
    Last Post: 11-24-2013, 11:10 AM
  5. Better email client needed
    By newmikro in forum Samsung Galaxy S4
    Replies: 6
    Last Post: 11-24-2013, 10:12 AM
LINK TO POST COPIED TO CLIPBOARD