1. UTnick's Avatar
    There has been a patched version of the updated Google Wallet released. Links updated. Now the Play Store won't ask you to update Wallet.

    If this is helping you out -- will you hit the thanks button for me. I am trying to collect as many as I can.

    This is a link w/the method I used to install the apk (the linked OP method didn't work for me) and the Google Wallet app seems to work fine for me. It is showing me my unused $10, but it is too late in the evening for me to actually go test it.

    Tested and it works perfectly.

    Anyway, you can try the linked OP method or I would recommend mine.

    Region / Device / Root Patched Google Wallet APK (1.1-R67-v5) - Android Software - MoDaCo

    Patched apk

    The install method I used is similar to the linked OP method. First I deleted the apk from system/app and data/app. Then I used Dropbox to get it on my phone from my PC. You can use whatever method you would like. Then I used Root Explorer to move the patched apk to system/app AND data/app. I also renamed the apk to what it was named previously on my phone when I downloaded Google Wallet from the Play Store. Your phone may have a different name as well. I think as long as they are named the same in system/app and data/app you should be fine. That is how I have it. Then don't forget to change permissions once you move it. With Root Explorer you will long press to get the menu and once you select permissions you will check the first two radio buttons on the first row of three. Then uncheck the last two radio buttons on the second row. Then uncheck the last radio button on the last row. Those permissions should match with all the other apps listed. It will look like this: rw-r--r--

    Step by step:
    - Be rooted
    - Uninstall Google Wallet in Play Store OR just delete Google Wallet from data/app
    - Delete Google Wallet apk in system/data
    - take the patched Google Wallet apk and rename to something closer to what was already listed under system/app that you previously deleted. It isn't terribly important that you rename it exactly.
    - move that apk to system/app
    - change permissions to read rw-r--r--
    - copy that apk and move to data/app
    - reboot

    Good luck.

    Here is a solid step-by-step list from fpineda101:

    I had to reboot my phone to get it to work. Here re the steps I took

    1. Write down apk name in system/app
    2. Delete apk in system/app
    3. Mount r/w in system/app using root Explorer
    4. Copy apk to system/app and rename it
    5. Set permissions. I actually used this which worked for me
    x x x
    6. Mount system/app as r/o
    7. Delete apk in data/app
    8. Copy apk from system/app with rename to data/app
    9. Reboot and run the sucka

    Don't take any update in Goggle Play. BUT if after you did this apk switch you took the update -- don't fret. Because we installed the apk in system/app all you have to do is go back into the Play Store and select uninstall. It will revert back to the version we manually installed.

    Thank you guys for hitting the thanks button. And you're welcome. It's cool knowing this is helping and working.

    This first screen starts with the W in grey scale and animates to color after your phone has been read by the merchant:

    This is the following screen if all is going well. Actually, even if it isn't. I got this screen when the grocery store register said "RFID payment system not setup blah blah."

    Cory Cunningham and dabking like this.
    07-01-2012 01:00 PM
  2. UTnick's Avatar
    Thank you, Google, for buying me McDonalds.

    07-02-2012 02:28 PM
  3. rohan32's Avatar
    Awesome, trying now! Thanks!

    EDIT: Gets hung up on "Activating Account" for me. Still gets further than before though!
    I'm using the AT&T HTC One X
    07-02-2012 07:03 PM
  4. bairon85's Avatar
    Tried it as well and it gets stuck at "Activating Account" and then says google wallet has stopped. Boo, I was really excited to go get some free McDonalds.
    07-02-2012 08:14 PM
  5. UTnick's Avatar
    Tried it as well and it gets stuck at "Activating Account" and then says google wallet has stopped. Boo, I was really excited to go get some free McDonalds.
    I hate to say it, but you gotta just keep trying. It took me a couple tries too.
    07-02-2012 08:57 PM
  6. Pauley's Avatar
    You guys trust a hacked financial app? Really?
    adamtalife likes this.
    07-02-2012 10:11 PM
  7. UTnick's Avatar
    You guys trust a hacked financial app? Really?
    Yes, yes I do.
    SpencerHTC and jiwengang like this.
    07-03-2012 12:23 PM
  8. Cyrilmak's Avatar

    This is what I use. Works good.
    07-13-2012 03:02 AM
  9. dover2015's Avatar
    Hello I followed the steps above and got Wallet installed but would not work properly. Then I repeted the steps and still got the same error which is the one below. Anyone have any ideas of how I can fix this?

    Sent from my HTC One X using Android Central Forums
    08-02-2012 05:27 AM
  10. robthesixthree's Avatar
    Same here ! Anyone have an idea how to get this to work with out root ?

    Sent from my HTC One X using Android Central Forums
    08-27-2012 01:54 AM
  11. shamsyed's Avatar
    The same issue is still coming up, there has to be a way to get past this issue with the keys, please give us a way everything else works fine, except for the permissions
    08-29-2012 08:40 PM
  12. loefflerj012's Avatar
    I have the same error with insufficient privileges. Anyone have a fix for this?
    11-06-2012 07:18 PM
  13. Lester Fajardo's Avatar
    Failed to add account.
    Please try again later.
    08-21-2013 04:55 PM
  14. Jack Hell's Avatar
    Sir my phone is not rooted. . .what should i do. . .plss help me
    01-18-2014 07:17 AM
  15. Ferdi Grotsius's Avatar
    Is this still working?
    11-19-2014 08:27 AM