1. andy1991's Avatar
    I put ARHD ROM and everything was fine, until i put Fonter module and changed font and then HOX stuck at quietly brilliant screen..
    I was in panic and i wiped everything, and sdcard, and data, and system, everything.. And then i [inappropriate language edited by Moderator] up all..

    So now i can go into recovery, i can go in fastboot, everything is working, just i cannot get sdcard to work. I think that it should be formatted but it won't work.. I tried several ways that i googled and on every i stuck

    I tried put TWRP but it stuck on swipe to unlock and it won't work, i tried several versions, still nothing..

    I tried this How to: Fix a corrupted DATA partition on the HTC One on ARHD webpage ( I cannot put links )
    And when i put this
    Code:
     /tmp/mkfs.ext4 -b 4096 -O ^huge_file,^dir_nlink,^ext_attr,^resize_inode,^extra_isize -m 0 /dev/block/mmcblk0p37
    It say
    Code:
    Could not stat /dev/block/mmcblk0p37 --- No such file or directory
    Then i tried this
    Code:
    Here's what you'll need:
    Working recovery, basic knowledge of adb & the shell
    Parted (download here)
    stock PB31IMG.zip
    
    Note also that I had run unrevoked forever (so my phone was S-OFF) ... I'm not sure if that's required or not.
    
    So, grab parted from the link above.  Now you need to extract the individual binaries from the .zip (the 6 files in the sdparted folder within the zip), ideally to your android-sdk\tools directory.  Now push all 6 files (adb push [file] /sbin/).  Next, we need to make them useable, so go into the shell (adb shell).  Change to your /sbin/ directory, and run: chmod 0755  on each of the 6 files.
    
    Now, we need to fix the partitions.  This is assuming that the partitions are there, just the wrong format (which is what happened to me .. I accidentally made them FAT32 instead of ext).  So, run the following: parted /dev/block/mmcblk0 mkfs ext2.  It will ask if you want to continue, hit yes.  When it asks for the partition number, enter 1.  Next, when it asks for the format, enter ext2.  Let it do its thing.  Now, once it's done, run parted again.  This time, enter partition 2 (everything else is the same).
    
    Once all that's done, your recovery program should be able to mount both the /data and /cache partitions.  If that's true, you're pretty much done!  One thing I found was that I couldn't directly install a new OS (I tried both Cyanogen and Ultimate).  In both cases, it would look for stuff in the davik-cache that it couldn't find, so something wasn't installing correctly I think.  So, if that happens, flash back to the stock PB31IMG.zip (put it in the root of your /sdcard/ and let hboot install it), and then root your phone anew.  That's what I ended up doing.
    
    Again, huge credit for this goes to -Steveo- and ciwrl for helping me figure out which partitions were the right ones (and for supplying parted, which I hadn't been able to find anywhere).  If something doesn't end up working, just drop me a pm and we'll see what we can do.
    And here it wont when i put command
    Code:
    parted /dev/block/mmcblk0 mkfs ext2
    it say
    Code:
    Error: /dev/block/mmcblk0: unrecognised disk label
    But when i do this
    Code:
    fdisk -l /dev/block/mmcblk0
    it say
    Code:
    Disk /dev/block/mmcblk0: 31.2 GB, 31268536320 bytes
    4 heads, 16 sectors/track, 954240 cylinders
    Units = cylinders of 64 * 512 = 32768 bytes
    
    Disk /dev/block/mmcblk0 doesn't contain a valid partition table
    I am sorry for bad english, but i really need help, i were searching the web for 10hours and nothing worked.. I need to full format sdcard, so could anyone help me?

    Thanks
    10-17-2014 12:19 PM

Similar Threads

  1. Replies: 9
    Last Post: 11-27-2014, 11:50 AM
  2. Replies: 8
    Last Post: 10-21-2014, 08:40 PM
  3. Why are applications refusing to download on the new Note 4?
    By Aref Afshar in forum Samsung Galaxy Note 4
    Replies: 5
    Last Post: 10-17-2014, 09:31 PM
  4. Replies: 9
    Last Post: 10-17-2014, 07:20 PM
  5. Need advice on an RMA that was cancelled.
    By Vacuus Dilectio in forum Google Play Store
    Replies: 4
    Last Post: 10-17-2014, 12:31 PM
LINK TO POST COPIED TO CLIPBOARD