1. anon(153966)'s Avatar
    Does your HTC One X keep the correct time?

    Sent from my HTC One X using Android Central Forums
    05-12-2012 10:57 AM
  2. SAENZ_SCENE's Avatar
    I had one incident where the time actually was about twenty minutes behind. I rebooted and it has not happened since.

    Sent from my HTC One X
    05-12-2012 10:59 AM
  3. Kevin OQuinn's Avatar
    Never had this problem. Think it has something to do with leaving wifi on overnight and it going to deep sleep or something.

    Sent from my HTC One X using Android Central Forums
    05-12-2012 12:07 PM
  4. burrari's Avatar
    As if yet no issues with the time hope none occur :-)

    Sent from my HTC One X using Android Central Forums
    05-12-2012 12:29 PM
  5. aggie's Avatar
    So far so good but I've only had it one day

    Sent from my HTC One X using Tapatalk 2
    05-12-2012 12:30 PM
  6. anon(153966)'s Avatar
    I think Kevin might be right...


    Sent from my iPad using Tapatalk
    05-12-2012 04:20 PM
  7. SAENZ_SCENE's Avatar
    Yup I did have my WiFi on all night so I wouldn't doubt that.

    Sent from my HTC One X
    05-12-2012 06:03 PM
  8. icebike's Avatar
    Time is set by the cell towers.

    Been that way since the Pleistocene.

    That being said, I wonder if the clock is also set by NNTP over the WIFI? This capability was added to Honeycomb/ICS for tablets.

    Your you turned off the check boxes for "USE Network provided Time" I could see you having some clock drift.

    If the HOX is getting time from your router, and your is not synced with a time server, that could cause drift as well.

    This has got me thinking. My HOX drops wifi every night at midnight (or within a few minutes thereof). I'm wondering about where it gets its time now. Maybe my router is horked.
    05-12-2012 06:55 PM
  9. nokia4life's Avatar
    i have left my wifi on and never experienced this my time has been correct not sure i understand how wifi being on over night has anything to do with the time if thats the case wouldn't the laptops or desktops be wrong i checked and mine are correct is this dependent on what router you use?
    05-13-2012 12:50 AM
  10. noname2062's Avatar
    I had that issue. For the first week i owned the phone, every morning i would wake up and the clock on the One X would be 5-10 minutes behind the actual time. I always leave my wifi on. When I rebooted the phone, the time would correct itself until the next night and it would happen again. I even turned the date / time to Manual instead of Network provided time and the problem still persists.

    I did a Master Reset and that fixed my issue. I have been going on over a week with zero issues with the time on my phone since the reset.

    Hope this helps
    05-15-2012 10:50 AM
  11. swhoutx's Avatar
    I have the problem every night. When I get up, the phone is always 5 to 10 minutes behind the correct time. It is that way whether or not the settings are set to connect to use network time or not. A switch to airplane mode and back seems to reset the time when set to use the network time.

    I haven't tried turning off wifi at night to see if the time stays correct, but will try today. This is the only real nagging problem I have with the phone.
    05-15-2012 12:26 PM
  12. cd36's Avatar
    The phone keeps good time but beweather can't keep time at all it will often freeze on me. Sometimes opening beweather and letting it update will change its time otherwise I need to reboot.

    Sent from my HTC One X using Tapatalk 2
    05-15-2012 01:50 PM
  13. swhoutx's Avatar
    The master reset/restore factory settings did not resolve the issue.
    05-16-2012 08:13 AM
  14. noname2062's Avatar
    You're right... The master reset only solved the problem for a week and now it's happening again... :-(

    I have been turning off My wifi at night and so far haven't had the issue again...

    Here's to an quick update by HTC to fix this problem.

    Sent from my HTC One X using Android Central Forums
    05-28-2012 07:09 AM
  15. summersrl's Avatar
    I have experienced this issue twice since buying the phone. The first time the phone was 20 minutes slow when I woke up, and 2 minutes slow the second time. In both cases, toggling the phone into and out of airplane mode caused the phone time to reset to the correct time. In both cases the phone was being charged and both wifi and data were turned off. A quick search shows quite a few different Android phones have similar incorrect time reports. am considering taking the phone back for a replacement as it is an otherwise great device.
    06-04-2012 10:40 PM
  16. icebike's Avatar
    The thing is that the time is supposed to be set by network (as long as you have that setting turned on).

    That does not need wifi. But you turned data off, and therefore it couldn't get to the time servers.

    Why turn data off at night?
    Its not like its going to use a ton of dsta just sitting there.


    Sent from my HOX
    06-04-2012 11:27 PM
  17. nokia4life's Avatar
    Mine has always been correct.

    Sent from my HTC One X using Tapatalk 2
    06-05-2012 12:56 PM
  18. MrSherms's Avatar
    I have the problem every night. When I get up, the phone is always 5 to 10 minutes behind the correct time.
    I've had my HOX for about a month now, and noticed this happening for the first time this week. Settings are checked for time to be set by the network. Sometimes I leave wifi on overnight, sometimes I don't. I'll pay more attention to see if that is the reason. No idea why it has just started to do this.
    06-05-2012 01:36 PM
  19. summersrl's Avatar
    The thing is that the time is supposed to be set by network (as long as you have that setting turned on).

    That does not need wifi. But you turned data off, and therefore it couldn't get to the time servers.
    You might be right, icebike. That said... I do not have the phone set into airplane mode so even though I have turned off the wifi and data radios I can still initiate and receive voice calls and text messages. To my mind, that means the device remains in contact with the AT&T network throughout the night. I would have thought the voice connection would have been sufficient to maintain the time sync between my phone and the AT&T network. Of course, I'm a banker, not an engineer. So, what do I know! I'll try leaving the data radio on and see if I experience this issue again.

    Thanks for the input.
    06-05-2012 08:05 PM
LINK TO POST COPIED TO CLIPBOARD