1. jordan443's Avatar
    Hey guys i have a huge problem. I have a Rogers HTC One X that is rooted. I installed cm10 and I didn't like it so I booted into twrp recovery and wiped EVERYTHING, I wasn't thinking. so there is no ROM on the phone. I have the stock ROM but I couldn't get it onto the phone because twrp wouldn't let me mount my SD. TO get the ROM onto the phone, I partitioned the drive to FAT32 and put the ROM on. It did not appear on twrp. does anyone know how to mount the SD card so I can install it?

    I just tried to mount the sdcard using this guide:

    If you don't have an sd card, or your slot is broken you can try this trick, but you will need a custom recovery like Clockwork.
    Boot up your phone to recovery. And move your rom file to the adb directory, and start a command line ( cmd )
    adb shell
    mount data
    adb push D:\custom_rom.zip /data/
    Wait until the push finised, and restart your device to recovery again with "adb reboot-bootloader"
    mount data
    mount /data /sdcard ( mount the data folder into your sdcard folder, so your recovery will think that you have an sdcard installed )
    Locate the ROM .Zip file you wish to flash.
    Confirm the flash by following the on-screen instructions (ie: pressing the trackball, pressing the call button, etc.)
    If no errors arise during the flashing process then the ROM flash was successful, Reboot the device.
    With some root file explorer, remove the rom file if you don't need it anymore, to free up space.
    Or use adb to remove the custom recovery
    adb shell rm data/custom_rom.zip

    i ended up getting this error:

    Jordan:OneXRootTools Jordan$ ./adb-mac shell
    * daemon not running. starting it now *
    * daemon started successfully *
    ~ # mount data
    mount: mounting /dev/block/mmcblk0p35 on /data failed: Invalid argument

    I tried it again after partitioning the drive to FAT32, still didn't work

    I also tried to flash the ROM vie fast boot and got this:

    Jordan:OneXRootOneClick Jordan$ ./fastboot-mac flash zip PJ83IMG_Evita_UL_Rogers_WWE_1.73.631.1_Radio_0.16a .32.09.06_10.81.32.14L_release_254934_signed.zip
    sending 'zip' (590714 KB)... INFOstart check_usb: usb_ep0: type=128, request=6

    INFOstart check_usb: usb_ep0: type=2, request=1

    It seems to be stuck there
    12-31-2012 07:29 PM
  2. Bizzle69's Avatar
    I haven't seen this myself, so I'm not sure. Maybe check how to install the ruu for your phone? I have no clue
    12-31-2012 08:29 PM

Similar Threads

  1. 0.00 internal memory and can't mount SD Card in CWM Recovery
    By kbpease in forum Verizon Fascinate Rooting, ROMs, and Hacks
    Replies: 9
    Last Post: 08-05-2013, 11:04 PM
  2. Clockwork can't mount sd card
    By JDowling in forum ASUS EeePad Transformer
    Replies: 3
    Last Post: 06-17-2011, 12:56 PM
  3. Can't install apps; can't access SD card in mass storage mode
    By sluMDoc121 in forum Motorola Droid X
    Replies: 6
    Last Post: 02-14-2011, 02:36 PM
  4. Can't mount SD card after Root
    By delucx in forum Verizon Fascinate Rooting, ROMs, and Hacks
    Replies: 22
    Last Post: 01-23-2011, 12:38 AM
  5. can't mount sd card
    By linwiz in forum Verizon Droid Incredible
    Replies: 5
    Last Post: 12-10-2010, 09:19 PM