1. Solirus's Avatar
    Copy and pasting from XDA because I haven't gotten any replies there yet and I'm getting increasingly desperate after almost a full day of a broken phone:

    I rooted my HTC One X about a week ago and installed a nightly of CyanogenMod 10. It was fun for a while but I started to notice the ROM was unstable, causing issues with battery life and freezing. So I wiped it and tried to do a restore to the backup I made just after rooting. But it didn't work. I ended up stuck in a bootloop and panicked. So I went to the same guy that showed me how to root my phone and found a video from him on how to UNROOT/UNBRICK it to get it working again. Also: had to edit out the links to the videos I used because I have less than ten posts. But his videos are stamped with AndroidRoot.

    I got my bootloader relocked with no problem. But whenever I tried to use the RUU file he gave me to get HTC back on there it wouldn't work. I spent hours trying everything I could think of. I kept getting Error 155 and it would get stuck on 'Sending' and never get past it. So now I have a phone with a locked bootloader, no OS/interface, no Recovery, or anything of any kind, just my fastboot screen.

    So then I gave up on the RUU (and it's the right one last I checked but maybe I'm wrong here) and decided I would just try to reroot it and find a stable ROM. Anything to get it working again. But now I can't get my bootloader unlocked. I'm following the same video as last time, and using the same unlock token that I had and everything. But it keeps failing to send the unlock token, or else it just gets stuck on 'Sending Unlock Token' in the command prompt.

    Please help me I miss my phone.
    02-09-2013 09:59 AM
  2. comk4ver's Avatar
    Did you upgrade the boot loader? what version do you have?

    Sent from my Galaxy Nexus using Android Central Forums
    02-09-2013 10:03 AM
  3. Solirus's Avatar
    My phone is the ATT One X with 2.20 on it (the locked bootloader that requires the identifier token) and as far as I know I did not upgrade the bootloader. All I did was root it, put TWRP recovery on there, then I installed a CM10 nightly. Since I relocked the bootloader though nothing is working except my bootloader screen. My unlock token won't unlock it again, and I've tried to get a new one. Stock rom RUU won't install. Nothing.
    02-09-2013 10:07 AM

Similar Threads

  1. Replies: 8
    Last Post: 12-02-2012, 06:26 PM
  2. need some serious help after rooting
    By passerby99 in forum Virgin Mobile Optimus Slider
    Replies: 3
    Last Post: 12-12-2011, 07:22 PM
  3. Need some serious HELP!!
    By ruthieperry82 in forum T-Mobile Optimus T
    Replies: 9
    Last Post: 04-02-2011, 10:49 PM
  4. New to loading ROM's need some slight help
    By Franzie3 in forum Incredible Rooting, ROMs, and Hacks
    Replies: 2
    Last Post: 08-11-2010, 03:02 PM
  5. need a little help from the themers out there
    By wtphoto in forum HTC Hero
    Replies: 0
    Last Post: 02-11-2010, 09:05 PM