1. StubenZocker's Avatar
    (taken right from my reddit-post over at r/Huawei)

    Hi there,

    Please help me understand if I’m just too stupid to use my P20 Pro (9.0.0.195), or if I managed to get a replacement phone with a similar problem – a problem I haven’t found anything about on the internet.

    First phone:
    https://streamable.com/t7ur0

    • had the problem that sometimes, when I pressed the power button to turn it off (like standby), it would flash – mainly on the upper and lower part of the screen, and then stay black, so no always-on display. I could then unlock it via fingerprint or face-recognition, but the screen would just stay black. I then pressed the power-button again, hoping it wouldn’t flash, and that the always-on display would appear. Sometimes I had to repeat this like 20 times to get the screen (?) working again.
    • phone was sent to repair 2 times, but the people there couldn’t identify a problem since they (probably) turn the phone on, check if it works, and then decide that, yes, it works. The problem however was/is, that the problem only appears after some 10+ hours of usage. I guess the people there don’t have the time to wait that long.
    • They did a factory reset twice, but the day after I got my phone back, I went back to my service provider because the problem had reappeared. They saw the problem and wrote it on the repair-info-sheet, but well…
    • After my phone was sent a third time to repair, I got a “new” phone (checked IMEI and SN)


    Second phone:
    https://streamable.com/l2ice

    • I noticed a lighter version of the flashing and staying black, but this time a new problem started. Sometimes the screen wouldn’t stay black, but it turned green. Phone is still responsive, but the screen is green (icons and stuff still visible).


    So yeah… The options:

    1. Am I too stupid to use a phone?
    2. Could this be software related? Like an app I installed, of some specific combination of settings I have? (Wouldn't guess so, considering my Updates 1 and 2 below)
    3. Did I manage to get a second defective phone with a similar problem – a problem I can’t find anything about on the internet?


    If I really managed to get a second defective phone, I should probably start playing the lottery...

    Thanks for your time and help

    UPDATE 1:
    So... Yesterday I did another factory reset on my phone and while setting it up again, I only chose to restore my pictures and stuff from the backup I have. NO Settings, and NO apps. I'm not using any screen color mods (like for the night), I'm not using the always-on display, and I'm not using the face recognition. This morning, after waking up - yet again the flashing and the screen staying black. At least no green screen so far. I really don't get it... I'll try one more factory reset and the only thing that's going to be restored or installed are my phone contacts.

    UPDATE 2:
    I did another factory reset. Only restoring my phone numbers afterwards. Didn't even get to the point where I could install 'mandatory' apps like Whatsapp or FB-Messenger that I really need for communication. Problem reappeared like 5 minutes after reset. Didn't even login to my Google or Huawei Account
    03-10-2019 05:11 AM
  2. slivy58's Avatar
    (taken right from my reddit-post over at r/Huawei)

    Hi there,

    Please help me understand if I’m just too stupid to use my P20 Pro (9.0.0.195), or if I managed to get a replacement phone with a similar problem – a problem I haven’t found anything about on the internet.

    First phone:
    https://streamable.com/t7ur0

    • had the problem that sometimes, when I pressed the power button to turn it off (like standby), it would flash – mainly on the upper and lower part of the screen, and then stay black, so no always-on display. I could then unlock it via fingerprint or face-recognition, but the screen would just stay black. I then pressed the power-button again, hoping it wouldn’t flash, and that the always-on display would appear. Sometimes I had to repeat this like 20 times to get the screen (?) working again.
    • phone was sent to repair 2 times, but the people there couldn’t identify a problem since they (probably) turn the phone on, check if it works, and then decide that, yes, it works. The problem however was/is, that the problem only appears after some 10+ hours of usage. I guess the people there don’t have the time to wait that long.
    • They did a factory reset twice, but the day after I got my phone back, I went back to my service provider because the problem had reappeared. They saw the problem and wrote it on the repair-info-sheet, but well…
    • After my phone was sent a third time to repair, I got a “new” phone (checked IMEI and SN)


    Second phone:
    https://streamable.com/l2ice

    • I noticed a lighter version of the flashing and staying black, but this time a new problem started. Sometimes the screen wouldn’t stay black, but it turned green. Phone is still responsive, but the screen is green (icons and stuff still visible).


    So yeah… The options:

    1. Am I too stupid to use a phone?
    2. Could this be software related? Like an app I installed, of some specific combination of settings I have? (Wouldn't guess so, considering my Updates 1 and 2 below)
    3. Did I manage to get a second defective phone with a similar problem – a problem I can’t find anything about on the internet?


    If I really managed to get a second defective phone, I should probably start playing the lottery...

    Thanks for your time and help

    UPDATE 1:
    So... Yesterday I did another factory reset on my phone and while setting it up again, I only chose to restore my pictures and stuff from the backup I have. NO Settings, and NO apps. I'm not using any screen color mods (like for the night), I'm not using the always-on display, and I'm not using the face recognition. This morning, after waking up - yet again the flashing and the screen staying black. At least no green screen so far. I really don't get it... I'll try one more factory reset and the only thing that's going to be restored or installed are my phone contacts.

    UPDATE 2:
    I did another factory reset. Only restoring my phone numbers afterwards. Didn't even get to the point where I could install 'mandatory' apps like Whatsapp or FB-Messenger that I really need for communication. Problem reappeared like 5 minutes after reset. Didn't even login to my Google or Huawei Account
    Hummm yeah that's some bad luck. Sorry to hear you are having so much troubles. And no it does not sound like an issue with the user at all.

    I have both the P20 (since Feb this year) and P20 Pro as of June last year. Not an ounce of problems as you so describe on either one. Actually the Pro has been performing excellent without a single reset since its initial set up. Did use Phone Clone to set up my P20 (Pro settings/apps) and that worked like a charm.

    So where did you purchase these phones from, your carrier or other? Were they new, refurbished/used?

    Sorry I couldn't be of more help at this time.
    03-10-2019 04:31 PM
  3. StubenZocker's Avatar
    So where did you purchase these phones from, your carrier or other? Were they new, refurbished/used?

    Sorry I couldn't be of more help at this time.
    Bought it from my carrier and it was new. Bought it in May and didn't have any problems 'till end of December - when it first got sent to repair.

    Went back to the carrier-shop today and showed them the problem again. I asked the lady if she could help me understand if I'm just too stupid to use a phone or what... So yeah... ''''funny'''' plot-twist. The "new" phone I got last Thursday wasn't so "new" after all. I checked the IMEIs and SN in the Android OS, and they were different to what's written on my box. They then checked the hardware IMEI (on the SIM-tray), and it's actually still my old phone. Not sure how/why the "software"-IMEIs were different.

    The phone will be send one more time to repair (sure hope so...), and then... I don't know...
    03-11-2019 11:42 AM
  4. nlm's Avatar
    I have not encountered any of the issues you describe. Ask for a new phone replacement and ask to see them take it out of fresh new box.
    03-17-2019 10:49 AM

Similar Threads

  1. Would you recommend Xfinity Mobile?
    By poweranimals in forum General News & Discussion
    Replies: 4
    Last Post: 03-11-2019, 04:53 PM
  2. I love this screen protector
    By Maknora in forum Samsung Galaxy S10 & S10+
    Replies: 28
    Last Post: 03-11-2019, 12:44 PM
  3. Dont know how to unlock quick memo saved content
    By Android Central Question in forum Ask a Question
    Replies: 2
    Last Post: 03-10-2019, 06:26 AM
  4. How to access system root folder in my samsung-G550T1
    By Android Central Question in forum Ask a Question
    Replies: 1
    Last Post: 03-10-2019, 01:55 AM
  5. samsung s9+ connected to wifi but no internet access
    By Android Central Question in forum Ask a Question
    Replies: 1
    Last Post: 03-10-2019, 01:18 AM
LINK TO POST COPIED TO CLIPBOARD