1. sledge007's Avatar
    In order to get a new theme, you need to login to Huawei ID. I press the button and it tells me:
    "This service requires the latest version of the following app:
    Huawei Mobile Services"

    Cancel/Install <options>

    Click Install....Checking for updates...Failed to check for updates.

    No mention of a fix here on this site, however I just got it to work using this method:

    This is what worked for me (I live in Canada):

    On your computer.

    Go to https://cloud.huawei.com/

    Create a new account.

    Set the Region to UK.

    Use E-mail rather than phone.

    Get Confirmation code (it took one day to receive the e-mail for some reason).

    Login.

    Now go to your phone.

    Go to : https://huawei-id.en.uptodown.com/android/old

    Download version: 2.6.4.304 (at least that's what worked for me)

    Install the app on your phone.

    Allow unknown sources if not already.

    Press "DONE." You wont be able to open the app either ways.

    Go to settings.

    search Huawei ID.

    Log in using the account you created on your PC.

    You'll receive a confirmation e-mail again.

    Go to settings > Search : "apps" > apps > find or search themes > click force stop AND > click storage > Clear Data, Clear Cache.

    Launch Themes.

    It'll ask to reset region.

    Press OK

    You're done ! Enjoy the best Rip-off themes.

    I found the app useless tbh, but meh, who cares at this point.

    Peace.

    -QD


    SOURCE:

    https://www.reddit.com/r/Huawei/comm..._to_check_for/
    Mathrania and darkehawke like this.
    04-18-2019 11:08 AM
  2. Ryan_YY's Avatar
    In order to get a new theme, you need to login to Huawei ID. I press the button and it tells me:
    "This service requires the latest version of the following app:
    Huawei Mobile Services"

    Cancel/Install <options>

    Click Install....Checking for updates...Failed to check for updates.

    No mention of a fix here on this site, however I just got it to work using this method:

    This is what worked for me (I live in Canada):

    On your computer.

    Go to https://cloud.huawei.com/

    Create a new account.

    Set the Region to UK.

    Use E-mail rather than phone.

    Get Confirmation code (it took one day to receive the e-mail for some reason).

    Login.

    Now go to your phone.

    Go to : https://huawei-id.en.uptodown.com/android/old

    Download version: 2.6.4.304 (at least that's what worked for me)

    Install the app on your phone.

    Allow unknown sources if not already.

    Press "DONE." You wont be able to open the app either ways.

    Go to settings.

    search Huawei ID.

    Log in using the account you created on your PC.

    You'll receive a confirmation e-mail again.

    Go to settings > Search : "apps" > apps > find or search themes > click force stop AND > click storage > Clear Data, Clear Cache.

    Launch Themes.

    It'll ask to reset region.

    Press OK

    You're done ! Enjoy the best Rip-off themes.

    I found the app useless tbh, but meh, who cares at this point.

    Peace.

    -QD


    SOURCE:

    https://www.reddit.com/r/Huawei/comm..._to_check_for/
    Hey there, I am also using a Cdn P30 pro from Rogers. I am having the issue where i only see the 12 preset themes. I followed everything you did above up to the point where i cannot clear data, only cache. I opened the themes app after but still the same, no region reset or anything. Can I perhaps delete the Themes app and reinstall it? TIA!
    06-10-2019 03:09 PM
  3. sledge007's Avatar
    Hey there, I am also using a Cdn P30 pro from Rogers. I am having the issue where i only see the 12 preset themes. I followed everything you did above up to the point where i cannot clear data, only cache. I opened the themes app after but still the same, no region reset or anything. Can I perhaps delete the Themes app and reinstall it? TIA!
    There's actually a thread on XDA about this issue that is caused by a recent update. I took a screenshot of the fix. I couldn't figure out step 1 so I just skipped it but it did work and now I have themes working as I did before Log In To Huawei ID Failure Solved-screenshot_20190604_202316_com.android.chrome.jpg
    Ryan_YY likes this.
    06-11-2019 09:34 PM
  4. Ryan_YY's Avatar
    thnx will try it out and report back

    There's actually a thread on XDA about this issue that is caused by a recent update. I took a screenshot of the fix. I couldn't figure out step 1 so I just skipped it but it did work and now I have themes working as I did before Click image for larger version. 

Name:	Screenshot_20190604_202316_com.android.chrome.jpg 
Views:	3 
Size:	245.9 KB 
ID:	304234
    06-16-2019 10:43 PM

Similar Threads

  1. Firmware updates to the S10's end of April?
    By Scutley in forum Samsung Galaxy S10 & S10+
    Replies: 24
    Last Post: 05-19-2019, 03:38 PM
  2. Cant get my A1 smartwatch from Amazon to connect to my LG V40?
    By Android Central Question in forum LG V40
    Replies: 1
    Last Post: 04-19-2019, 02:18 PM
  3. My LG 5 is going straight to voice mail
    By Android Central Question in forum Ask a Question
    Replies: 1
    Last Post: 04-19-2019, 02:14 PM
  4. With a Heavy Heart I Have to Stop Using My S10+ as My Daily Driver
    By knowledge775 in forum Samsung Galaxy S10 & S10+
    Replies: 32
    Last Post: 04-19-2019, 02:01 PM
  5. Replies: 0
    Last Post: 04-18-2019, 09:54 AM
LINK TO POST COPIED TO CLIPBOARD