1. 11_13_12's Avatar
    I haven't been able to use my Huawei Ascend ll phone(three months old) for three days now because every time i try to turn on my phone it says: "Sorry! The application com.android.huawei.keypadprogramming(process com.android.huawei.keypadprogramming) has stopped unexpectedly. Please try again." Then the pop-up will go away and show a loading sign. Please Help! I really don't want to buy another phone.

    01-03-2013 06:39 PM
  2. Bendroid55's Avatar
    Try rebooting by pressing and holding the volume down button at the same time as the power button. It might fix itself or bring you to a recovery menu.
    01-03-2013 07:29 PM
  3. 11_13_12's Avatar
    Do i press and hold the power button? Also, should the phone be off or on when I try this?
    01-03-2013 07:34 PM
  4. Bendroid55's Avatar
    Yes. With the phone off press and hold the power and volume down buttons simultaneously until the phone boots. I'm not familiar with your device, but this works on several of my own devices.
    11_13_12 likes this.
    01-03-2013 07:37 PM
  5. 11_13_12's Avatar
    Thank you. But, sadly it didn't work..
    01-03-2013 07:41 PM
  6. 11_13_12's Avatar
    It finally worked! but it now says:
    reboot system now
    apply update from sd card
    wipe data/factroy reset
    wipe cache partition
    wipe misc parition
    touchscreen firmware update
    01-03-2013 07:48 PM
  7. Bendroid55's Avatar
    Try the same thing with but holding volume up.
    01-03-2013 07:49 PM
  8. 11_13_12's Avatar
    It wants me to select one of these:

    reboot system now
    apply update from sd card
    wipe data/factroy reset
    wipe cache partition
    wipe misc parition
    touchscreen firmware update
    01-03-2013 07:53 PM
  9. Bendroid55's Avatar
    a factory reset will almost certainly fix it, but you will lose any saved data. Try rebooting from this menu first.
    11_13_12 likes this.
    01-03-2013 07:55 PM
  10. erondy05's Avatar
    Please help me !!!!! I'm having the same problem. Everytime I turn it on it says "sorry application android ... Has failed " this is e second one I bought because the first one did the same thing. Please help me so i don't have to buy a new phone again. Please please
    05-26-2013 01:16 AM
  11. Saleem Alazawi's Avatar
    so let me get this straight... the phone has to be off, and you press and hold both the volume down button and the power button until a menu pops up?
    07-13-2013 08:11 AM
  12. Saleem Alazawi's Avatar
    i still haven't been able to do it i'm confused on the directions.-.
    07-13-2013 08:15 AM
  13. Saleem Alazawi's Avatar
    i'm sorry these directions sort of confuse me. please help! i want to factory reset my phone. but it's having those same problems
    07-13-2013 08:46 AM
  14. Bendroid55's Avatar
    With the phone off, hold the volume down button and without letting go hold down the power button until the phone powers on. I'm not familiar with your device, but this is the process to get into the phone's recovery for a number of different devices that I have owned.
    07-13-2013 09:32 AM
  15. josearmz10789's Avatar
    Hold either vol+ or vol- and the power button until you boot into recovery. There select factory reset and kelvin cache. That should definitely take care of the problem if not you'll have to apply the stock rom via sd card with the same process.

    Sent from my SPH-L720 using AC Forums mobile app
    07-13-2013 09:37 AM
  16. Alice Powell's Avatar
    So, my phone is having the same issues. I've done the factory reset option, and it worked for a day. This morning, same error message came up about the com.keypadprogramming not working. I did the factory reset again, but I am hoping there is an option for fixing it for real (I don't want to loose everything every other day!).
    08-09-2013 10:57 AM
  17. milesaway214's Avatar
    I have the same phone and it does the same thing. If you have everything on your SD card I would call straight talk (or whoever your provider is) and tell then what's going on and they'll reprogram your phone. My friend had to get this done and it's worked since then. Hope it helped.
    08-14-2013 08:53 PM
  18. zack robinson's Avatar
    what number
    10-11-2013 11:05 AM
  19. Jason Hershberger's Avatar
    same problem, tryed to update it said to check the firmware in my sd card. lol. so i eventually did the factory wipe/reset and it is working for now
    10-14-2013 11:52 PM
  20. william reece's Avatar
    try doing a hard restart by first make sure the phone is off. then press and hold the volume control and the on button. then u will see several options scoll down to firmware update and enter. that option it worked for me i was almost ready to buy a new phone good luck
    12-02-2013 10:07 PM
  21. kimrkey22's Avatar
    When you did the factory wipe/reset did that wipe out your data?
    01-07-2014 05:08 PM
  22. ratchow1's Avatar
    I have discovered that every time I install the Facebook app, I have this problem. If you have the Facebook app, push and hold the search soft key at the bottom right. When it says to speak a command press the speak again. It will let you speak a search item. Doesn't matter what you say. When search comes up, search for play store and search Facebook. When you get to the download for the Facebook, if you have it on your device, it will give you the option to uninstall. Once the app is uninstalled, restart your device and it should be working fine. Don't download it again!
    05-05-2014 10:45 PM
  23. Katt Nicole's Avatar
    I try to hard reset my phone but its written there broadtest failed
    10-25-2014 03:50 PM
  24. Hoopehyehmie's Avatar
    Pls can you upload the firmware you used on your phone?
    09-15-2015 05:13 AM

Similar Threads

  1. Can I use my DX as an automated dash cam?
    By spooksmcgee in forum Motorola Droid X
    Replies: 9
    Last Post: 11-26-2010, 06:29 PM
  2. can I use my X in Canada via WiFi?
    By norwega in forum General Help and How To
    Replies: 2
    Last Post: 10-30-2010, 10:25 AM
  3. Can I use my phone as a wifi webcam for video chat?
    By whitenack in forum General Help and How To
    Replies: 1
    Last Post: 07-05-2010, 11:03 PM
  4. Sense = Force Close!!! Help, can't use my phone.
    By Ter1990 in forum HTC Droid Eris
    Replies: 6
    Last Post: 01-23-2010, 04:47 PM
  5. How Can I Use My Own "Ringtone" For E-Mails...
    By TheNobleJustin in forum General Help and How To
    Replies: 7
    Last Post: 11-10-2009, 12:11 AM