1. Qazme's Avatar
    Well I may have a solution to fix all your woes. For some reason on the stock rom I couldn't get titanium to work correctly due to the infamous "whoami" error. Well he is your fix. We need to reinstall busybox and superuser.

    First find your copy of busybox and the Superuser.apk and make sure they are on your SDcard.

    1. Reboot your phone into recovery.
    2. Goto the partitions menu and mount the /system partition
    3. Open up an adb shell and do the following.
    cd /system/xbin
    /system/bin/cat /sdcard/busybox > busybox
    chmod 777 busybox
    ./busybox --install -s /system/xbin
    We have now reinstalled busybox in case you have mucked something up from the beginning. Now we will deal with Superuser permissions and making them stick.

    4. Go back to your adb shell.

    /system/bin/cat /system/bin/sh > /system/bin/su
    /system/bin/chmod 4777 /system/bin/su
    Once you are back to a "#" prompt in adb recovery:

    export PATH=$PATH:/system/bin
    cd /system/app
    cat /sdcard/Superuser.apk > Superuser.apk
    cd /system/bin
    cat /sdcard/su > su
    ln -s /system/bin/su /system/xbin/su
    chmod 06755 su
    After doing these steps you have a couple of things to check out before you are ready to go.

    5. Reboot your phone into Android.
    6. Make sure you see the Superuser app. If you don't you may need to open up the Superuser.apk in Astro and install it. This shouldn't be necessary however.
    7. Open up Titanium Backup and make sure it asks you for Superuser permission.
    8. If you do then click on the "Problems?" button and let it download the latest busybox into the app's directory.

    Once all that is done you should have a fully working Titanium backup you can use, and will probably fix any other su issues you may have been having. Hopefully this helps someone else! Pass it along!!
    trebores and nuke3ae like this.
    06-29-2010 06:25 PM
  2. trebores's Avatar
    I was having this problem. This fixed it. Thanks!
    07-06-2010 05:33 AM
  3. Qazme's Avatar
    No problem! Was beginning to think that this post was passes by. If something helps you don't forget to hit the "Thanks" button under the persons post!!
    07-06-2010 05:41 AM
  4. nuke3ae's Avatar
    Thanks for this so much.
    07-15-2010 10:37 AM
  5. Qazme's Avatar
    No problem nuke3ae, glad you got your su etc working. Now time to play with your phone!!
    07-15-2010 11:30 AM
  6. EvoRoy's Avatar
    Ok, I am a noob at this. I had my SU Permissions set. With root (not full root) Today I attempted to do the full root and messed something up I am now getting a blank SU Permissions box and the phone freezes. Today I tried to install titanium, busybox and Rom manager one of those messed me up. Can someone please expain where exactly am I supposed to enter the above information? I did the regular root via commands not the unrevoked.
    07-16-2010 02:42 PM
  7. Qazme's Avatar
    Did you even read the post....don't look at just the commands read the post. I go step by freakin' step. Read the post read the post read the post. I tell you where to type in stuff how to get there etc, read the post.

    This is the issue with people using an easy root, they have no clue what they are doing and when they have an issue they have no clue how to fix it. So I would suggest to a lot of you guys having issues with root permissions etc, it probably wouldn't hurt to go back and read the original rooting thread over on XDA, because there is A LOT of information in it. I know it's like 100 pages long but well worth the read if you want to know whats going on.

    And honestly if you don't know where to type all these in you probably shouldn't be rooting your phone. Because it only gets harder from there if you really want to do stuff with the phone, well not harder but putting your phone at risk of bricking once you want to try harder stuff. (All the cool stuff really)
    07-16-2010 03:05 PM