1. fco2013's Avatar
    Okay, so I recently upgraded and got the droid DNA. Now I feel comfortable rooting my old OG Droid Incredible. A few months ago this process was easy and defintive. Downgrade, run unrevoked, bam. But now it seems like there are a handful of different ways, and the process is not so simple.

    Could anyone tell me how to Downgrade from 2.3.4 to 2.2 and root using the method where you use the RUU. I don't want to ADB. Not my cup of tea, and it takes forever, as for some reason my computer slows to a crawl while my phone is plugged in, even when it's just charging.

    12-24-2012 03:41 PM
  2. PvilleComp's Avatar
    Congrats on the DNA. I just got one myself!

    To downgrade and root - go here and download the Froyo RUU.
    Stock Images | PvilleComp's

    Once you are back to Froyo - go to unrevoked.com. Download the Drivers from here public:unrevoked3 [RootWiki] - and follow the instructions for unrevoked3. This will root your existing ROM and install an old clockworkmod recovery and give you S-OFF on the Bootloader. From there you can upgrade clockwork and load whatever ROM's are still available.

    If you need more help, let us know.
    12-24-2012 04:48 PM
  3. fco2013's Avatar
    Thanks! It's a superb phone, as I'm sure you are also aware haha!

    Ah many many thanks for the information and links. I will go through the process now. This will be a souped up media player for sure haha.

    Thank you again! I will post again if I run into trouble or successfully get through the process.
    12-24-2012 06:49 PM
  4. fco2013's Avatar
    Okay, right off the bat I hit a snag haha...I got an error about mid way through the RUU process. It said that my bootloader wasn't the correct version. This reminded me, I have Clockwork Mod Recovery on my phone already....was this the culprit? I'm thinking it was.

    EDIT: I found it on your resource site, do I flash the stock HTC recovery through HBOOT? I'm thinking this is correct, but just to confirm.
    12-24-2012 07:03 PM
  5. PvilleComp's Avatar
    If you already have clockwork on there then all you need to do is flash a rooted ROM - you're already S-OFF. You can confirm by booting into HBOOT. (Power off then power on while holding the power and down vol button at the same time) you should get to the white HBOOT screen and at the top it will say either S-ON or S-OFF. If you're S-OFF you're good to go. I would recomend flashing the latest CM7 Nightly it's stable and an excelent ROM if you want it to be an aTouch.
    fco2013 likes this.
    12-25-2012 02:16 PM
  6. fco2013's Avatar
    It still says I'm S-ON in HBOOT, and I downloaded a root checker from the market, which told me I'm not rooted. I ran unrevoked with this version of clockwork mod as the custom recovery, but it never finished the process. It always got stuck on "rebooting into recovery". This was from a previous attempt, which is why I wanted to try usuing the RUU method, which isn't working for me either haha.
    12-25-2012 05:32 PM
  7. PvilleComp's Avatar
    You can download the Stock recovery here: Recoveries | PvilleComp's

    Here's how to flash it in HBOOT: Flash in HBOOT | PvilleComp's

    Then you should be able to run the RUU.
    fco2013 likes this.
    12-25-2012 06:42 PM
  8. fco2013's Avatar
    You can download the Stock recovery here: Recoveries | PvilleComp's

    Here's how to flash it in HBOOT: Flash in HBOOT | PvilleComp's

    Then you should be able to run the RUU.
    Hmmm....I did that and then it didn't prompt me to install through HBOOT. My SD CArd is formatted to FAT32, and the file is on the root of the card, and is appropriately named.

    EDIT: Do I need to extract anything before placing it on the root? [nevermind]

    EDIT 2: It just cycles through the checking dialogue and then doesn't do anything. I get a loading bar at the top right side of the screen, but once it fills up, nada. It also says nothing once, then "no image" once, then "NO image or WRONG image!" once, then a line saying "checkig....PB31IMG.zip" with nothing else.

    EDIT 3: Even though my SDCARD was the right format, I reformatted it anyway to FAT32. No Change.

    EDIT 4: Tried a different SDCARD as my primary was a SDHC. No change.

    EDIT 5: Tried several times, it would say "loading PB31IMG.zip" then "checking PB31IMG.zip" then it just does nothing, it brings me back to the main HBOOT screen.
    12-25-2012 06:59 PM
  9. fco2013's Avatar
    12-25-2012 08:22 PM
  10. PvilleComp's Avatar
    Did you go into recovery and see if it's still Clockwork?
    12-25-2012 10:13 PM
  11. fco2013's Avatar
    It's still clockwork. I haven't been able to flash the stock recovery. It won't let me.
    12-25-2012 10:23 PM
  12. PvilleComp's Avatar
    Only other thing I can thing of it to flash the stock Gingerbread RUU from the same page as the Froyo RUU to get rid of clockwork, and then re-flash back to Froyo.
    12-25-2012 10:41 PM
  13. fco2013's Avatar
    Alright, I will try that next. Thanks for all the help so far!
    12-25-2012 10:47 PM
  14. fco2013's Avatar
    Nope, I did the latest OTA RUU, nothing changed. I guess I'm stuck with it this way haha.
    12-25-2012 11:29 PM
  15. PvilleComp's Avatar
    I guess that you tried to root previously and it did not fully take. It's weird that you have Clockwork but are S-ON.

    We gave it a shot. It will still work well as an "aPod."
    12-26-2012 08:33 AM
  16. fco2013's Avatar
    Yes it is indeed weird I was able to do that haha. Thanks for all the help once again!

    It's all setup now as an aPod, lightweight apps, lots of music. Gotta love micro SD cards! The one thing I will miss from my Incredible.
    PvilleComp likes this.
    12-26-2012 10:51 PM

Similar Threads

  1. [How-to] Root Droid Charge**5/19/11**[Windows & Mac] Now with GingerSnap!
    By DroidXcon in forum Droid Charge Rooting, ROMs, and Hacks
    Replies: 523
    Last Post: 04-17-2013, 08:43 PM
  2. Replies: 14
    Last Post: 05-06-2011, 04:49 PM
  3. Need help on how to root. im a noob
    By solost26 in forum AT&T Captivate Rooting, ROMs, and Hacks
    Replies: 11
    Last Post: 02-01-2011, 12:39 AM
  4. Help How to Root evo 4g 3.30.651.3
    By alexander__ekin in forum HTC EVO 4G
    Replies: 5
    Last Post: 12-15-2010, 01:12 PM
  5. Help How to Root evo 4g 3.30.651.3
    By alexander__ekin in forum HTC EVO 4G
    Replies: 1
    Last Post: 12-15-2010, 05:37 AM