1. shaundiesel's Avatar
    I've flashed about 6 different kernels, and with all I've had the same result:

    I lose my data connection (3G), therefore not being able to go on the internet or more importantly, not receiving my emails. I use this as a work phone, therefore it is vital that my exchange emails push. I'm fine on WIFI, obviously, but I need my data! I really want to keep the non-stock kernel, currently King #4, due to the battery saving features of the kernel.

    Can someone please help me? I'm not sure if I'm doing something wrong here or what, but it's getting rather frustrating. I'm really trying to avoid going back to the stock kernel here! Thanks in advance for any help!

    EDIT: This is not just from a non-stock kernel...I no longer have data PERIOD. I restored back to stock kernel (last working rom backup) and I can't get 3G at all. When I switch back to my old Moto Droid, I have fully functioning 3G?!?!??
    10-15-2010 10:08 PM
  2. shaundiesel's Avatar
    Any help here guys???????"
    10-16-2010 01:04 PM
  3. douger's Avatar
    You didn't manage to somehow disable your "always on" did you?

    Menu>settings>wireless and networks>mobile networks>enable always-on mobile data checked.

    Maybe you'll need to go back to a stock kernel and start from scratch.

    There's an issue in some ROMs with 3g shutting itself off or not coming on at boot, which rebooting a few times seems to at least temporarily fix.
    10-16-2010 01:17 PM
  4. shaundiesel's Avatar
    no....always on is checked. i checked and rechecked every setting!
    10-16-2010 02:13 PM
  5. bigpetefox's Avatar
    I've been having the same issue. It got better on its own, but I may have to get a replacement this week.

    Only thing I've done was change ROMs, no kernels. Flashing back to 2.1 stock (different radio) helped slightly, really don't want a refurb.

    Sent from my ADR6300 using Tapatalk
    10-17-2010 05:48 PM
  6. shaundiesel's Avatar
    Went back to 2.1???

    I can't revert that bad, ha. Im waiting for it to fix itself.
    10-18-2010 08:15 AM
  7. dharr18's Avatar
    Have you tried wiping the Davlik before loading a kernel? You might want to try and do a factory reset, clear cache, clear Davlik and then install the rom and kernel. Basically start from scratch. If you are using Titanium backup, don't restore any of the system data. It sounds like an app you have loaded may be affecting it or a setting got borked.
    10-18-2010 10:48 AM
  8. dharr18's Avatar
    Another quick thought... Have you done a 228?
    10-18-2010 10:59 AM
  9. crump13's Avatar
    I was having that problem with mobile network until I did the below.

    ##778
    Edit Mode
    000000 <ok>
    M.IP Default Profile
    NAI (changed to my cellphone number including area code @vzw3g.com. I noticed it had 0000008472@vzw3g.com)
    DUN NAI (changed to my cellphone number with area code @dun.vzw3g.com. It had the same number 0000008472 before the @dun.vzw3g.com like above)
    Menu
    Commit Modification
    it will reboot in 10 seconds and then after 30 seconds to a minute my 3g was working again.
    shaundiesel likes this.
    10-18-2010 11:13 AM
  10. shaundiesel's Avatar
    Yes, did a 228.....But, crump13, that's interesting stuff.
    I have since finally gotten it fixed, but only after i went into HBOOT, and cleared storage, then loaded my rom/kernel, and reactivated.

    You have no idea how brutal it is not having data for 3 days! My smartphone became a dumbphone, making ME DUMB!!
    10-18-2010 03:42 PM
LINK TO POST COPIED TO CLIPBOARD