1. metallifan33's Avatar
    Hello,
    I like using Swiftkey for my HTC M8. A previous update added Emoji in the "enter" key. It's really annoying to me because when I'm typing an email or something and I mean to hit "enter" to start a new line, the keyboard changes to the Emoji keyboard which drives me crazy. Then to get back, I have to push another button which gets me my keyboard back. Is there a way to completely remove Emoji? I also accidentally activate the Emoji keyboard when I fat finger the period (or full stop) button like when I want to add an ellipsis (...)
    Thanks!
    02-09-2015 10:22 AM
  2. SpookDroid's Avatar
    If you go to the SwiftKey settings, under LAYOUT you can see the 'Enter Key' option. This allows you to have an emoji keyboard available instead of the Enter Key, or if the emoji keyboard will only appear if you long press on the enter key (leaving, of course, and actual enter key for you to use).

    Unfortunately, you can't turn the Emoji feature off entirely, just relegate it to a long-press trigger.
    02-09-2015 11:12 AM
  3. Krzysztof Korotko's Avatar
    Hi,

    On my xperia z ultra there is no option for enter button.
    I could use other sms app that is not affected but I prefer sony stock app where are two emoji buttons and no enter button at the moment.
    07-10-2015 02:01 AM
  4. google-play's Avatar
    Thank you
    07-11-2015 09:11 PM
  5. c-dee's Avatar
    You can configure the Enter key options of the Swiftkey settings, but cannot disable Emoi's entirely. I had this same issue on my old Samsung Galaxy S3
    07-16-2015 05:54 AM
  6. Javier P's Avatar
    You can configure the Enter key options of the Swiftkey settings, but cannot disable Emoi's entirely. I had this same issue on my old Samsung Galaxy S3
    That's true. The emojis will pop up after you long press on the enter key. One thing you could try is changing the "long-keypress duration". Set a higher time in the Swiftkey settings - advanced and it will reduce the number of times that you open the emojis (and all other options) by accident.
    07-16-2015 07:15 AM
  7. LucyVanderbuilt's Avatar
    Still can't find a solution for this.
    Like metallifan33, it's not really that I hate emoji's but that my fat fingers are constantly hitting the stupid emoji button when I'm trying to tap some other key, it switches keyboards/palettes, and I end up typing several characters of emoji's before I realize it.

    I just want to get rid of the emoji palette altogether.

    I can't believe this isn't an option/setting. I really doubt that most pure business users really care about emoji's.
    11-30-2015 10:43 AM
  8. Hebekiah's Avatar
    Newer settings for swiftkey are to open Swiftkey from apps, select Typing, the Keys, then (counterintuitively) put a checkmark in Emoji access. This worked for me (I never, ever, ever use them). As others stated, you can then increase long-press duration (though I didn't because I wasn't sure if it affected all the buttons and I use accents and other things and didn't want that slowed down) but I've had no problem at the default setting.

    Another tip for the large fingered, while you're there: put a checkmark in Show arrow keys on keyboard. I love that so that when I'm trying to edit text I don't have to mess around moving that cursor just right; I select anywhere near the text I want and use the arrow keys to pinpoint. Faster for me and less frustrating.
    01-23-2016 11:49 PM
  9. qualityservices's Avatar
    Dear I have solution of your problem.
    1. Click on hamburger icon which is on top left side of keyboard.
    2. Then click on More button
    3. Then click on setting gear icon which is in right bottom corner
    4. Then click on typing button under languages button
    5.Then click on keys button
    6. And now enable third option " dedicated emoji key"
    Hurray problem solved. Best of luck
    01-30-2018 08:53 PM

Similar Threads

  1. Replies: 5
    Last Post: 03-08-2015, 01:45 PM
  2. Question....When Lollipop comes are you going to
    By UnlockedOnly in forum Motorola Droid Turbo
    Replies: 23
    Last Post: 02-11-2015, 09:09 PM
  3. Replies: 1
    Last Post: 02-09-2015, 02:31 PM
  4. How do I get recovery mode working on Kies (not working)?
    By ZeUbermench in forum Samsung Galaxy S3
    Replies: 0
    Last Post: 02-09-2015, 10:06 AM
  5. Replies: 1
    Last Post: 02-09-2015, 09:32 AM
LINK TO POST COPIED TO CLIPBOARD