1. tarakos's Avatar

    I have an LG Spirit H420. This is my old phone and didn't use it in the last two years. But recently I found it and turned it on worked, but it was super slow.

    The problem occurred when the next day I turned on again to save some stuff from it. It didn't turn on, the LG logo appears on the screen, and the 'powered by android' title, then the screen goes black and the LG logo appears again with animation and that's it. I left it at first because I thought it's old and it needs some time. After two hours still saw the LG logo with the animation.

    Got suspicious it doesn't gonna start so I took out the battery and put it back again then turned on but with the same result after some time passed. Tried this a couple more times with no success.

    I tried factory resetting the phone by accessing the hard reset menu. It starts the process but after rebooting the phone, the same situation. Only the LG logo with the animation. I tried this a couple of times as well, again with no success.

    At this point, my only reasonable thing that came to my mind is, to go in recovery mode and see what can I do there. I searched for the button combination(volup + power button) nothing happened. Tried releasing when the logo appears, tried to keep pushing, tried to release for a sec when the logo appears. I tried every possible combination that I found online but none of them works. There was one try when the phone actually did something by pressing only the volup button and during that connecting to a PC. This would result in reaching download mode if I'm correct, but the phone just shows a red warning sign with a "Your Device is corrupt. It can't be trusted" message.

    I check with "adb devices" and "fastboot devices" but couldn't get anywhere, none of them recognized the device. The phone needs to be in fastboot mode or recovery mode or download mode to work and recognize, but I can't reach any of them.

    My last chance to revive the phone I guess is manually updating the firmware or manually setting the firmware back to the factory one. but if I' not wrong I'm only able to do through recovery mode. Or another mode(I lost track which one is which).

    I read something about flashing the ROM or something, I don't know what this means or how to do it.

    So my phone is dead? Am I missing something? How can I change the firmware if I can't access the mode I have to? Is my only option flashing the ROM? But how?

    Thanks for your time :) and sorry for any bad English or hard to understand phrases
    09-09-2020 11:45 AM
  2. B. Diddy's Avatar
    Welcome to Android Central! It might just be a failing battery. You could try looking for a replacement online, but be aware that any replacement battery for that phone will also be old, and therefore also may be significantly deteriorated.
    09-09-2020 02:50 PM
  3. tarakos's Avatar
    I perform these with a charger cable plugged in. The battery still, could power the phone for a day. So could be? I can try using a small power supply to power the phone and not with the battery. This way the power can't be a problem. I'll give it a try when I can. I'll check out some replacement after. Thanks
    09-10-2020 02:03 AM
  4. B. Diddy's Avatar
    So are you saying the bootloop only occurs when plugged in, and the phone works normally on battery alone?
    09-10-2020 09:42 PM
  5. tarakos's Avatar
    Ohh no. It doesn't matter if plugged in or not. I tried without the charger and it bootloops as long as the battery allows. I just plugged in to extend the time if only slowness was the cause.
    09-11-2020 04:38 AM
  6. B. Diddy's Avatar
    The other possibilities are a failed motherboard or corrupt firmware. Not much you can do about the former. For corrupt firmware, you'd have to reinstall the stock firmware, but I'm not sure if that's possible on your phone. You could try LGUP: https://lgflash.com/LGUP/
    09-11-2020 10:08 PM
  7. tarakos's Avatar
    I'll give it a try when I am able to. I'll post a result. Thank you
    B. Diddy likes this.
    09-12-2020 05:19 AM

Similar Threads

  1. Suddenly very slow data and bad cellular service
    By Ned Squiggly in forum LG V30
    Replies: 5
    Last Post: 09-09-2020, 04:42 PM
  2. Phone stuck in a bootloop
    By joshkrupinsky in forum General Help and How To
    Replies: 2
    Last Post: 09-09-2020, 03:24 PM
  3. My Samsung SM-G388F is stuck ..
    By Android Central Question in forum Ask a Question
    Replies: 1
    Last Post: 09-09-2020, 02:54 PM
  4. Samsung S8 completely shuts down at night
    By Android Central Question in forum Ask a Question
    Replies: 1
    Last Post: 09-09-2020, 10:37 AM
  5. Why is my phone making noises at night
    By Android Central Question in forum Ask a Question
    Replies: 2
    Last Post: 09-08-2020, 10:45 PM