1. cruisexx's Avatar
    I promise I've searched this topic before posting because I can see its quite a popular problem. But nothing has helped.

    Solutions I've tried and neither have worked:
    1) Clear Data/Cache of Play Music app
    2) Install and run one of those Media Rescan programs (eg. Rescan SD)
    3) Checked all filenames and ID3 tags for any non-UTF8 data
    4) Tried other media players (e.g. Winamp)
    5) Power off and restart the device
    6) Copied stuff back and forth into like every folder in /sdcard/{Music, Download, etc...}
    7) Checked for .nomedia files (none were found in /sdcard/*)

    And like most people with this problem, I can play the songs just fine if I find them using a file manager and select "Open" and choose a player. All my files play just fine this way. But none of them can be seen from the media players apps directly.

    So here is the weird part. If I download a file through Firefox, all the media players can see the file. But if I download the same file using another means (e.g. through a network share) none of the players can see the file.

    I've tried this with the same files so its driving me insane. For a test, I installed an FTP server on my desktop alongside a samba server. I go to ftp:/192.168... on firefox, download a song, and I see it on all the players. But if I use ES File Manager and log into my samba share and download the same file, to the same locations (and I've verified the permissions are the same) none of the players see it.

    EDIT: I've also obviously also tried adb push to get files on the devices. Same deal as with using a Samba share.

    I'm stumped.

    Running the latest stock rom on a Nexus 4.
    04-28-2013 12:35 PM
  2. litlprince's Avatar
    I've had the same troubles before. Unfortunatly i dont have a real solution. I've done all that you have done and well after a while it finaly takes and reads.

    Like i said i dont have a true solution.. But after playing with it for a while it finaly "discovers all the music"

    My question for you though... Where are the files.... On the device or sd card??

    never mind that.. just saw... NEXUS 4.... uhhh.. i dont know then.. In my S3 and Note 10.1 when things get weird like that it means i screwed something up moving files and alot of times a combination of "playing with it" and a reformatting helps...

    Dont Lose Hope.... Stay strong and keep your chin up....
    04-29-2013 08:24 PM
  3. cruisexx's Avatar
    Just thought I'd stop in and say that this is still a problem. I'm pretty sure this is some kind of bug in Mediaserver.
    05-27-2013 01:06 PM
  4. dpirtle213's Avatar
    Having the same problem as you. At first it was only affecting new files but after doing the steps as you listed (which I found elsewhere) all music files are affected. But I can play them through the file system, so they should be perfectly valid.
    06-06-2013 03:43 PM
  5. cruisexx's Avatar
    Just reporting in to say that 4.3 (and app updates as of today) have not changed the situation. WTF GOOGLE?
    08-03-2013 02:49 AM

Similar Threads

  1. What music apps do you like?
    By QponCutie in forum Sprint Galaxy S III
    Replies: 7
    Last Post: 09-27-2012, 09:42 PM
  2. Music apps don't see music folder
    By menelfloss in forum Droid RAZR
    Replies: 0
    Last Post: 06-30-2012, 11:09 AM
  3. Music App/Gallery not finding songs/pics
    By mulishaman187 in forum Verizon HTC Rezound
    Replies: 2
    Last Post: 06-29-2012, 11:18 AM
  4. Music beta not seeing music on the cloud!
    By knapkins in forum General Help and How To
    Replies: 1
    Last Post: 06-04-2011, 03:26 PM
  5. What Droid apps do not work with Google Apps?
    By chipwich in forum Motorola Droid
    Replies: 3
    Last Post: 11-22-2009, 01:52 PM
LINK TO POST COPIED TO CLIPBOARD