1. Hoib's Avatar
    Here's a first - for me anyway!!!

    Friend of mine went into his friendly WallyMart and picked up an Xcelio (?) Android JB 4.1 tablet for $49. OK, so the saying goes you get what you pay for. Fine. I looked at it, at first glance it looks OK at 4gB of RAM, SD card slot and an HDMI connect.- nothing special - made in China. Except there's NO Google Play Store. I mean - NONE, it's not in the App Drawer.

    So how does he get his apps? I gather he's got to go with one of a dozen "alternative" app stores (like Amazon App Store for Android) but I mean - why? Is it that the Xcelio folks didn't cough up enough dough?

    Question 1: How embedded is this Play Store into Android? Any chance he can get to mount the Play Store manually? Question 2: Suppose he finds a .apk, from an alternative source, will JB 4.1 know how to handle that? We've set the thing to allow apps from unknown sources. I don't want to try something I've never done before and somehow brick this thing.

    01-13-2014 10:53 PM
  2. John Woo1's Avatar
    1. Yes. Dl play store apk and just install it. Play store works with all android versions.
    2 Yes.

    Sent from my GT-N7100 using Tapatalk
    01-13-2014 11:00 PM
  3. B. Diddy's Avatar
    Welcome to Android Central! Not all devices are compatible with the Google Play Store, which is often seen with the lesser-known brands. They usually rely on other 3rd party app stores like GetJar or SlideMe. You could always install the Amazon Appstore. You could also try installing the latest Google Play Store apk installer file here, but no guarantees it'll work:

    01-13-2014 11:02 PM
  4. Hoib's Avatar
    OK, thanks to both of you form coming in on this.

    This thing has no file manager! It only has 12 stock applets out of the box none of which appear to allow copying and installing any app. So if I go retrieve the .apk, I'm going to have to copy it over to EMMC off a PC. Now the problem is: what process am I going to use to launch and install the Play Store (or any app for that matter)? Again, I'm sorry but I've never encountered one of these before...

    Just as an aside, the thing came in a box that clearly and unequivocally states "Google Play" in and amongst the feature set. What a rip-off!

    01-13-2014 11:42 PM
  5. B. Diddy's Avatar
    Install Amazon Appstore, then install ES File Explorer.
    01-13-2014 11:53 PM
  6. Hoib's Avatar
    OK, then once I get the .apk in a folder somewhere and get ES to find it, am I simply pressing that representation?

    01-14-2014 12:10 AM
  7. B. Diddy's Avatar
    What would probable be easier would be for you to download whichever apk file you're talking about directly to your tablet using the tablet's browser. Anything you download can then be accessible by using the Downloads shortcut--you can find that in the App Drawer (tap the icon that looks like a grid of dots). You should see the apk file there--just tap it to open it, and it should automatically install
    01-14-2014 12:55 AM
  8. Hoib's Avatar
    OK, sounds simple enough. We'll give it a shot. And, I'll learn something new in the process.
    Guess we'll count our blessings that they at least included the browser in this thing.
    01-14-2014 07:15 AM
  9. patruns's Avatar
    This should explain why you don't have it: https://support.google.com/googlepla.../1397129?hl=en

    This being the key phrase: Manufacturers must obtain a license from Google in order to install the Google Play Store app on their devices.

    That means pay up manufacturer.
    01-14-2014 10:02 AM
  10. Hoib's Avatar
    You know - I figured that might have something to do with it. And folks really have to be careful here because, right on the side of the box, in bold letters and amongst the array of "features" are the words "Google Play Store". And because this company is off shore no one's being held accountable for that. I suppose the retailers take the hit in the end.

    Going to tackle this tomorrow....

    01-14-2014 05:12 PM
  11. Hoib's Avatar
    Nothing succeeds like success...

    Open browser, Googled " Play Store .apk". Find it on some odd-ball forum AndroidAPK or something like that, install it. There was a built in Explorer, locate the .apk, press, answer Yes in install -- poof -- Perfect.
    Yes, I do realize too that D/Ling from odd-ball places is dangerous. But this forum looked quite active with normal users/posts/information. So I took a shortcut.
    Looks like it wasn't such a big deal afterall. Plus I found this thing came through the door with SlideMe Marketplace which apparently the OEM threw on in place of GPS. I have set it back though to D/L only from the Store..

    All is well. You know, really - for $49, this isn't such a bad deal. 4gB RAM, 8gB "drive", SD card slot, sound is good, plays YouTube (where my Nook Color CM7 won't). Will see what kind of battery life this has tomorrow. Will be interesting to see how tough it is under use. I'm going to steal it for the day and see how good it is!!! I'm tempted (if I can even find one now...)

    01-15-2014 10:59 PM
  12. patruns's Avatar
    plays YouTube (where my Nook Color CM7 won't).
    Worked fine on mine, though I since moved to JB....
    01-16-2014 09:21 AM
  13. Algus's Avatar
    My first Android tablet didn't have the Play Store either. This was back before Honeycomb when vendors were trying to compete with iPad and just slapping Gingerbread onto any old thing. It actually wasn't to bad but I did have to get the Amazon app store. A couple big apps didn't work right (got lots of crashes in Angry Birds) but Netflix, etc. all worked fine.

    As long as you aren't particularly concerned about playing the high end apps, you can definitely farm the Amazon app store for enough useful apps to still make it a great device for you. I read tons and tons of books on my old tab and it did pretty good with Netflix as well. Only bad thing was it was a heavy sucker.
    01-16-2014 09:25 AM

Similar Threads

  1. Travelling to the US, need suggestions and places to buy phone/tablet
    By soumian in forum General News & Discussion
    Replies: 23
    Last Post: 02-14-2014, 05:48 AM
  2. New Google Play Services Update
    By amcity32 in forum Legacy Android & Other OS's
    Replies: 15
    Last Post: 01-16-2014, 05:34 PM
  3. Tablet cannot find WiFi at home
    By fuamami in forum General Help and How To
    Replies: 2
    Last Post: 01-13-2014, 11:39 PM
  4. Pin Number put on Android Tablet and number forgotten!
    By Melany Wright in forum General Help and How To
    Replies: 1
    Last Post: 01-13-2014, 08:06 PM
  5. Can't play videos I downloaded onto sdcard from Galaxy SIII on HTC Evo
    By sparklegirl24_7 in forum Samsung Galaxy S3
    Replies: 0
    Last Post: 01-13-2014, 04:24 PM