1. Karl Kulp's Avatar
    N7 grouper running KK 4.4.2 (stock) & Faux123v24m kernel

    Problem 1, OTG:

    1. Using Stickmount
    2. OTG unmounted - OK.
    3. Removed micro sd - OK.
    4. Removed OTG - Screen freeze and reboot.
    5. IIRC, I don't need to mount using Stickmount with the Faux123 kernel.
    6. This was working in JB 4.2.2

    Problem 2, USB OTG Hostmode:

    1. USB Hostmode charging doesn't seem to be working.
    2. Could be my DYI OTG y-cable; I haven't rung it out.
    3. USB Host mode charging is suppported, as far as I know.
    4. This was working in JB 4.2.2 also, but I might have diddled it when I untaped it to do proper solder connections.

    Problem 3, Bluetooth:

    1. All of these accessories are Inland cheapies
    2. Pairs with keyboard and headphones
    3. Mouse shows up in settings as available, but will not pair.
    4. I don't remember if I paired the mouse while I had JB 4.3 running.
    5. I know KK has issues with Bt.

    Any suggestions, hints, pointers will be appreciated. Or a knock on the head if I'm being a doofus.
    I've read through older threads, but haven't fund anything helpful to me.
    Apologies if I missed anything pertinent.


    02-08-2014 07:32 PM
  2. patruns's Avatar
    My first thought is the non stock kernel.
    02-09-2014 11:00 AM
  3. Karl Kulp's Avatar
    OK. I reverted to the stock kernel.

    That seems to have fixed the OTG rebooting problem. Unplugging OTG w/o unmounting works OK, also.

    Bt mouse shows up as available, but still won't pair. The other pairs are working just as before. Tried pairing with a different mouse and it worked. Unpaired it and tried the first one again. No love. Tried the second one and now it won't pair, either.

    When I touch on any available devices in the settings menu, I get an option to pair with it. Not so with the mouse. (Except) for the one time, which I can not repeat.) I'm pretty sure I'm going through the pairing steps correctly, since I can get the keyboard and headphones to pair and unpair without trouble.

    Since the mouse pairing doesn't work with the stock kernel, I think it indicates that it's not the custom kernel. It's either me or the mouse :-)

    Do you know if the stock kernel allows OTG host mode charging?

    02-09-2014 12:46 PM
  4. Karl Kulp's Avatar
    So. I went back to JB 4.3 with the Faux123v22 kernel. The Bt keyboard, headphones, and mouse all paired and connected without trouble. As I sit here I'm typing on the keyboard; mousing around for editing; and listening to music that is streamed from our server over wifi.

    I'm tempted to say that KK 4.4.2 was my problem, and not the custom kernel.

    Next items to test are USB OTG (i.e. unmounting without crashing), and USB host mode charging.

    02-09-2014 10:19 PM
  5. Karl Kulp's Avatar
    OK. Riddle me this. I had the same issues as the guy in the linked video, i.e., Bt mouse not pairing and not even clickable.

    I can't tell you exactly why I did it, but I unrooted and relocked. Then I got the OTA 4.4.2. (Instead of the one I flashed.) Used everything for a few days. Mouse still refused to pair. Just now I unlocked and rooted. Guess what? Mouse paired and connected without problems. I've now got a Bt mouse, keyboard, AND headphones running just fine!

    You could be right about the custom kernel. I can't say at this point. I don't want to break things that are working. I really want OTG + charging, so I might have to, though.

    I'd like to shut it all down to see if things reconnect automatically, but I don't want to press my luck.

    02-15-2014 07:19 PM
  6. zworld's Avatar
    I am having the same issue. Stock. Non-rooted. KitKat 4.4.2. I have tried two BT devices. A MS Surface Pro BT mouse, and a Gear Head mouse. The MS mouse didn't work at all, although it shows up in available devices -- but won't pair even when clicked. The Gear Head mouse worked for bit, until I paired my keyboard then it did the same thing as the MS mouse - appears as a device, but won't pair.

    If anyone finds an answer, I'd love to know.

    05-02-2014 11:44 PM

Similar Threads

  1. Problem with connecting PC with my Samsung Note 3
    By ManiaksXLR in forum AT&T Samsung Galaxy Note 3
    Replies: 69
    Last Post: 11-28-2017, 03:30 PM
  2. 4.4 KitKat for the Galaxy S3
    By makris0000 in forum Sprint Galaxy S III
    Replies: 18
    Last Post: 03-07-2014, 09:21 PM
  3. Switching from Sprint to T-Mobile with Nexus 5
    By rpras in forum Google Nexus 5
    Replies: 4
    Last Post: 02-09-2014, 12:18 PM
  4. Need help with video calls between the Galaxy S Blaze and an iPhone
    By androidfan4000 in forum General Help and How To
    Replies: 2
    Last Post: 02-09-2014, 11:21 AM
  5. grainy screen with Zagg
    By anon8523217 in forum LG G2
    Replies: 1
    Last Post: 02-08-2014, 04:42 PM