1. Sobha Gadi's Avatar
    Hey reddit. 3 days ago I purchased a brand new factory unlocked Moto G in Pakistan. The problem is, whenever I try to uninstall any app I downloaded off the Play Store the phone shuts down and then the start-up screen is displayed after which the phone restarts back to the unlock screen. I did a complete reset to factory settings but the problem still persists. The version of Android is 4.4.2
    I could return the device but its a hassle I dont want to take if one of you can help me fix the phone.
    02-24-2014 07:09 AM
  2. Gekko's Avatar
    you did a complete hard reset back to factory fresh state and the problem still persists? amazing.

    try clearing the cache/data of BOTH the Google Play Services and Google Play Store Apps.

    Settings-->Apps-->Google Play Services and Google Play Store Apps-->Clear Cache, Clear Data

    good luck.
    02-24-2014 07:37 AM
  3. Sobha Gadi's Avatar
    Hi. Thanks for the reply.

    This is highly weird. I did what you told me to do and the moment i hit clear data the same soft reboot happens and the problem is still there.
    02-24-2014 09:30 AM
  4. mrsmumbles's Avatar
    Hi. Thanks for the reply.

    This is highly weird. I did what you told me to do and the moment i hit clear data the same soft reboot happens and the problem is still there.
    Try resetting date and time, even if they look correct.

    Also try resetting App preferences. Settings, Apps, All, tap the 3 dots menu button, tap Reset Preferences.

    Sent from my Nexus 5 using Tapatalk 2
    02-24-2014 10:41 AM
  5. Sobha Gadi's Avatar
    Did both. Nothing happens. As another side issue, I cant open Security in Settings. It says 'Unfortunately, Settings has stopped.'
    02-25-2014 06:46 AM
  6. Gekko's Avatar
    return the device and get a new one.
    02-25-2014 07:10 AM
  7. Blas Simarro's Avatar
    return the device and get a new one.
    Same problems here with reboot while uninstalling apps and no access to settings-security. Shall I also return my own phone?

    For instance, same results with ART and Dalvik.
    02-27-2014 07:47 PM
  8. Gekko's Avatar
    did you buy these from a reputable dealer? sounds like something shady is going on. take them back to the dealer and show them and ask them WTF is going on.
    02-28-2014 07:55 AM
  9. emilik's Avatar
    After some fighting with my phone I came up with a solution.

    1. Since the phone said that it was optimizing one app always, I assumed the problem was a single app. Then I deduced that app was Floatifications because it messed up with the phone security settings (for the notifications access) and was the most mod-heavy app I has installed lately. So I tried to uninstall it via ADB.

    1.1 I had a second issue that the phone didn't recognized that it was connected to a computer. To circumvent this I booted into fastboot menu and I selected the BP tools option. When the phone booted up again with the service app activated it recognized the USB connection to the computer and turned on debugging mode.

    2. I tried different commands to uninstall it via ADB, the one that worked was: adb shell pm uninstall -k <package name>
    2.1 In this case of floatifications the whole command is 'adb shell pm uninstall -k robj.floating.notifications'

    3. After a reboot everything was working normally. Including the USB connection.

    For a final remark, I came up with this whole process by trial and error so maybe there is an easier way of doing all this stuff. I also uninstalled in the same process the lockscreen app "Cover" that also requested access to notifications but I don't think that app was the problem since the phone said it was optimizing one app and it isn't as muddy as Floatifications.
    05-07-2014 01:06 PM
  10. Saad Naveed's Avatar
    Hi Sobha,
    Recently I have bought a factory unlocked moto G and I was having the same problem but finally I found a solution.

    You should try changing the runtime from dalvik to ART

    go to setings>developer options>select runtime

    To enable the developer options go to settings>about phone>tap build number three or four times
    05-17-2014 12:47 PM
  11. Uday Bhanu's Avatar
    Dear Shoba Gadi,
    I was facing the same problem. It always showed me Android Is Upgrading and I was unable to connect to the USB and uninstall any of the apps. I was also unable to open security settings. I resolved the problem by changing the android runtime to dalvik from ART. It worked for me . Hope it works for you too.
    05-18-2014 02:23 AM

Similar Threads

  1. Replies: 21
    Last Post: 03-08-2016, 09:16 PM
  2. 16GB US Moto G great condition
    By Bl00dRunzC0ld in forum Marketplace Archive
    Replies: 6
    Last Post: 05-04-2014, 11:27 PM
  3. [FREE][APP] mQuiz
    By spectrum_softtech in forum Android Apps
    Replies: 1
    Last Post: 02-24-2014, 10:20 AM
  4. [FREE][APP] mSaver- Guardian app
    By spectrum_softtech in forum Android Apps
    Replies: 0
    Last Post: 02-24-2014, 04:35 AM
  5. whats app profile
    By Uttam Kumar Agarwal in forum Samsung Galaxy S4 Mini
    Replies: 0
    Last Post: 02-24-2014, 03:39 AM