1. Wendy Tyo's Avatar
    My tablet Trio Stealth 10 MST 10-21 froze on the logo screen so i did a reset by holding down the volume button the android system recovery list came up i went to wipe data/factory reset it freezes on that screen also.so i went back to system recovery and wiped cache partition also wiped media partion it still will not startup and stays frozen on wipe data/factory reset screen i have also reset it by the reset pinhole button still freezes. I do not know if its rooted i didnt root it myself but idk if it came pre rooted when i bought it.Im not real tech savy lol. i also do not have a sd card inserted in this tablet bc its already 16 gb i have also let the battery drain all the way down then tried everything again can someone plz help me thanks
    04-05-2014 12:59 PM
  2. JD Alston's Avatar
    I have a similar problem. I have a trio stealth - 10 (mst10-21). I did an update and it froze on boot logo when I rebooted it. I can't get it to go past that. I tried to do a soft reset but it didn't work. So, I tried a hard reset, but it won't go to the android. I've tried everything I can think of but I can't get it to go further than boot logo. I was told that I could put jellybean on an sd card and re-install the OS but I can't find jellybean to download it for my trio stealth mst10-21. Can anyone help me with this?
    06-01-2014 07:31 PM
  3. Susann Philbrook's Avatar
    It just happened to my tablet as well. I think this may be due to a download/update for something like the OS. So, I guess nothing is going to work considering what I have read here. I also tried connecting it via USB to my pc. The driver will not load for the tablet. Cannot access it at all! Does this tablet use google?

    The same thing recently happened to my Virgin Mobile phone. I believe an update downloaded and now all of the apps are failing. The first apps to fail on my cell phone were the google apps. (Me things there is a connection here!)
    06-03-2014 06:31 PM
  4. Carolina Solis's Avatar
    Please say me, Did you get help to your trio stealth 10?, I have the same problem and same tablet. I could not get the jellybean. Thanks.
    11-01-2014 12:26 PM
  5. Stacy Lee6's Avatar
    i am having the same problem with as you guys could someone please tell me if you have gotten any help as to what to do for it to come up please share....
    11-26-2014 01:32 PM
  6. rmarcus's Avatar
    So, any news on that? I also have the same problem.
    11-28-2014 10:37 PM
  7. Julie Hops's Avatar
    hello, found your question and was wondering if you ever figured this problem out. I have the same tablet with the same problem. I noticed the date on your post and was wondering if you were able to fix yours. Thanks so much!!
    02-25-2015 01:52 PM
  8. 1256-224-9316's Avatar
    I'm experiencing the same thing with my trio stealth-10 MST10-21. Can anyone help
    04-14-2016 04:32 AM
  9. danielosko's Avatar
    Seems like this is a BS site! No answers, just Questions! Seems like there just trying to make a buck off of the advertisements!!!!
    12-15-2016 04:18 PM

Similar Threads

  1. Galaxy S3 Stuck in Boot Loop
    By Samuel Cramphorn in forum Samsung Galaxy SIII I9300
    Replies: 12
    Last Post: 12-23-2017, 10:00 AM
  2. Replies: 26
    Last Post: 11-01-2016, 08:59 AM
  3. Verizon Note 3: I need help turning off automatic OS updates
    By Evilguppy in forum Samsung Galaxy Note 3
    Replies: 26
    Last Post: 02-06-2015, 09:08 AM
  4. My Phone/Hangouts is Driving Me Crazy with Notifications. Help?
    By smallfrys in forum General Help and How To
    Replies: 3
    Last Post: 04-07-2014, 11:25 PM
  5. any help there ...
    By waleed az in forum Google Nexus 5
    Replies: 2
    Last Post: 04-05-2014, 08:16 PM