1. hungrybear8's Avatar
    Hi all, I have a problem getting my phone to recognize that it's connected to a computer. It is a BLU 5.0k with android 4.4 and a menu is supposed to appear in the notification area when it is attached by USB to a computer, but it does not. I have already tried all the obvious fixes and determined it is a android software problem, It's not my computer, or the cable, or the port on my phone. It always charges fine, and if I play with the "USB debugging" setting, I can sometimes get the phone to connect, but then it doesn't work again if I unplug it and replug it.

    A factory reset did not fix the problem. I also cleared the cache in the boot menu, and there is no new update for my phone. It has worked fine in the past without any drivers even after I rooted it, but now it doesn't even show up in device manager. My USB ports are all 2.0, and I've tried different data cables.

    I really appreciate any help with this, I'm totally stumped.
    11-24-2014 10:04 PM
  2. B. Diddy's Avatar
    Welcome to Android Central! Have you tried connecting it to a different computer?
    11-25-2014 12:50 AM
  3. Olivier Falcou's Avatar
    Hi, i had the same problem yesterday, so I'm here to find. Finally, i didn't saw anything like that and i decided to restard my phone, letting him connected with USB, and then : It works !!! I've the menu to choose which type of connexion.... i can see my SD...
    Hope it will work with u
    11-25-2014 09:59 AM
  4. hungrybear8's Avatar
    I tried it with 2 computers, it never needed a driver in mass storage mode and I am using the same data cable that worked before.
    11-25-2014 03:18 PM
  5. hungrybear8's Avatar
    I found out something interesting. I deleted the contents of the /data/dalvik-cache/ folder on the system partition, then switched the runtime back to dalvik in developer options and rebooted. (Really annoying how the boot menu doesn't have a clear dalvik option.) Now the USB storage works if I boot it plugged into the computer, but not if I plug it in when its on. Weird.
    11-25-2014 03:42 PM
  6. Kevin Linder's Avatar
    How do I get to the dalvic cache on my blue 5.0
    02-28-2015 04:43 PM
  7. CVAngelo's Avatar
    How do I get to the dalvic cache on my blue 5.0
    See post #5. It's pretty much explicitly stated there!
    07-14-2015 12:09 PM
  8. jjavierv's Avatar
    Actually it isn't, in my case I opened /data but did not find dalvic/cache. Is there anywhere else where I should look? Do my phone need to be rooted?
    10-22-2015 06:46 PM
  9. Loverleezack's Avatar
    Oh how I wish that made even a little bit of sense to me. I'm having the same problem with my phone, I was hoping to find a simple solution.
    12-24-2015 07:40 PM
  10. Mitch Alan's Avatar
    Is there any update on this? I have a Blu R1 HD and when connected to my PC via the USB cord, Windows 10 doesn't recognize it. It was working for a bit then something must have gotten corruped on the Blu R1. There is no driver listed on the Blu website, and my PC works fine with other cell phone USB MTPs.

    I called up Blu, they don't know anything. I may have to go to a level two over there. Any suggestions? I couldn't find that file listed in the posting above.
    09-08-2016 10:14 AM
  11. Lynn Spencer's Avatar
    Post #5 isn't showing up. Can someone re-post those instructions? I use my phone to take pictures for my job. It doesn't do me any good if I can't transfer the pics to my computer.
    04-17-2017 10:04 AM
  12. Lynn Spencer's Avatar
    I can't find post #5 .
    04-17-2017 10:07 AM

Similar Threads

  1. My Samsung Galaxy tab 3 won't turn on or chrage, help?
    By eckeryb in forum Samsung Galaxy Tab 3
    Replies: 3
    Last Post: 12-19-2014, 01:05 AM
  2. Replies: 10
    Last Post: 11-26-2014, 01:10 PM
  3. Contacts Storage Application Crashes
    By Kylethedarkn in forum Motorola Droid Pro
    Replies: 7
    Last Post: 11-25-2014, 07:54 PM
  4. Fastest way to launch Google Now in Listening... mode
    By niraj246 in forum Samsung Galaxy S5
    Replies: 2
    Last Post: 11-25-2014, 07:50 AM
  5. mobile id and battery always heating up when in use?
    By ColbyJvonBrown in forum Moto G
    Replies: 0
    Last Post: 11-24-2014, 08:16 PM