1. mroman1960's Avatar
    After bricking my phone while trying to install cm12 using ss 3.73, I used the droid razr utility xt912 to try and get my phone back. I was able to get jb 4.1.2 back, and even downloaded the latest ota. I couldn't get root or safestrap to work via the utility so I accessed root via Kingo Root. At this point, I went to download safestrap when I noticed there was a new version 3.75, so I downloaded the apk and installed the recovery. And here is where the problem started... On initial reboot, following the motoroal logo, the new splash screen appears for approximately 10 seconds then the screen goes black, rather than booting into 4.1.2. I tried to reboot the system and touching the menu icon to enter SS gives me an oversized boot options and backup screen, but i am unable to see an entire screen to make selections. I tried to reboot again, this time touching the search icon to enter normal power up and I just get a black screen. Please don't tell me that I've finally killed off old reliable. All help is greatly appreciated.
    03-09-2015 04:55 PM
  2. Rukbat's Avatar
    SafeStrap 3.72 is for 4.3. SafeStrap 3.75 is for 4.4.2 with a kernel date earlier than June 3, 2014. (You'll get a "device not supported" if the kernel is newer than that.)

    Make sure you're using the right version of SafeStrap for the version of Android. (Your symptoms sound exactly like 3.75 on 4.3. Don't get upset - I've installed the wrong version a few times, until I finally copied the 3.72 backup to my computer and deleted it from the SD card entirely. After beating your head against a wall for an hour, you make stupid mistakes. We all do. It's human. AS long as I have a System backup and a Data backup (it's faster to keep doing a data backup every week or so, than to do a full backup every week or so - once you have a system you like, it's not going to change for a while), a brick is an annoyance, not a calamity. (If you use the right version of SS. If you don't forget to install Busybox before you install SS [did that once, but that was all it took to never do it again].)
    03-10-2015 12:08 AM
  3. mroman1960's Avatar
    Thanks for your support Rukbat! Any idea how to actually bring my phone back t.75o stock at this point? As stated earlier, when I first unbricked the phone using Razr Utility, it cleared out my old SS 3.73. But now when I try to run the utitlity, it fails, (i.e., 3.75 remains and screen goes dark).
    03-11-2015 11:26 AM
  4. mopundit1's Avatar
    Hi there, am a newbie. This is my first Droid 'XT912'. It keeps restarting when it's about to boot into homescreen.
    04-10-2015 06:21 PM
  5. talktozee's Avatar
    I did the same thing, and have the same issue (oversized SS interface, in which I can't do anything). How specifically did you fix your problem?
    01-15-2016 09:56 AM

Similar Threads

  1. After MWC, Best phones with removable battery
    By AC Question in forum Ask a Question
    Replies: 4
    Last Post: 03-10-2015, 09:02 PM
  2. Verizon G5 5.0 installed by the book, MS Exchange issue
    By jonheld in forum Samsung Galaxy S5
    Replies: 1
    Last Post: 03-10-2015, 08:59 AM
  3. Replies: 1
    Last Post: 03-09-2015, 07:05 PM
  4. Replies: 1
    Last Post: 03-09-2015, 06:47 PM
  5. Replies: 2
    Last Post: 03-09-2015, 06:08 PM
LINK TO POST COPIED TO CLIPBOARD