1. Andy Birkett's Avatar
    I've just updated my wife's S4 to Lollipop via Samsung Smart Switch. Straight away, as happened when I did mine, an error popped up saying I needed to update Google Play Services. Frustrating, when this should surely update itself like everything else, but expected. I downloaded an up-to-date APK of Play Services and installed it. Even after two restarts, we're getting 'unknown Google Play Services error with Google Music', which my wife doesn't use. Ire-downloaded the APK and tried to reinstall, but just got 'did not install' message. Tried to disable/uninstall Play Services so I could replace it, but got a message about it being a device administrator but it didn't appear in the list that came up.

    So I can't disable it, I can uninstall it, and manually installing a new APK just results in error messages. I've cleared the cache, restarted, same results.

    Any suggestions *gratefully* received, with the exception of rooting. Tried it twice before and bricked phones, so don't trust myself.


    kamilbutt likes this.
    06-24-2015 02:32 AM
  2. kamilbutt's Avatar
    I like this andy

    Sent from my it1453 using Tapatalk
    06-24-2015 03:03 AM
  3. Javier P's Avatar
    Hi Andy, welcome to the forums! There's a trick that some people have been using to force the Play services update. Go to the Play Store and install Android Wear.


    You don't need a watch and you don't even have to use this app. Just wait after it's installed. Before that maybe you should disable the Google play music.
    06-24-2015 04:04 AM
  4. Andy Birkett's Avatar
    Thanks. Disabling Music seemed to help, I also thought I'd download Android Wear, as there shouldn't be any harm in that, but whichever of these actions caused it, a 'Google Play Services has stopped' error keeps popping up around every couple of minutes, even when I'm not using Play, or in fact doing anything. Any more ideas? Appreciate your help
    06-24-2015 12:17 PM
  5. Javier P's Avatar
    Some people fixed that problem just disabling location services in the settings. You could try that.

    Just in case you could wipe the cache partition. That's a recommended action after a system update. The instructions could depend on your specific carrier.
    06-24-2015 12:44 PM
  6. Andy Birkett's Avatar
    Location settings tried and failed, individually disabled all Google apps (except Google plus and Gmail) but no effect. In App Manager > Play Services, the option to force stop or uninstall updates is greyed out, and if I try to disable, it gives the option to revert to factory version, but then if I click uninstall, I get an error saying 'can't uninstall because this package is an active device administrator'. Clicking on 'manage device administrators' then brings up a list which only includes Lookout, Android device manager (locking lost devices) and S Voice, so there's no way to disable, uninstall or roll back Play Services.

    I've also tried downloading the APK and installing Play Services again in an attempt to update it, but it just comes up with 'App not installed' message, nothing more helpful.

    'Google Play Services has stopped' still popping up every few seconds and now Gmail gives 'unknown Google Play Services error' message. Phone becoming unusable and no idea where to go now.

    How would I look into 'wiping cache partition'?

    06-24-2015 01:54 PM
  7. Javier P's Avatar
    You can try the instructions included in this thread.

    06-24-2015 02:55 PM
  8. Andy Birkett's Avatar
    Me again. Realised that if I unticked things on that 'device management' page, I could then uninstall updates to Play Services it and disable it. Within a few moments, I got a message saying I needed to update Play Services to use Maps, so I clicked it which ran the auto-update of Play Services, and error message now vanished, seemingly for good!

    Thanks for all the advice and swift responses, really good of you
    Javier P and zxmon21 like this.
    06-24-2015 04:56 PM
  9. Javier P's Avatar
    Glad you managed to fix it! Thanks for the follow up. See you around the forums.
    06-24-2015 05:38 PM

Similar Threads

  1. Multiple issues... Root/Lollipop Update...
    By Ohioman1972 in forum Samsung Galaxy S6 edge
    Replies: 13
    Last Post: 07-26-2015, 07:25 PM
  2. Replies: 8
    Last Post: 06-24-2015, 06:11 PM
  3. Google Play Services
    By blg923 in forum Moto X
    Replies: 3
    Last Post: 06-24-2015, 02:11 PM
  4. 5.1 update
    By Mst99 in forum Samsung Galaxy S5
    Replies: 0
    Last Post: 06-23-2015, 09:48 PM