1. Alex ONeal's Avatar
    So i recently rooted my phone everything was going well then my phone shut off so i was like ok. I turn it back on and everything seemed fine then i check my apps and google play was not there so i tried downloading it off the web didn't work. So after trying everything i decided to factory reset my phone Google play was still not there so i un rooted my phone then factory reset it again same problem then i finally waited and then the message popped up saying"Google play services,which some of your applications rely on, is not supported by your device. Please contact the manufacturer for assistance" i did they did nothing. Please help I'm really having trouble here and i need my google stuff to work again. Oh and every time i try logging into google it comes up with an error.


    My phone is a Samsung galaxy s3
    4.4.2 kitkat
    Hardware:L710.14
    06-26-2015 02:27 PM
  2. Alex ONeal's Avatar
    Please anyone
    06-26-2015 05:49 PM

Similar Threads

  1. Replies: 2
    Last Post: 02-19-2017, 01:08 PM
  2. Replies: 1
    Last Post: 06-30-2015, 08:23 AM
  3. Why is the beeping noise during phone calls on my S3 mini?
    By AC Question in forum Samsung Galaxy S3 Mini
    Replies: 1
    Last Post: 06-30-2015, 08:18 AM
  4. Can’t find Data usage android version 4.1.2
    By neilbdm in forum Legacy Android & Other OS's
    Replies: 2
    Last Post: 06-30-2015, 08:07 AM
  5. Replies: 1
    Last Post: 06-27-2015, 01:08 AM
LINK TO POST COPIED TO CLIPBOARD