1. caixamagica's Avatar
    Hello, experts. Android 4.4.2, stock browser. Whenever I do a search in Google and ask for the desktop mode, the browser automatically downloads a file named search.txt which contains the HTML source code from the search page and I never get to see the actual desktop view.
    Desktop view works fine in other browsers like Chrome and Firefox. This issue only affects Google searches.
    Does anyone know the cause for this and how to display the desktop view correctly in the KitKat stock browser?
    Thank you in advance.
    09-12-2016 12:40 AM
  2. B. Diddy's Avatar
    Welcome to Android Central! The "stock" browser probably differs from phone to phone, since it's preinstalled by the manufacturer. Which phone do you have? Have you tried going to Settings>Apps, selecting the stock Browser, and Clearing Cache/Data? Be aware that this will probably erase your locally saved bookmarks, though.
    09-12-2016 01:35 AM
  3. caixamagica's Avatar
    Hi, B. Diddy, thank you. My phone is a Vodafone Smart 4 Turbo and the browser I'm talking about has a blue globe icon and says it's version is 4.4.2-2550921. I really don't use that browser very often but this other one that I like called Naked Browser, which I read somewhere it shares the same webview that it's used by the "stock" browser, so the problem affects it too.
    Yes, I've tried to clear all data from browser, but it keeps downloading search.txt files whenever I google for something in desktop view. I'd be grateful for other suggestions.
    09-12-2016 06:02 AM
  4. B. Diddy's Avatar
    Strange behavior. So if you request Desktop View on any other site, it works fine?
    09-12-2016 01:35 PM
  5. caixamagica's Avatar
    Isn't it? I find it odd too. Desktop view works fine on any other website or search engine, except for Google.
    I've tweaked some options, like www.google.com/search?q= instead of www.google.pt/search?q=, Safe Search on/off, JavaScript on/off, logged in/off on my account... no matter what, I always get the same search file containing HTML codes.
    So clearly something Google-related is causing this behavior... what could it be?
    09-12-2016 02:19 PM
  6. B. Diddy's Avatar
    Hmm, I'm not sure. My Google-fu is failing me right now, and unfortunately, I can't test this out on any of my devices, because the ones that have a preinstalled non-Chrome browser are on Marshmallow already. Will let you know if I find anything.
    caixamagica likes this.
    09-12-2016 04:24 PM

Similar Threads

  1. Why is my phone telling me it's not signing in
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 09-12-2016, 04:20 AM
  2. Replies: 1
    Last Post: 09-12-2016, 01:43 AM
  3. file manager has question marks in files
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 09-12-2016, 12:05 AM
  4. Not able to connect phone in MTP mode
    By AC Question in forum Ask a Question
    Replies: 0
    Last Post: 09-11-2016, 09:42 PM
  5. Hi guys problem with "blocked from network usage"
    By yinxzon in forum Samsung Galaxy S7
    Replies: 1
    Last Post: 09-11-2016, 08:53 PM
LINK TO POST COPIED TO CLIPBOARD