1. JDbug417's Avatar
    Hey guys,

    I have a Droid Turbo 2, I updated to Nougat, and now my Netflix app does not work. I have tried all the typical troubleshooting. Error reads 500.-116 Device Failure Occurred.

    Side bar: The Nougat update also made it to my 64 GB is no longer readable by any device. It worked beautifully as internal storage before the update, now no device can read it including my phone. Ideas?

    Thanks guys
    rw741600 likes this.
    03-02-2017 05:09 PM
  2. rw741600's Avatar
    I have exact same issue
    03-03-2017 07:26 AM
  3. Cheryl Correll's Avatar
    You probably have it on, turn off try again.
    03-03-2017 06:52 PM
  4. JDbug417's Avatar
    I have rebooted, deleted the app, re-uploaded, and done everything else I can think of.
    03-04-2017 01:03 PM
  5. Cheryl Correll's Avatar
    Sound quit on me last night.
    anon(10194295) likes this.
    03-04-2017 07:32 PM
  6. JasonDuck_74's Avatar
    I'm having the exact same problems. Have done everything short of factory resetting my phone, which I am loathe to do simply for one app. (had to delete frowny face emoji)
    03-05-2017 02:11 AM
  7. Quintkent's Avatar
    I was having the same problem. Found a fix!!
    Force close Netflix, clear the catch in the app storage, open Netflix. Netflix then crashes with an error code to restart the device.
    Restart the device, open Netflix, crash with error saying to restart the application.
    Reopen Netflix. It should now work.. you might be able to skip opening Netflix before the restart but this is just how i did it.
    Morgan Farnsworth likes this.
    03-05-2017 08:40 PM
  8. Morgan Farnsworth's Avatar
    CONFIRMED! I have been struggling with this error on my Droid Turbo 2 for a week, after I upgraded to Nougat (Android 7.0) and this fix, used with persistence and stubbornness, wins the day!!
    04-14-2017 11:37 PM
  9. anon(9434928)'s Avatar
    Confirmed! This method worked for me too! After clearing the cache and data. I Force stopped the app, then started it again. I got a 501 error. Then I restarted my Turbo 2. Then opened Netflix, & got a 503 error telling me to restart the app. Then, presto-chango! Netflix is working properly now. Thanks @Quintkent
    04-19-2017 06:42 AM

Similar Threads

  1. How can I change the normal App Icons
    By AC Question in forum Ask a Question
    Replies: 3
    Last Post: 03-06-2017, 08:11 PM
  2. Transfer notes to Huawai P9
    By AC Question in forum Huawei P9 & P9 Plus
    Replies: 3
    Last Post: 03-05-2017, 02:53 AM
  3. How to i fix the screen of my sony xperia xz dual?
    By AC Question in forum Sony Xperia XZ
    Replies: 1
    Last Post: 03-03-2017, 01:37 AM
  4. Transfer notes to Huawai P9
    By AC Question in forum Ask a Question
    Replies: 0
    Last Post: 03-02-2017, 04:54 PM