Save big + get 3 months free! Sign up for ExpressVPN today

  1. Mar D's Avatar
    I recently bought an Oneplus 6.
    First thing i like to do it set up the notifications. What I like is to put my phone to vibrate. When someone calls i would like it to vibrate, but when I get a notification for let's say a whatsapp message I want it to be silent.
    I came from the galaxy s6 with android 7 if i remember correctly. In here I turned off the vibrating option in whatsapp itself and everything was fine. Doing the same thing in Oreo doesnt seem to work. Also tried to turn it off in the notification settings of android itself. The phone still vibrates when receiving a whatsapp message. First i thought it was a oneplus 6 specific issue, but i also tried this on a galaxy s9 and this phone also has the same problem. So it seems to be Oreo related.

    The only options seem to be
    Phone calls on sound > all notifications also on sound
    Phone calls on vibrate > all notifications also on vibrate.
    Phone calls on silent > all notifications also on silent.

    Its the same like in IOS now. Thats what I hated the most in IOS when I was trying it out for 6 months.
    Is this a known issue or am I missing something. I searched the internet but not much people seem to complain about this. For me its a major let down, because receive lots of messages during the day and its so annoying to have you phone vibrate constantly. If there is a feedback thread for this to Google somewhere please share the link.
    07-18-2018 07:24 PM
  2. hallux's Avatar
    Go into Settings > Apps & Notifications > Whatsapp (you may need to tap See All apps) In there, tap each notification type and turn off vibration there.
    Tim1954 likes this.
    07-18-2018 07:35 PM
  3. Mar D's Avatar
    I did also turn it off in the Android notification settings itself. I noticed this setting mirrors the settings in whatsapp itself. So turning off vibrate in Android notification setting will also turn vibrate off in whatsapp settings. I attached two screen shots. One of the Android notification settings and one of the whatsapp notifications settings. It's in dutch but I highlighted the vibrate settings which are turned off.
    So in my situation vibration is turned off in Android notification settings and whatsapp itself, but still the phone vibrates!
    Can someone confirm this is working on his/her phone and if so pls tell what phone and android version you're using.
    Attached Thumbnails Notifications in Oreo. How to set them up-screenshot_20180719-112014__01__01.jpg   Notifications in Oreo. How to set them up-screenshot_20180719-112129__01.jpg  
    07-19-2018 04:45 AM
  4. Mar D's Avatar
    Ok found another thing. And this is clearly a bug.
    When I go to notifications > choose whatsapp > Importance > Low
    This means when receiving a whatsapp message it should not make a sound or vibrate and also not show a notification on the notification bar.
    But instead it still vibrates when receiving a whatsapp message and on top of that the 'Importance' settings changes automatically from low to high.
    07-19-2018 06:29 AM
  5. RK_BB's Avatar
    Ok found another thing. And this is clearly a bug.
    When I go to notifications > choose whatsapp > Importance > Low
    This means when receiving a whatsapp message it should not make a sound or vibrate and also not show a notification on the notification bar.
    But instead it still vibrates when receiving a whatsapp message and on top of that the 'Importance' settings changes automatically from low to high.
    Unfortunately this is not a bug! This is an intended behaviour of WhatsApp. The app overrule Low Importance by design; the next message coming in will alter your settings to the next importance level.

    This is quoted from a WhatsApp Rep:

    +++

    On Android 8.0 and higher, WhatsApp added Group notifications and Message notifications, which have the following special rules:

    The notifications are always on. If you turn them off, the notifications will turn back on when you receive a message.

    Medium and Low importance are disabled. If you set notifications to Medium or Low importance, the notifications will automatically change to Urgent importance when you receive a message.

    If you want to set the behavior to Medium importance, you can set the notification sound to None. For all other pre-populated notifications, we don't recommend modifying importance.

    This is an intended functionality of the app and its features. We apologize for any confusion.

    +++
    09-03-2018 11:00 AM
  6. ManiacJoe's Avatar
    Wow. That is a great way to **** off your customers!
    09-03-2018 11:52 PM

Similar Threads

  1. New here trying to learn android programming
    By Alec Baldwin in forum New to the Forums? Introduce Yourself Here!
    Replies: 8
    Last Post: 07-24-2018, 01:30 AM
  2. Does anyone know how to unlock T-Mobile US LTE bands.
    By Android Central Question in forum Ask a Question
    Replies: 6
    Last Post: 07-19-2018, 09:38 AM
  3. Block notifications for Junk Mail only?
    By lindleys in forum Legacy Android & Other OS's
    Replies: 1
    Last Post: 07-18-2018, 08:35 PM
  4. Moto G 4 Plus Can't connect to Wi-Fi
    By Android Central Question in forum Ask a Question
    Replies: 2
    Last Post: 07-18-2018, 06:52 PM
  5. I can't send half my msgs due to message blocking is active
    By Android Central Question in forum Ask a Question
    Replies: 0
    Last Post: 07-18-2018, 06:47 PM
LINK TO POST COPIED TO CLIPBOARD