1. DevonSwallow's Avatar
    This is an old question but I've tried all the old answers but without any joy.

    I have a Sony Z5 and Nexus 9 tablet, both on Android 7.1.1. The Z5 does what I expect when I plug a USB cable into it and allows me to choose whether to charge it or transfer files. The Nexus 9 does nothing. I've tried different cables.
    I've enabled Developer options with the 7 taps on the Build but there is no USB Debugging option in the Developer option window. It isn't greyed out, it simply isn't there.
    Has anyone any ideas how to wake my tablet up and take notice of me when I plug a USB cable into it?
    I've been able to transfer files from the tablet using wireless and the File Commander app but I need it to recognise a USB cable so I can lift files off SD cards.
    09-01-2018 11:59 AM
  2. B. Diddy's Avatar
    Welcome to Android Central! When you connect the tablet via USB and then swipe down the notification panel, there's no USB icon there at all?
    09-01-2018 08:52 PM
  3. DevonSwallow's Avatar
    Many thanks for the welcome. And no, there is nothing to see if I swipe down from the top of the screen and of course the PC doesn't recognise the device either, even after getting it to scan for new hardware.
    I suppose the USB port itself might be damaged and one or other of the data connections is not working. But I would have still expected to find USB Debugging in the Developer options window but it isn't as you can see in the screenshot below. It is puzzling as my phone with the same software works correctly. The Nexus used to connect with the USB cable but packed up about a year ago. I assumed this followed a software update.

    Nexus 9 Won't Connect to PC-screenshot_20180902-102450.jpg
    09-02-2018 04:31 AM
  4. B. Diddy's Avatar
    Hmm, strange. You can't scroll down any further in that menu, right? And what shows up if you tap the overflow menu button at the upper right?
    09-02-2018 07:56 PM
  5. DevonSwallow's Avatar
    Thank you again. In the screenshot above there was nothing below the menu shown (no scroll bar) and the three dots menu just has "Help and Feedback".

    However, I tried today with a third cable and it suddenly showed the USB Debugging features. Sadly the PC claims it doesn't recognise the device (it used to when it was working) despite me trying various options such as MTP and PTP. It also doesn't connect with the SD card reader, which again it used to.

    I suspect the USB port on the tablet may be damaged. It is a few years old now.
    09-03-2018 06:18 AM
  6. B. Diddy's Avatar
    That's what I'm thinking as well. Just to be sure, use a can of compressed air to blow out the port, and a Q-tip dipped in rubbing alcohol to clean the USB port contacts.
    09-03-2018 07:00 PM
  7. DevonSwallow's Avatar
    I finally got around to replacing the USB socket and I also replaced the battery at the same time while I had it apart. This has solved the problem - the tablet now connects correctly with a PC. So it was the USB socket after all. Thank you for the help.
    B. Diddy likes this.
    11-11-2018 02:08 AM

Similar Threads

  1. The address to send V10 for repair?
    By datum9 in forum LG V10
    Replies: 9
    Last Post: 10-17-2018, 05:53 PM
  2. Replies: 2
    Last Post: 09-01-2018, 10:59 PM
  3. Replies: 2
    Last Post: 09-01-2018, 09:05 PM
  4. My memory card got encrypted and I had to do a factory reset on the phone
    By Android Central Question in forum Ask a Question
    Replies: 1
    Last Post: 09-01-2018, 08:55 PM
  5. Diy... How to fix lg Fiesta won't charge, and blinks constantly on 0% battery?
    By Android Central Question in forum Ask a Question
    Replies: 2
    Last Post: 09-01-2018, 08:24 PM
LINK TO POST COPIED TO CLIPBOARD