1. nyannaco's Avatar
    While my phone memory is running dangerously low, I try to move stuff to the SD card, only to find out it is read only! I have found a number of solutions on the net for getting write access to the SD card, with the help of various file managers. I tried several, and when I get to the step that I must choose the SD card to set the write access for, they all give me the same error message:
    The selected location is different than the location of this storage. You must select the root directory of this storage, i.e., "SD Card"
    The problem is I don't get such an option, I get "07C1-D1D9" and "Internal storage", I choose the former (assuming it is the SD card - indeed I see the file folders in it), and I get the above error message.
    What can i do to fix this?
    04-25-2019 10:13 AM
  2. Rukbat's Avatar
    Look in the phone's main storage (you may need something like ES File Explorer to do it. Go to mnt. In there (that's the folder that things - like the SD card are mounted to) you should find the SD card. Create a folder in the SD card (name it anything, it doesn't matter). That should give you a pace to start. Now when you want to copy things to the SD card, go to that folder, then back one step and select wherever you are. (Never Move things, Copy them. Then, if the copy is good, delete the original. If a Move blows up in the middle you can lose both the original and the copy. [Some apps load the file into memory, delete the original, then write the file to the destination (the "move to") location. If it blows up after the delete, everything is gone. Not every "developer" is a developer.[)
    04-27-2019 01:23 PM
  3. nyannaco's Avatar
    Thank you for your reply, and apologies for not coming back sooner, I was out of town.
    Regrettably the solution you proposed did not work, when I try to create a new folder on the SD card I get an error message that this only works on a rooted phone. I even tried to root mine with KingoRoot, and although it seemed to work, when it got to the end of the process it gave me a Root Failed error message. So back to square one...
    04-30-2019 04:23 AM
  4. nyannaco's Avatar
    Problem solved! Turns out the source of the problem was the SD card. I mounted it on my PC, and it diagnosed the problem and prompted me to fix it. I did so, put it back on the phone, and used FX Explored app to gain write access to it. Now it worked, whereas it did not before.
    Note: this app does not require rooting the device to grant write access to the SD card.
    05-04-2019 04:34 AM

Similar Threads

  1. Who's moving to the S10 5G?
    By jeepentj in forum Samsung Galaxy S10 & S10+
    Replies: 17
    Last Post: 04-29-2019, 03:32 PM
  2. Samsung Galaxy S8 Not Sending MMS via WiFi Since Upgrade to Android 9.0
    By Android Central Question in forum Samsung Galaxy S8 & S8+
    Replies: 1
    Last Post: 04-27-2019, 07:52 PM
  3. ((Samsung Galaxy 9+) Copy to clipboard delayed in Samsung Notes only
    By Android Central Question in forum Ask a Question
    Replies: 4
    Last Post: 04-26-2019, 05:48 AM
  4. No option to set broadcast channel at mobile hot-spot advanced settings
    By Android Central Question in forum Ask a Question
    Replies: 1
    Last Post: 04-25-2019, 12:46 PM