1. Android Central Question's Avatar
    TIM is my carrier and I suspended my data plan temporarily when I still had Android 7x. After I upgraded to Oreo 8.1.0 this notification about the carrier being not present started to appear. I don't know and couldn't find how it reads in English, so I'll try to translate it from Brazilian Portuguese the best way I can for you to get what I'm talking about. It says:

    Smartphone services
    No service
    The selected network (TIM) is not available

    If I tap this notification, it shows a Mobile network page with all options grayed out. If I swipe to the side, it shows two icons: a gear and a clock.

    If I tap the gear, I get the message: Smartphone Services - Notifications - Notifications of this app cannot be turned off.

    If I tap the clock, I can choose to snooze the notification for 15 minutes, 30 minutes and 2 hours, the default being 1 hour. I always choose 2 hours, but obviously it comes back after that.

    I wonder if there's any way to get rid of this annoying notification. It's the kind of thing that developers do not seem to consider in terms of user experience. Of course I know the TIM network is not available, I have requested to suspend it myself, I do not need a notification telling me this permanently!

    I suppose this notification should serve other situations, like when the network becomes unavailable because the device is outside the coverage area. But to make a notification that cannot be turned off only for this seems like an exaggeration.

    I was thinking: if I remove the microSD card, will I end it? But if I do this will I lose other features of the smartphone or the system?

    Is there some third-party solution for this?

    TIA.
    05-03-2019 10:43 AM
  2. Rukbat's Avatar
    Turn off mobile data. The phone has it enabled, it's looking for it, and it's not finding it. If you turn it off, it won't look for it.
    05-03-2019 01:35 PM
  3. Paultx's Avatar
    Turn off mobile data. The phone has it enabled, it's looking for it, and it's not finding it. If you turn it off, it won't look for it.
    As I said, all mobile data options are grayed out. And they're all already disabled.

    How to rid this annoying Oreo 8.1 notification?-screenshot_20190506-125450.png

    Or do you mean somewhere else?
    05-06-2019 01:00 PM
  4. Javier P's Avatar
    As I said, all mobile data options are grayed out. And they're all already disabled.

    Click image for larger version. 

Name:	Screenshot_20190506-125450.png 
Views:	6 
Size:	64.9 KB 
ID:	302855

    Or do you mean somewhere else?
    Welcome to the forums. You can disable mobile data in different places, one of them under the data usage settings (see screenshot).

    I'm not sure if I completely understand your situation. Do you mean that the TIM network is not available at all, even for calls and texts? If that's the case you can disable it in the SIM card settings or you can switch airplane mode on and enable WiFi or any other radio when needed.How to rid this annoying Oreo 8.1 notification?-img_20190506_142656.jpeg
    05-06-2019 01:35 PM
  5. Paultx's Avatar
    Welcome to the forums. You can disable mobile data in different places, one of them under the data usage settings (see screenshot).

    I'm not sure if I completely understand your situation. Do you mean that the TIM network is not available at all, even for calls and texts? If that's the case you can disable it in the SIM card settings or you can switch airplane mode on and enable WiFi or any other radio when needed.

    Click image for larger version. 

Name:	IMG_20190506_142656.jpeg 
Views:	6 
Size:	27.0 KB 
ID:	302856
    Yes, it's temporarily suspended for a 120 days period by my request.
    The data usage settings are also grayed out:

    How to rid this annoying Oreo 8.1 notification?-screenshot_20190506-152449.png

    I suspended it temporarily because I'm now unemployed and doing some freelance work at home, where I have Wi-Fi, which is the only connection I'm using.
    05-06-2019 03:28 PM
  6. Javier P's Avatar
    I'd recommend you to disable it in the SIM card settings then. Or airplane mode as I said before.
    05-06-2019 03:33 PM
  7. Paultx's Avatar
    Solution found: I moved the SIM card to the other slot. Phone working as usual. Annoying notification gone. Case closed!
    06-07-2019 12:55 PM

Similar Threads

  1. Replies: 3
    Last Post: 05-22-2019, 08:07 PM
  2. What is this icon
    By Android Central Question in forum Ask a Question
    Replies: 2
    Last Post: 05-03-2019, 09:15 PM
  3. Replies: 1
    Last Post: 05-03-2019, 01:40 PM
  4. Replies: 0
    Last Post: 05-03-2019, 08:07 AM
  5. How can reset my S secure passward
    By Android Central Question in forum Ask a Question
    Replies: 1
    Last Post: 05-03-2019, 07:03 AM
LINK TO POST COPIED TO CLIPBOARD