1. Wout Mertens's Avatar
    Hi all,

    My watch has been turning off without warning lately (the past few months), and when I try to turn it on again it shows the LG logo and immediately goes black again. Only when I put it on the cradle will it boot normally, and once it booted the charge shows as 50-90%.

    I sort of suspect the battery; I opened it up, unplugged the battery, replugged the battery, and then it behaved halfway normally for a few hours. Now, even that doesn't help.

    The odd thing is that if I go into the bootloader, the watch stays on - so is the problem the battery or something else?

    The watch is past warrantee now, but I've had to send it in 5-6 times for repairs due to blackscreens even while connected to my phone. They replaced the battery a couple of times, so that also points to the battery maybe not being the culprit.

    There is no trace of corrosion on the motherboard. I tried factory reset from the bootloader - no change.

    Thoughts?
    02-03-2017 02:36 AM
  2. Wout Mertens's Avatar
    Update: I drained the battery by putting it in bootloader mode so it wouldn't turn off, and then I fully charged it in 3 hours, and then I could take it off the cradle without it stopping.

    However, a few minutes later it turned off when it tried to vibrate. Maybe it's the battery after all, and booting/vibrating takes too much power?

    Also interesting is that when it boots, it resets to 1AM, so the internal clock also lost power, if there is such a thing.

    So, still dead
    02-03-2017 08:46 AM

Similar Threads

  1. Fast Charge Not Working
    By Shifty88 in forum Samsung Galaxy S7
    Replies: 7
    Last Post: 02-18-2017, 04:04 PM
  2. Moto E (2nd Generation) Home Button Not Working!
    By Cassandra Leong in forum Moto E
    Replies: 2
    Last Post: 02-03-2017, 12:00 PM
  3. Recent app screen not working and crashing
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 02-03-2017, 05:53 AM
  4. how do i get remote to work during reset
    By AC Question in forum Ask a Question
    Replies: 0
    Last Post: 02-03-2017, 02:26 AM
  5. camera doest works, sim card isnt detecting
    By AC Question in forum Ask a Question
    Replies: 0
    Last Post: 02-03-2017, 12:50 AM
LINK TO POST COPIED TO CLIPBOARD