1. wayned42's Avatar
    I just got my LG G Watch and I'm trying to figure out if it is defective or if Android Wear is just super buggy. (I'm trying to use it with a Galaxy S4 phone running KitKat, BTW.) Things I've seen so far:

    Lots and lots of blank cards. Just about anything beyond gmail and hangout messages displays as an empty card. I have 1Weather loaded since it was supposed to have a nice weather card on the watch. I instead see a nearly black card with a question mark and a couple other symbols (but no letters or numbers). If I use the Android Wear app to send demo cards to the watch, I can get 2 to show text (the birthday and flight status), but most everything else is blank or doesn't appear at all (e.g. I can't get the boarding pass to show up at all).
    blank cards, lack of results, crashing-20140707_145246.jpgblank cards, lack of results, crashing-20140707_144442.jpg
    If I say "Navigate to" place-name, I see the words appearing properly, but the watch then does nothing. I can get it to set an alarm, but if I go into the list of actions and ask to see a list of alarms, the watch crashes ("Unfortunately Android Wear has stopped").

    And just now the watch was refusing to let me choose any actions after tapping the red mic icon -- it would give me a near instant "I didn't catch that" black screen, which means that I couldn't ask the watch to reboot via the UI (I had to use a ball-point pen on the rear power switch).

    I also tried using the "Wear Aware" app to have it notify me if my watch and phone get separated, but it doesn't do anything for me (can't even use the test button). Not sure if that is related to the other issues or not. Anyone getting it to work with their LG?

    07-07-2014 06:37 PM
  2. alistairs's Avatar
    Have you had the update yet? Mine was doing similar things until it popped up and said update available. Tap to install (seems like nothing is happening, but wait a few mins and it will reboot and install). After that everything is working great.
    bcbbanga4l likes this.
    07-07-2014 08:31 PM
  3. bmarvoz's Avatar
    I haven't had this happen to me yet but I agree that maybe you need to update (mine did). Double tap the screen, tap the g in the upper right corner, scroll down to settings, about, system updates. Maybe that could force an update if one is necessary. I'm not totally sure.

    Theres also an option to reset the device in the settings menu. Maybe try that too.

    Edit: Maybe if you have the means try pairing it with another android device to see if it still happens.
    Edit2: I also saw people say that rebooting their phone after the update solved some problems they were experiencing.
    bcbbanga4l and wayned42 like this.
    07-07-2014 09:57 PM
  4. wayned42's Avatar
    Have you had the update yet? Mine was doing similar things until it popped up and said update available.
    Indeed, the update fixed the weirdness. Sadly, it wasn't being offered to my watch at the time I wrote my message, so I wasn't aware that I was missing it. In the process of fixing things I originally tried a factory reset, which then went into a "Something went wrong. Retry?" over and over again. I set the watch aside until the evening and then it finally succeeded in downloading the update (which I only discovered was what that prompt was trying to do after it succeeded). I wonder if their servers were overloaded earlier in the day? At first it was failing instanty (without any progress in the circular progress meter).

    Now that it has updated I'm much happier with the watch. The various wear-enabled apps are now working, notifications aren't blank, and things seem more stable. I can only assume that it will continue to get even better as time goes on.

    Thanks for your help!
    07-08-2014 02:22 PM

Similar Threads

  1. Play Store crashes whenever I choose an app
    By oferei in forum Ask a Question
    Replies: 2
    Last Post: 07-16-2014, 04:45 AM
  2. Charger woes - users report easy breaking of GearLive charger
    By Fearless Freep in forum Samsung Gear Live
    Replies: 8
    Last Post: 07-12-2014, 06:24 PM
  3. [New Free Quiz]True of False -Test
    By lex023 in forum Android Games
    Replies: 2
    Last Post: 07-09-2014, 10:39 AM
  4. Lost of signal @ residence
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 07-07-2014, 06:51 PM
  5. Locked out of android phone (too many pattern attempts)
    By Unregistered in forum Ask a Question
    Replies: 1
    Last Post: 07-07-2014, 05:27 PM