1. CruiSin's Avatar
    I got the G watch yesterday, and was playing around. Tried to do navigation and it seemed to start up, but was going to the wrong location. I closed it out and since then have not been able to get navigation on the watch...

    It recognized it on the watch, launches navigation on the phone, but will not do any navigation on the G watch. I've reset the watch, reinstalled the Maps update, removed and installed Android Wear again.

    No matter what I do, there is no navigation on the watch. Anybody else run into this?

    More importantly, who do I talk to? LG? Google?
    07-10-2014 11:26 AM
  2. jasonaward's Avatar
    More importantly, who do I talk to? LG? Google?
    Definitely sounds like a bug, possibly in the maps app. You would need to talk to Google though, as LG is mainly just a hardware provider in this case.
    07-10-2014 01:34 PM
  3. CruiSin's Avatar
    So I guess I didn't try it the right way after doing all the steps of reinstalling Maps, Android Wear, and resetting the watch...

    Went to lunch and told it to navigate - it worked! Yay...
    07-10-2014 02:30 PM

Similar Threads

  1. Nova Launcher Prime - No SMS notification sounds
    By milos85732 in forum Ask a Question
    Replies: 3
    Last Post: 01-09-2017, 10:57 AM
  2. GPS appears to fail when starting navigation
    By greatgoogly in forum Google Nexus 4
    Replies: 4
    Last Post: 08-26-2014, 01:26 PM
  3. Screen protectors: Necessary or no?
    By Fearless Freep in forum LG G Watch
    Replies: 9
    Last Post: 07-17-2014, 11:45 PM
  4. ASUS Memo Pad 8 is definitely on but there is no display
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 07-10-2014, 12:06 PM
  5. No push notifications for emails
    By PogoMips in forum Android 4.4 KitKat
    Replies: 0
    Last Post: 07-09-2014, 03:46 PM