1. joeynox's Avatar
    Can someone tell me why my G2 does this when its on the charger or conwnctes to the PC.im unable to charge it. I'm seriously thinking about turning back time and just getting a beeper. Since nov2012 I've been through 6 Nokia 920's and now this is my new lgg2 . Wtf lol
    https://skydrive.live.com/redir?resi...IIsLkqhBgQVQfA
    09-24-2013 04:00 PM
  2. mhunter6378's Avatar
    That's strange to watch. I'm guessing you already know that plug in animation should only flash once then the phone should start charging. Have you tried to rule out the simple stuff like trying a different cable and or charger? May also try restarting the phone to see if its just a software glitch too. A more drastic step would be a factory software reset. And last option it may be a bad charge / data port on the phone.
    09-24-2013 04:10 PM
  3. joeynox's Avatar
    I tried 2 cables and 2 USB plugs for the cables. , turned the phone off and back on . Haven't done a hard reset yet.
    09-24-2013 04:16 PM
  4. mhunter6378's Avatar
    I tried 2 cables and 2 USB plugs for the cables. , turned the phone off and back on . Haven't done a hard reset yet.
    It can be a bit of work setting the phone back up but the reset may be worth a shot. It's probably down to that or getting a replacement at this point. If you get a replacement you will have to set it up again anyway. You have an AT&T version? If so, you can run the LG backup and save everything like it is, just be sure to off load that backup file to a computer or cloud drive before the reset so you can use it to restore from.
    09-24-2013 04:30 PM
  5. joeynox's Avatar
    Thank you all for responding. I did the factory reset and it didn't help. I went to an att store and just swapped for a new unit and so far everything seems ok. I seriousl y have no luck with cell phones. 6 Lumia 920s and now 2 G2's
    10-01-2013 09:59 AM

Similar Threads

  1. Replies: 2
    Last Post: 01-21-2015, 05:37 AM
  2. Trying decide on a new phone.....any insight is appreciated.
    By sprocket2107 in forum General Help and How To
    Replies: 3
    Last Post: 09-24-2013, 03:46 PM
  3. Replies: 1
    Last Post: 09-24-2013, 03:32 PM
  4. Replies: 0
    Last Post: 09-24-2013, 03:17 PM
  5. iMessage issues after switching from 4S to Droid Razr M
    By Michael Van Veghten in forum Droid RAZR M
    Replies: 1
    Last Post: 09-24-2013, 02:41 PM
LINK TO POST COPIED TO CLIPBOARD