1. backslap's Avatar
    Hi All,

    I've updated my device on 21 MAR with a Nightly update. The install went well. No problems. Yesterday I rebooted my device for the first time since this update and it got stuck op the LG splash screen.

    I have tried wiping everything. No result. Unfortunately I wasnt able to try and restore my backup, I saved it on the PC and deleted it from the phone for more storage space.

    And this is exactly the problem I'm facing. Eversince I got the phone, I've never been able to connect it to my PC. It did connect to my work PC, but only from inside Cyanogenmod. Now that I cant access CM I cannot connect the phone to PC anymore. It keeps giving the same error: MTP USB Device: Failed

    I've tried installing, uninstalling, re-installing LG drivers, I've tried LG Mobile Support Tool, I've tried renaming the C:\windows\inf\WPDMTP.inf, I've tried, conversely, selecting this inf for the MTP installation, I've tried connecting with ADB Sideloader: No connection possible.

    If I could only get the phone recognized as a USB drive by any computer I could flash a new ROM and go from there, but I'm running out of options...

    Any help is much appreciated!
    03-24-2014 02:02 PM
  2. jmillertime86's Avatar
    What about them menova micro sd adaptor things, worth a try putting a rom on an sd card and trying that, not sure if it will work though. Gotta be worth $10 to try

    Posted via Android Central App
    03-24-2014 02:31 PM
  3. SactoKingsFan's Avatar
    Can you enter download mode?

    (Long press volume up + connect USB from computer to phone)

    If you can enter download mode, then you can flash the stock D802 firmware using LG flash tool.

    Sent from my LG-G2 running Carbon 4.4.2
    03-24-2014 07:31 PM
  4. backslap's Avatar
    J Miller: Thanks for the suggestion, but I need to connect a PC to push the firmware over to the phone.

    SactoKings: Thanks. I can get the phone in D/L mode no problem, but also in D/L mode it will not connect properly to the PC:

    It tries to install the following:
    • USB Composite - OK
    • LGE Andoid USB Serial Port (COM5) - OK
    • CDC Serial / USB Modem - FAIL

    Then, when I start the Flash tool with the phone connected it says: LG USB / Parallel Lock Key not detected.

    I've also tried connecting the phone on another PC at work, but that doesnt recognize the phone either. Maybe it's because they're all Windows 7.

    Any suggestions?

    *EDIT: Is it true that other versions of Windows might have less trouble detecting the phone? SHould I take the trouble to make a double boot WindowsXP on my PC?
    03-25-2014 06:34 AM
  5. SactoKingsFan's Avatar
    I've only heard of an issue with Windows 8. I have Windows 7 and haven't had any issues using flash tool. You probably need to install the correct LG drivers or didn't unlock flash tool.

    This YouTube video has a link in description to LG drivers. And the Megalock DLL file will unlock flash tool if that's the issue.

    This guide has the files required to restore international G2.


    Sent from my LG-G2 running Carbon 4.4.2
    backslap likes this.
    03-25-2014 11:51 AM
  6. SactoKingsFan's Avatar
    Just saw that you have the serial port set to COM 5. Try changing it to COM 41 in device manager.

    Sent from my LG-G2 running Carbon 4.4.2
    03-25-2014 12:12 PM
  7. backslap's Avatar
    Yeah, I saw that in the video!

    I don't get to that part though. Because the CDC Serial refuses to install there is no access to the phone unfortunately.

    I have now tried with different drivers as well (as per this thread: How to install LG G2 drivers - Page 3 - xda-developers ) but neither the standard, nor the verizon drivers work.

    This is so frustrating. All I need is either the CDC, or the MTP driver to work.

    Any suggestions will be much appreciated.
    Leonard Lumasoc likes this.
    03-25-2014 04:17 PM
  8. backslap's Avatar
    Hi All,

    I did it!

    If you run into this nasty prblem, just follow the description in the last post on here: How to install LG G2 drivers - Page 3 - xda-developers

    Get the KOUSH ADB driver: Koush

    After days of searching this is the only solution that got my phone to connect to the computer. Completely rediculous, but I'm all the happier for it!

    Thanks guys for your help.
    03-27-2014 02:52 PM
  9. Shahzaib anjum's Avatar
    I tried to flash my lg g2 D802 using the KDZ method but the lg flash tool crashed halfway and now my g2 is stuck on the lg logo with no download mode and with no adb device found and it doesn't factory reset & it doesn't turn off if if try to power it off it starts back again, please help thankyou in advance.
    03-09-2015 07:13 AM
  10. backslap's Avatar
    I'm back.

    I just tried to install Lollipop on my LG G2 as instructed on "naldotech" website (can't post the link for some reason...)

    The phone was recognized as usual and the installation started.

    At about 50% though, the installation aborted.

    Now, when I turn my phone on, all it does is go into download mode, which would be OK if it got recognized by the PC... but it doesn't... Even with KOOSH drivers the phone does not get recognized, instead it gives error" device could not be started"

    How to proceed please?
    05-31-2015 01:14 PM
  11. runninsavvy's Avatar
    I'm in the same boat as you, all my phone can do is go into download mode, but its not ACTUALLY download mode since it doesn't get recognized by the computer, it just tries to install the MTP drivers, fails, and then the flash stock tool doesn't work or anything. I can't reset or put it into recovery either. Like I said, all it does is go to Firmware Update screen no matter what I do.
    06-16-2015 10:17 PM
  12. Octavio Gonzalez's Avatar
    I have the same symptom on my phone, its in "firmware update mode no matter what" cannot access reocvery mode but only a Factory reset thing; also after doing that immediately runs again into "firmware update" LG Mobile tool doesn recognize the phone; any ideas?
    06-17-2015 02:02 PM
  13. Hammadgen's Avatar
    I have the same symptom on my phone, its in "firmware update mode no matter what" cannot access reocvery mode but only a Factory reset thing; also after doing that immediately runs again into "firmware update" LG Mobile tool doesn recognize the phone; any ideas?
    Activate Windows update .restart your pc and then connect your g2 ..........or change your usb cable .....
    09-13-2015 12:49 PM
  14. trcpkjo's Avatar
    hello I came across your post in my attempt to unbrick my LG Optimus Exceed 2 it made me think I should try the LG Mobile repair manager again I was using an old version. as I was sitting watching the LG Mobile repair tool froze at 20% repair again, I dropped the phone and the battery popped and the repair installed and went to 100% and completed and I am up and going again. Just thought you might like to try this.
    02-02-2016 10:50 PM

Similar Threads

  1. S4 Weather Widget Playing Up Since Update
    By Andy Birkett in forum Android 4.4 KitKat
    Replies: 2
    Last Post: 01-28-2015, 05:19 AM
  2. Replies: 2
    Last Post: 03-31-2014, 06:15 AM
  3. HTC One 4.4.2 update download unsuccessful
    By HTCOne98 in forum HTC One M7
    Replies: 1
    Last Post: 03-29-2014, 12:00 PM
  4. Replies: 1
    Last Post: 03-25-2014, 09:11 AM
  5. Which phone should I buy?
    By XtrGamer123 in forum General Help and How To
    Replies: 3
    Last Post: 03-24-2014, 02:21 PM