1. richardm0806's Avatar
    Hello all, I am new to posting, but I browse these and other forums a lot. I have done a lot of rooting ect. but nothing too major. I've been able to fix soft bricks before but at this point I'm stuck. I have not seen any other post with a situation like mine, and having my phone bricked for a month has finally cracked me down enough to make a post. I have an LG G2 with the sprint network, I had rooted it, put a custom recovery (TWRP) as well as a custom rom. When I didn't like it and tried to go back, I guess i wiped something wrong and my backups and rom was gone. TWRP didn't help much, until I bought an OTG cable to read an external memory card and from there I was able to load another recovery, but again something went wrong and I had bricked it so I could only access fastboot mode. Through fastboot mode, I was able to flash everything completely stock, but I still have no rom on there. Now I'm stuck with stock recovery and when I try to enter download mode it takes me to a firmware update screen and neither fastboot nor adb sees any devices. When I plug the phone it it gives me the chime to show that its connected and when I install other different drivers it still installs the phone. I am stuck and not sure what else to do, any ideas? Thank you in advance.
    06-20-2014 08:36 AM
  2. Golfdriver97's Avatar
    Have you tried updating your drivers for your PC?
    06-20-2014 09:16 AM
  3. richardm0806's Avatar
    Yes, I've gone through many different drivers even some for other networks.
    06-20-2014 09:24 AM
  4. Golfdriver97's Avatar
    Not sure what else to suggest. You can look into a JTAG service, but I have never done anything lime that before.

    Signed, XenonRom, Nexus 5 and AC Forums App
    06-20-2014 11:54 AM
  5. Seeker03's Avatar
    Check out mobiletechvideos.com. Don't be thrown by their name. My boyfriend had bricked my s3 [ now retired ] w/ an international rom. We found this site sent in my phone and got it back within a week. Still works 'till this day! And yes, they do repair bricked LG G2's. Good luck!
    Update: I didn't take out of phone after I turned it off. Next thing I know, I'm bricked The above method was the only one that I knew of. After alot of reading on xda - 2days worth!-I found what worked for me. Give this a try.

    If you can get into download mode by holding Vol Up and then connecting a USB cable (while the device is off) then this method will work for you.


    1. Download the above Zip and extract it to a folder on your Desktop called "LG G2 Stock" (or whatever you prefer to name it).

    2. Install LGUnitedMobileDriver from "LG G2 Stock" Folder

    3. Install Setup_LGFlashTool from "LG G2 Stock" Folder (You will get a log in error if you try to open it)

    4. Extract MegaLock.zip from the "LG G2 Stock" Folder to C:\LG\LGFlashTool and overwrite existing MegaLock.dll file. This gets around the Log in Error you got before when you tried to open it.

    6. Put phone in Download mode by holding Volume up for a couple seconds and then plugging the phone in via USB.

    7. Go to Windows Start Menu and under "search programs and files" type "device manager" and open it up.

    8. Go to Ports (COM & LPT). You should see LGE AndroidNet etc... Right click it and go to Properties > Port Settings > Advanced > Change COM Port Number to COM41 > OK > OK > Close Device Manager

    9. You should have a LGFlashTool shortcut on your desktop. Double Click it to open it up.

    10. In the Model Config that opens up Select Manual Mode in top left.

    11. For DLL browse to "LG G2 Stock" folder and select LGLS980_20130904_LGFLASHv151.dll file

    12. For S/W browse to "LG G2 Stock" Folder and select LS980ZV7_01.tot file

    13. Hit OK and then click the Yellow Arrow in top left of LG Flash Tool. Wait for it to say "READY!!"

    14. Unplug your phone and power it off (it may reboot before you can power it off).

    15. Go back into download mode and the stock ROM will start flashing on it's own. It should take no more than 10 minutes. It may stop around 80% but your phone will say 100% and reboot and Presto! Back to stock or unbricked! (Whichever you were trying to do)
    Add Thank You Quote this message in a reply
    [+] 1 user says Thank You to Red_Kamel for this post

    Make sure sure you have winzip or something similar to extract once downloaded.Also be aware if you're on 4.4.2, that this will put you back in the land of jellybean 4.2.2. You'll lose root if you have it but you can get it back with iroot.FOLLOW THIS FIX TO THE LETTER!! Best of luck!
    06-24-2014 11:59 AM

Similar Threads

  1. LG LU6200 Hard Bricked
    By AC Question in forum Ask a Question
    Replies: 2
    Last Post: 08-09-2015, 01:03 AM
  2. [FREE] My Alarm Clock: beautiful, reliable, versatile
    By BrianLester in forum Android Apps
    Replies: 1
    Last Post: 06-21-2014, 04:08 AM
  3. Replies: 1
    Last Post: 06-20-2014, 10:21 AM
  4. Can I change my phone's ip address?
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 06-20-2014, 09:44 AM
  5. my phone
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 06-20-2014, 12:48 AM