1. OhAlfie's Avatar
    Up until this last week or so, when I use my SUV's NAV/Phone system to make phone calls, it worked fine. Meaning if I told it to "Call Mom" it would acknowledge and start dialing. Perfect.

    Suddenly last week when I'd try to do the same call, it started to tell me "There are two numbers associated with Mom, please choose which one to use" and then the screen shows the exact same number twice and makes me pick one of the two before it calls.

    So all I can gather is this darn Google Contact and AT&T Address Book is mucking things up somehow. So how can I get my contacts back in order to where I just have one of each of the contacts vs. when I go in to edit any contact I'm finding BOTH a Google version and ATT Address Book version of the same contact? There has to be a way to clean this all back up.

    07-20-2015 09:19 AM
  2. anon(9555426)'s Avatar
    There apps out there that will clean up your contacts if you have duplicates, I think CC Cleaner has one actually. If it was CC cleaner the one I used once also allowed you to merge the duplicates. I would just try a few out. My phones sometimes recognised +44 an area code and 07 for different numbers and so contacts.
    07-21-2015 09:08 AM
  3. Crashdamage's Avatar
    IMHO you should consolidate all your contacts to your Google account. This gives you an online backup and makes restoring or transferring contacts to a new device super simple. And you'll never lose your contacts.

    To do it follow these steps:

    1. On the phone, export the AT&T contacts as a .vcf file.

    2. Go to Settings > Accounts > Google > Select your account > Disable contacts sync.

    3. Transfer the .vcf file to a computer for upload or you can do it from the phone using a browser. Be sure to make a backup copy!

    4. Login online to your Google (Gmail) account. Import the contacts file to the Gmail contacts.

    5. In online contacts, click on 'More' and select 'Merge duplicates'. Once the Merge is completed, you might want to go through the contacts manually to check for any necessary edits.

    6. To make sure the cleaned-up contacts list does not get corrupted by contacts remaining on the phone, go to: Settings > Apps > All > Google contacts > Clear cache > Clear data. This deletes all contacts on the phone.

    7. On the phone, enable contacts sync. Contacts should automatically sync to the phone.

    You are done. All your contacts should be in your Google account, cleaned up and backed up. Be sure to always save additions/deletions/edits to your contacts to your Google account.

    Android since v1.0. Linux user since 2001.
    07-21-2015 09:52 AM
  4. OhAlfie's Avatar

    But AT&T Address Book is still going to want to load contacts as well?? SO how do I stop that since it will put me right back to where I started..full of duplicates since the phone wants to load Google AND AT&T contacts.
    07-21-2015 01:31 PM
  5. Crashdamage's Avatar
    If you consolidate your contacts, you don't need the AT&T book anymore. So can't it be removed or disabled?

    Android since v1.0. Linux since 2001.
    07-21-2015 01:42 PM
  6. OhAlfie's Avatar
    I can't find a way to disable it.
    07-21-2015 03:55 PM
  7. Crashdamage's Avatar
    Then can you uninstall it? Delete the contacts in it? Maybe AT&T can tell you how to disable it, uninstall it or otherwise keep it from mucking up things again. There's gotta be a way...

    Android since v1.0. Linux since 2001.
    07-21-2015 04:01 PM
  8. UnlockedOnly's Avatar
    settings, contacts,click on the 3 dots upper right corner, select settings then select contacts to display........done !!!
    07-25-2015 11:05 PM
  9. Crashdamage's Avatar
    That only sets the contacts displayed in the contacts app. It won't affect the contacts called up by a search or dialing, which is the OP's problem.

    Android since v1.0. Linux since 2001.
    07-25-2015 11:17 PM
  10. shepette's Avatar
    Hello. I am having this same issue. I love Dragon Voice but whenever I use it to send texts on my Samsung Galaxy Note 5, it finds multiple mobile numbers for a contact and it asks me to choose one before continuing. If I open the Contact info on my phone, only one number is displayed. Was there ever a definitive answer for this issue? I removed the Linked Contact info on the phone itself but still have the setting for Google and the cloud. Presumably removing one of these will fix it? If yes, which one and why? Thanks everyone!
    11-07-2016 07:59 AM

Similar Threads

  1. How can I get my contacts to display in groups
    By AC Question in forum Ask a Question
    Replies: 2
    Last Post: 04-15-2016, 06:14 AM
  2. Why isn't my Google account responding on my Samsung S4?
    By AC Question in forum Samsung Galaxy S4
    Replies: 1
    Last Post: 07-20-2015, 12:16 PM
  3. How do I get out of the Android download?
    By acain7 in forum General Help and How To
    Replies: 2
    Last Post: 07-20-2015, 11:32 AM
  4. Why is my phone crap right now?
    By AC Question in forum General Help and How To
    Replies: 2
    Last Post: 07-20-2015, 11:31 AM
  5. Replies: 1
    Last Post: 07-20-2015, 09:14 AM