1. bobselby1949's Avatar
    I have a new LG G3 (With Qi !!) and need to block SMS messages from unknown numbers (ie any not in my contacts list).

    I have enabled "Block Spam" and "Block Unknown Number" but the darn things are still slipping through :-(

    Is this a "feature" of the G3 or a general issue with KitKat ???

    Has anyone found a workaround for this ???

    The service provider is Vodafone ad the G3 is fully up to date.
    TIA
    Bob
    11-11-2014 06:21 AM
  2. CliveEdinburgh's Avatar
    Try "calls Blacklist" & and ditch the stock message app & get handcent" message app. It has lots of security settings, ie text and call blocker. Been using them both for ages.

    Posted via the Android Central App
    11-11-2014 02:03 PM
  3. bobselby1949's Avatar
    Thanks, I'll try that.

    Is this a known problem on the G3 or with KitKat ???

    Bob
    11-12-2014 03:33 AM
  4. CliveEdinburgh's Avatar
    It's a hit and miss in Stock. The two I gave should work fine

    Posted via the Android Central App
    11-12-2014 09:24 AM
  5. Darkdeckard's Avatar
    You're right. The best option is an external app. I use another one and it runs quite well
    11-12-2014 10:08 AM
  6. bobselby1949's Avatar
    I tried "handCent" and setup the option to filter senders no in my contacts list - but I'm still getting the horrid things!
    11-13-2014 04:15 AM

Similar Threads

  1. Replies: 13
    Last Post: 03-12-2015, 04:33 PM
  2. Replies: 1
    Last Post: 11-11-2014, 08:11 PM
  3. Replies: 0
    Last Post: 11-11-2014, 03:25 AM
  4. Can't make GO SMS default txt app
    By Muppet Rat in forum Sony Xperia Z2
    Replies: 0
    Last Post: 11-11-2014, 02:41 AM
  5. Why I can't make voice call from Hangout?
    By tomghan in forum Android 4.1 / 4.2 / 4.3 Jelly Bean
    Replies: 0
    Last Post: 11-11-2014, 12:29 AM
LINK TO POST COPIED TO CLIPBOARD