1. Sometimes_Nerdy's Avatar
    I just bought the LG G3 recently and switched over from a lenovo phone. Didnt think i'd have any problems but ive been trying to get the stupid phone to connect to my laptop for the past 2 hours and nothing's working and at this point im extremely frustrated and tried.

    things to consider:
    already have PC suite.
    already installed the drivers at least 3 different times.
    restarted PC after installing drivers.

    Whenever I open LG PC Suite and look for devices it says no devices found and tells me i might need to reinstall driver, whenever i click on reinstall driver it says LG USB driver not found after which i click the reinstall button. after that a windows notification asking to authorization may or may not appear. Iv'e done this same thing over 10 times already (reinstalling driver through PC Suite) and every time after i reinstall through PC suite it says the same thing no usb driver found again also when the waiting animation for the reinstall driver finishes i dont get any message it just goes to the main screen for the PC suite which in this case is the music panel on the program.

    Also: My USB ports are completely fine.
    I tried this on a different laptop as well and it gave me the same error.

    Someone please help me asap and any input would be highly appreciated.

    Thank you.
    12-02-2014 09:07 PM
  2. Paul627g's Avatar
    Have you tried using a different USB cable?
    twofirstnames likes this.
    12-03-2014 09:08 AM
  3. Sometimes_Nerdy's Avatar
    Yeah I used the old USB cord from my lenovo and it still didnt work. I dont even get the notification on the phone to choose which mode i want to put it in so the phone doesn't recognize connection to a laptop either.
    12-03-2014 08:13 PM
  4. Paul627g's Avatar
    Do you have access to a friends computer or a different computer to try it out on? At least then got something to go from, possibly a hardware issue on the phone. Wondering if one of the pins in the USB connection was damaged or just not functioning to complete the data connection.
    12-04-2014 09:01 AM
  5. CliveEdinburgh's Avatar
    I hate these PC suites,try Airdroid from the play store. Does it wireless through your router,so easy.

    Posted via the Android Central App
    12-05-2014 02:39 PM
  6. rjf111's Avatar
    I use Amazon file manager to do wireless transfers between the phone and the computer. It picks up your PC network and finds your shared folders -- then copy and paste files to your folders on the phone (and vice versa).
    12-06-2014 04:34 AM
  7. Kvothe Bloodless's Avatar
    I am having this issue as well. I appreciate that everyone is trying to offer alternative programs, but I was not able to actually manage the files on my phone via my PC BEFORE installing the suite. You can simply plug your LG G3 into your computer and set it to MTP Media Sync and pull up the file explorer for the phone via Windows. I can do this, with or without the suite, however, when I try to move files, I get a window that says, <Phone Name> is busy. Please wait. After about 5 minutes, it gives me an error saying, <File> could not be moved/copied/deleted/etc.
    10-27-2015 08:18 PM
  8. JohnASmith's Avatar
    I have 2 LG G3 phones. Both have always connected to my PC but suddenly one refuses to. It makes all the right sounds but doesn't display in "My Computer" so I can't open folders. Both have the same OS Android 5.01. They do have some app variations so possibly one of them is causing issues. Has anyone figured this one out?
    12-12-2015 06:40 PM
  9. Lithoguy's Avatar
    Hello, I was having the same issue. After messing around a bit I first downloaded USB drivers from the LG website. 2) I then plugged my phone into the computer. then I messed with the USB tethering option in the settings in phone. I had to turn it on a couple of times and then wha la! the computer finally recognized the phone. I had to try this a couple of times but it finally worked. The phone wants to shut off the USB tethering for some reason. Maybe that is why the computer is not recognizing the phone.
    I hope this helps.
    05-12-2016 09:12 PM
  10. the Core's Avatar
    Hi all,

    Did you try to (re-)install the USB Drivers (Windows/Mac)?

    Also, make sure your USB connection type is set to MTP (media device) and the device is unlocked (enter your (knock) code).

    Even if the phone is turned off, Windows will make a sound if you connect the phone. That's just to tell something is connected. Your phone will probably charge then.

    For the ones like JohnASmith, you could try upgrading your phone to Marsmallow this way:
    1. turn off your phone
    2. keep holding the [volume up] button
    3. connect the phone to the computer with a USB cable
    4. After it has entered download mode, release the button
    5. Open LG PC Suite
    6. Go to "restore upgrade errors" in the menu bar
    7. Wait for an hour or so

      Cor
    05-14-2016 11:03 AM
  11. Wolverine2982's Avatar
    my phone went to firmware update immediately entering download mode. it is at 0% still after 10 minutes. any ideas?
    05-28-2016 02:00 PM
  12. yassineabd's Avatar
    Actually it seem that they want to do the same as Apple by blocking the ineterface wish is dum since they dont have something else!
    Installing USB ect will not change anything its a software related prob it just cant comunicate anymore and from few years company have been really bad doin update and ******* up the OS on smart phone! Industry pressur obligation and mistaken priorities so finally not much to do about it! Since nowadays Android act like Apple you actually have no way to deal with the bad programing! Soooo nope thats just **** like evertything else now goin out on a profit first market!
    05-29-2016 04:13 AM
  13. Calah's Avatar
    This worked for me, thank you so much!
    08-22-2016 11:15 AM
  14. Zuhaib Abid's Avatar
    Heres and simple way. That worked for me.
    Go to LG form and find your device. then install lg drivers.
    After installing drivers, it will automatically showing your drivers.
    12-01-2016 12:47 AM
  15. muhammad sami2's Avatar
    Try turning of dev mode
    12-09-2016 06:38 AM
  16. Dale E Hayes's Avatar
    Tethering
    Use Tethering to share your device’s Internet connection with a computer that connects to your device via USB tethering, Wi-Fi hotspot or by Bluetooth.

    Tap home key > Tools tools app icon > Settings settings app icon > Networks tab > Tethering.
    Select a tethering option: USB tethering, Wi-Fi hotspot or Bluetooth tethering.
    USB tethering: Allows other devices to connect to your phone via USB cable.
    Wi-Fi hotspot: Allows other devices to connect to your phone via Wi-Fi.
    Bluetooth: Pair your phone with the other device via Bluetooth.
    12-14-2016 02:11 PM
  17. QQQ3838's Avatar
    Hi Cor,
    My G3 was working well one month ago. Yesterday I use the USB Cable to connect to the PC LG Suite and it can not find the G3, I try re-install driver and reinstall the LG PC Suite and even reset the G3 to the factory setting, non was be able to find the G3 via USB cable. But it can use the Wifi connection. I try your suggesting by holding the volume uo button and then connect the USB cable, all I get is the battery charging logo and nothing else. I think the USB driver on the phone is gone.
    Then even worst, after reset the phone and now can not upgrade to the new software and the error message as bellow;
    This drvise is suspectrf inrooting, software upgrade is not available for rooting devise Err: 0X1125000.
    Can any one give suggestions on how to fix this problem?
    Thanks.
    12-19-2016 09:05 PM
  18. diandal's Avatar
    thank you for the link. downloaded usb driver and phone now connects. much appreciated.
    01-23-2017 06:38 AM
  19. twofirstnames's Avatar
    Using a different cable worked for me!

    I tried many other, more complicated things but it turns out the cable I was using was bad. Probably some cheap aftermarket thing that works with charging but not with syncing.

    After using a different cable, the PC and phone immediately acknowledged each other, and the phone instructed me to install new drivers for the PC. Did a few rounds of this and now everything works as it should.

    Strange that a certain cable can charge but not sync....
    03-03-2017 01:21 PM
  20. BagusAry13's Avatar
    Is your problem solved​. I have that problem too. Can you give solution ?
    04-26-2017 12:13 AM
  21. CeeStyle's Avatar
    It took me too long to just open my eyes and read but there is a pop-up that displays on the LG PC Suite that tells you:

    "For phone or tablet with Android 5.0 Lollipop or later,
    phone or tablet will not back up or restore properly due to security on Android.
    Refrain from use
    ."

    So basically, If you have Lollipop (5.0.x or above), The software won't work - whether you are in MTP mode or USB Download Mode. The question is: Why hasn't LG updated their software? This cost me a bunch of time but hopefully it will save someone else time.

    Sigh.. time for a new phone.
    11-02-2017 12:02 AM

Similar Threads

  1. Nexus 5: My lock screen changed somehow
    By ChuckG73 in forum Google Nexus 5
    Replies: 11
    Last Post: 05-12-2018, 07:24 PM
  2. Does my Galaxy S5 Sport Need a Case
    By dstone8484 in forum Samsung Galaxy S5 Accessories
    Replies: 3
    Last Post: 07-07-2015, 08:44 AM
  3. (Nexus 4) Can't unlock phone, randomly
    By purepolygon in forum Android 5.0 Lollipop
    Replies: 4
    Last Post: 12-08-2014, 10:24 PM
  4. Remember the LG GD910 and Samsung S9110?
    By Active55 in forum Samsung Gear S
    Replies: 3
    Last Post: 12-03-2014, 04:17 PM
  5. Why can't I send text message on my new Galaxy S5?
    By mhgamer890 in forum Samsung Galaxy S5
    Replies: 1
    Last Post: 12-03-2014, 08:42 AM
LINK TO POST COPIED TO CLIPBOARD