1. SammieLoran's Avatar
    Every time I connect my LG G3 to my desktop computer via USB, I receive a pop up stating that "the device software was not successfully installed" and the device is not recognized under Computer on my desktop.
    12-26-2014 10:00 AM
  2. xocomaox's Avatar
    Depending on your phone model, you should find and install the appropriate driver:

    Download LG G3 Drivers! | Android Drivers!

    Let us know if this does not help your situation.
    12-26-2014 10:20 AM
  3. SammieLoran's Avatar
    That didn't help. It still gives me the same message. After clicking on the message it says that the MTP USB Device Failed.
    12-26-2014 10:54 AM
  4. xocomaox's Avatar
    When your phone is connected via USB, on the phone pull down the Notification shade and select the USB Connected As notification and change it to Camera PTP.
    12-26-2014 12:33 PM
  5. SammieLoran's Avatar
    It comes up with the same error when I do that.
    12-26-2014 03:22 PM
  6. xocomaox's Avatar
    What Operating System are you running on your computer? And did you have the G3 disconnected from the computer during the driver install?
    12-26-2014 03:25 PM
  7. SammieLoran's Avatar
    It is Windows 7 and I I am pretty sure that the G3 was disconnected during the install but I am not positive.
    12-26-2014 03:58 PM
  8. CliveEdinburgh's Avatar
    Easier option, try Airdroid from play store.

    Posted via the Android Central App
    12-27-2014 07:10 AM
  9. RoadDawgBob's Avatar
    Try Airdroid. It's a great program. You'll love it.
    12-30-2014 06:51 PM

Similar Threads

  1. Replies: 6
    Last Post: 10-26-2016, 05:12 PM
  2. Replies: 3
    Last Post: 12-27-2014, 12:20 PM
  3. Replies: 2
    Last Post: 12-27-2014, 06:25 AM
  4. Why is my GS4 charging incredibly slow?
    By Emb0505 in forum Samsung Galaxy S4
    Replies: 1
    Last Post: 12-27-2014, 04:01 AM
  5. Can I use Android Central's News feeds on my website?
    By Nitish Gongala in forum Ask a Question
    Replies: 2
    Last Post: 12-26-2014, 12:49 PM