1. tardus's Avatar
    The first thing I noticed after upgrading to Lollipop was the "Quiet" on the notification taskbar has been replaced by the three way toggle - "Do Not Disturb", "Sound", and "Vibrate". I can't get alarm as a priority to work. In other words, when in Do Not Disturb mode - how is alarm set as a priority? At night I don't want to be disturbed by calls, text messages, etc but do need to hear the alarm when it goes off!

    Edit: I see you can set do not disturb times - for example 11PM to 7AM next day, but there is only one setting. So you could set it for M-F and leave the weekend uncovered, but what if you want, for example:
    11PM to 7AM Monday Thurs Friday
    11PM to 9AM Tuesday Wednesday
    2AM to 10AM Saturday and Sunday

    Not so granular unless I'm missing something.
    04-13-2015 10:40 AM
  2. tardus's Avatar
    It appears to be a bug in 5.01 - in "Do Not Disturb" mode the alarms don't have priority - are blocked. Things should get better in 5.1. And when 5.1 will drop on T-Mobile for the G3 is anyone's guess.
    04-14-2015 09:03 AM
  3. dusterdude's Avatar
    on my d850,i have to go into settings,then sounds,then do not disturb,hit priorty only.that takes care of it.i do think you have to make your alarm a priority
    04-14-2015 11:36 AM
  4. Robnfl's Avatar
    My AT&T 851 has the same issue after upgrading to 5.0.1. The alarm doesn't sound in do-not-disturb/silent mode. If I use "priority only", then the phone still beeps when the battery is full, plus other notifications come through, even though they are turned off. The wife and I have used our phones for an alarm for years, but now that isn't possible.

    Time for an S6 or iphone 6!!!

    Rob
    04-28-2015 12:46 PM
  5. justafew's Avatar
    This has been updated in Android 5.1, but I expect a few months before the G3 gets that version. There are a few options to get around this in the meantime.

    1) Instead of clicking on the Sound button in the notification panel (which toggles between Silent/Vibrate/Sound), just hit your volume button up or down. A window will pop up and you can then choose Silent/Do Not Disturb from there. That method will give you an option to set the amount of time you want the Do Not Disturb to be on. So if you know your Alarm is set for 8.5 hours from now, set that to 8 hours so you know your alarm won't be disabled anymore.

    2) An even better option is to go into Settings/Sound/Do Not Disturb and set up a schedule. For example, I have my Do Not Disturb schedule from 10:00 p.m. - 7:00 a.m. You can set Priority Calls or Messages to override the DND if you like. But regardless, alarms are not impacted by this schedule. It blocks all notifications, unless you choose the Priority options, but yet your alarm will still sound even if within that window. My alarm is typically at 6 each morning and it goes off w/o a hitch using this schedule.

    While not ideal (an option for Silent to not block alarms would be better), at least they are better than nothing.
    tardus likes this.
    04-29-2015 12:39 PM
  6. Claire James's Avatar
    omigosh how f'ing annoying is this. I was late for work this morning because my phone was constantly vibrating with notification alerts at 1am, so my daughter disabled the vibration using do not disturb and my s*dding alarm didn't go off. It's outrageous that this isn't easier to sort out. OBVIOUSLY you want a 1 hit button to silence your phone for nightime, cinema, theatre etc that disables all sound EXCEPT the alarm. The current setup is waaaaaaaaaaaaaaaaaaaaaay more complicated than is needed and impossible to get it to do what is needed.
    tomab21 likes this.
    08-13-2015 07:10 AM
  7. some2's Avatar
    This is ridiculous ... SUCKS!!! I have the LG Spirit h440n and this whole thing sucks!!! I have the 5 0 1 lollipop now? Will I ever get the 5 1 0 or something like that where this creepy alarm thing is fixed ???

    dusterdude's method works, but needs to be done over and over again every single time, because once you exit Sound more or DND mode, then the settings get reset to default, meaning that you have to go back and set it to 'Priority Only'
    10-25-2015 07:42 AM
  8. Hayley_Mills's Avatar
    I am sure you have all figured this out since the original discussion started @ the end of 2015. However, I'm going post how to fix this problem in case anyone is now or will be later asking the same info.
    1. Select sounds
    2. Scroll down to find the "Do not Disturb" that follow with dots (meaning oh can personalize)
    3.once you click that, you will come to another screen with an option to Select your schedules. I set several ones for different days that changes when I don't need up so early. Schedule your schedule(s).
    4. Go back to previous page and select "priorities". Here it allows you to allow certain calls come in.
    5.Now go back a screen again and select notifications. This option allows you to add certain notifications to ignore "Do not Disturb" and alarm is indeed included in the list.
    You're all set. Just make sure to enable "Do not Disturb"
    06-10-2017 02:31 AM
  9. PhoneKween's Avatar
    I am sure you have all figured this out since the original discussion started @ the end of 2015. However, I'm going post how to fix this problem in case anyone is now or will be later asking the same info.
    1. Select sounds
    2. Scroll down to find the "Do not Disturb" that follow with dots (meaning oh can personalize)
    3.once you click that, you will come to another screen with an option to Select your schedules. I set several ones for different days that changes when I don't need up so early. Schedule your schedule(s).
    4. Go back to previous page and select "priorities". Here it allows you to allow certain calls come in.
    5.Now go back a screen again and select notifications. This option allows you to add certain notifications to ignore "Do not Disturb" and alarm is indeed included in the list.
    You're all set. Just make sure to enable "Do not Disturb"
    04-15-2018 08:14 AM
  10. PhoneKween's Avatar
    This is exactly what DOESN'T work. Has anyone found a fix for this yet?
    04-15-2018 08:15 AM

Similar Threads

  1. How do I get the Charge Boost screen to appear when charging my Note 4?
    By AC Question in forum Samsung Galaxy Note 4
    Replies: 13
    Last Post: 02-10-2017, 10:30 AM
  2. KNOX Mode
    By elyeh in forum Samsung Galaxy S5
    Replies: 2
    Last Post: 04-19-2015, 10:39 AM
  3. Notification sounds sometimes not firing?
    By Alex Dobie in forum HTC One M9
    Replies: 2
    Last Post: 04-13-2015, 01:21 PM
  4. G4 is not that much bigger than G3
    By illdini in forum LG G4
    Replies: 2
    Last Post: 04-13-2015, 11:25 AM
LINK TO POST COPIED TO CLIPBOARD