1. mcortes512's Avatar
    I just got the LG G3 and I can't connect to the WiFi at my work. Every time I try to connect it says Avoided poor Internet connection. I read some forums and this is what I've tried:
    1- turn off phone and turn it back on
    2- turn off phone, remove battery wait 30 seconds, replace battery and restart.
    3- tried switching from DHCP to Static and retyping IP address
    3- Read some forums- tried to find the misc/dhcp files to delete like many forums said but can't find them
    4- checked all my advanced settings to make sure I didn't have something checked that would prevent me from connecting.
    5- I know it WILL connect to WiFi because i can connect at home.
    6- The WiFi at my work has allowed me to connect me previous phone Samsung Galaxy S4 as well as my kindle.
    7- The WiFi at my work DOES require a login once you are connected but i can't even get to that step.
    8- I connected to another network this weekend that was a public network requiring login without any problems.
    9- I've read that I can access the dhcp files by rooting but scared to Root because I don't know that much about it and don't want to screw something up.
    9b- I did go into my device settings and unlock my developer options. Haven't done much past that.
    10- I'd really love to NOT to a factory hard reset.
    10b- I will if I have to because I've got to connect to WiFi at work to avoid using up all my data in the first two weeks of my billing cycle.

    I'm currently running KitKat Android 4.2
    Haven't updated to lollipop yet.

    Any help would be great
    04-14-2015 02:16 PM
  2. Melfunn's Avatar
    Are there any firewalls you have to go thru at work? Maybe ask other android owners how their phones are setup.

    Sent from my VS985 4G using Tapatalk
    mcortes512 likes this.
    04-14-2015 03:25 PM
  3. mcortes512's Avatar
    Several other android users are able to get access. I'm sure there is a firewall because I am a teacher. Thanks for the thought though.
    04-14-2015 05:36 PM
  4. mcortes512's Avatar
    --Update---
    I updated my software to lollipop and it didn't have any impact on this issue.
    04-14-2015 05:37 PM
  5. durango992007's Avatar
    Something really dumb, but has worked for me in the past, forget the network, then try it again.

    Posted via the Android Central App
    04-14-2015 06:28 PM

Similar Threads

  1. Why won't my Lollipop update download?
    By AC Question in forum Android 5.0 Lollipop
    Replies: 2
    Last Post: 04-15-2015, 10:25 PM
  2. I have the Samsang Galaxy 5 and my ringtone goes in and out
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 04-14-2015, 06:38 PM
  3. Why won't my phone go into recovery mode?
    By AC Question in forum Lenovo Android Phones
    Replies: 2
    Last Post: 04-14-2015, 05:01 PM
  4. Galaxy S6 - Possible to Skip Verizon's Activation Process?
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 04-14-2015, 03:43 PM
  5. URGENT - Can you recover lost photos?
    By connor_kelly645 in forum HTC One M8
    Replies: 2
    Last Post: 04-14-2015, 02:21 PM
LINK TO POST COPIED TO CLIPBOARD