1. mkchillin's Avatar
    I can't unroot my AT&T G4. I downloaded the files and when I follow the steps, it gets stuck at 60% and says the phone is disconnected from the PC and won't finish the process. I've reset my phone, I wish to flash stock firmware or remove the root in any other way. I tried to do it via Super SU too and it won't work that way either.
    09-24-2015 01:25 AM
  2. AndroidHabit's Avatar
    Why are you trying to unroot?
    09-24-2015 01:38 AM
  3. mkchillin's Avatar
    My phone was malfunctioning when rooted and I want my phone to be able to receive updates and have full, smooth functionality.
    09-24-2015 01:40 AM
  4. AndroidHabit's Avatar
    What did you do to make it malfunction?
    Root wont cause that unless you remove or edit something you shouldn't have.
    09-24-2015 01:43 AM
  5. mkchillin's Avatar
    I don't know for sure, I used Xposed and did some modding and the phone would sometimes restart on it's own, and frequently have to upgrade all the hundreds of apps when restarting. Furthermore, the phone as a whole was full of stutter and choppiness. I've already factory reseted my phone and like it this way but I want to unroot entirely so that's what I am here to discuss.
    09-24-2015 01:46 AM
  6. AndroidHabit's Avatar
    Also didn't you know you shouldnt take OTA updates while rooted, unless you flash the updates yourself.
    SuperSU should have no problem removing root and then after that just do a factory reset.
    Just to be clear, you are not trying to send this to AT&T for service right?
    They don't waste time checking for root anyways, trust me I sent two G3's with root.
    09-24-2015 01:46 AM
  7. mkchillin's Avatar
    When I hit unroot on SuperSU it spins and says please wait but after a while it doesn't do anything, how long should I expect it to take? I'm notbsensing it to ATT, I'm keeping it.
    09-24-2015 01:49 AM
  8. AndroidHabit's Avatar
    I would let it sit and finish, it is just taking a while to remove root.
    You can also try LG's firmware tool and update it through there.
    It should give you the latest AT&T software.
    Try unrooting it first though.
    09-24-2015 01:56 AM
  9. mkchillin's Avatar
    Just worked, thank you.
    09-24-2015 02:00 AM
  10. AndroidHabit's Avatar
    What worked, SuperSU unrooting or LG Tool?
    09-24-2015 02:12 AM
  11. anon(782252)'s Avatar
    If you thought Xposed or one of the modules was the problem, why not just run the Xposed uninstaller?

    And if you wanted to kill everything, why not just flash the stock image in download mode?
    09-24-2015 07:42 AM
  12. dungoyle's Avatar
    Just worked, thank you.
    What worked, SuperSU unrooting or LG Tool?
    @mkchillin, it would help the community to have an answer here. Also, who is you carrier?
    10-26-2015 05:35 PM

Similar Threads

  1. Replies: 4
    Last Post: 09-24-2015, 04:03 PM
  2. My Samsung Pay Experience, Nearly Perfect!
    By srz1977 in forum Samsung Pay
    Replies: 1
    Last Post: 09-24-2015, 09:34 AM
  3. Replies: 1
    Last Post: 09-24-2015, 02:37 AM
  4. I Can't access my Gmail account in my samsung s5830 android
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 09-24-2015, 02:36 AM
  5. Replies: 1
    Last Post: 09-24-2015, 12:09 AM
LINK TO POST COPIED TO CLIPBOARD